Package ethernet implements marshaling and unmarshaling of IEEE 802.3 Ethernet II frames and IEEE 802.1Q VLAN tags. MIT Licensed.
☆289Feb 21, 2022Updated 4 years ago
Alternatives and similar repositories for ethernet
Users that are interested in ethernet are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.☆423Feb 21, 2022Updated 4 years ago
- Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.☆391Sep 23, 2026Updated last month
- Package block enables programmatic access to block devices. MIT Licensed.☆22Oct 25, 2018Updated 8 years ago
- Package dhcp6 implements a DHCPv6 server, as described in RFC 3315. MIT Licensed.☆80Feb 24, 2023Updated 3 years ago
- Package xdp provides access to Linux userspace XDP sockets (AF_XDP). MIT Licensed.☆40Mar 7, 2019Updated 7 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Package packet provides access to Linux packet sockets (AF_PACKET). MIT Licensed.☆108Sep 12, 2026Updated last month
- Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK). MIT Licensed.☆1,086Oct 14, 2026Updated 2 weeks ago
- Package wifi provides access to IEEE 802.11 WiFi device actions and statistics. MIT Licensed.☆322Oct 1, 2026Updated 3 weeks ago
- Provides packet processing capabilities for Go☆6,798Mar 19, 2025Updated last year
- Package genetlink implements generic netlink interactions and data types. MIT Licensed.☆67Jun 3, 2026Updated 4 months ago
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆238Oct 16, 2026Updated 2 weeks ago
- Package socket provides a low-level network connection type which integrates with Go's runtime network poller to provide asynchronous I/O…☆101Oct 12, 2026Updated 2 weeks ago
- eBPF Utilities, Maps, and more☆254Mar 15, 2023Updated 3 years ago
- Package tftp implements a TFTP server, as described in RFC 1350. MIT Licensed.☆11Jun 19, 2015Updated 11 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- xoshiro256** random number generator☆22May 7, 2018Updated 8 years ago
- Go implementation of Linux Network Block Devices☆140Aug 12, 2024Updated 2 years ago
- A Go package for sending and receiving ethernet frames. Currently supporting Linux, Freebsd, and OS X.☆82Apr 5, 2016Updated 10 years ago
- Package wol implements a Wake-on-LAN client. MIT Licensed.☆116Feb 21, 2022Updated 4 years ago
- Package wgdynamic implements a client and server for the the wg-dynamic protocol. MIT Licensed.☆13Feb 25, 2023Updated 3 years ago
- Linux networking in Go☆598Aug 8, 2020Updated 6 years ago
- Calculate average score and rating based on Wilson Score Equation☆17Aug 5, 2017Updated 9 years ago
- An example ReadMe file for Go libraries.☆22Feb 11, 2017Updated 9 years ago
- Cross-platform OpenGL bindings in Go.☆18Jun 21, 2024Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- IPv4 and IPv6 userland network stack☆3,111Dec 10, 2019Updated 6 years ago
- Libraries for parsing and constructing common network packets.☆69Apr 4, 2016Updated 10 years ago
- DHCPv6 and DHCPv4 packet library, client and server written in Go☆849Oct 14, 2026Updated 2 weeks ago
- Package mptcp provides detection functionality for active, multipath TCP connections from a remote client to the current host. MIT Licen…☆17May 19, 2015Updated 11 years ago
- ☆17Oct 24, 2017Updated 9 years ago
- Generates a GitHub issue description for go-fuzz findings☆11Dec 3, 2015Updated 10 years ago
- A simple TUN/TAP library written in native Go.☆2,168Jul 30, 2024Updated 2 years ago
- Cross-platform Go library to place an icon in the host operating system's taskbar☆15Sep 19, 2014Updated 12 years ago
- Package aoe implements an ATA over Ethernet server, as described in the AoEr11 specification. MIT Licensed.☆13Nov 7, 2016Updated 9 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- BGP implemented in the Go Programming Language☆4,117Updated this week
- Zero-copy sockets for Linux in Golang☆830Jul 7, 2020Updated 6 years ago
- Older version of periph, see new version at https://github.com/periph☆1,731May 29, 2022Updated 4 years ago
- github.com/cznic/file has moved to modernc.org/file☆57Nov 22, 2018Updated 7 years ago
- Package smbios provides detection and access to System Management BIOS (SMBIOS) and Desktop Management Interface (DMI) data and structure…☆174Mar 31, 2023Updated 3 years ago
- Package sdnotify implements systemd readiness notifications as described in https://www.freedesktop.org/software/systemd/man/sd_notify.ht…☆46Apr 6, 2022Updated 4 years ago
- Simple netlink library for go.☆3,321Updated this week