Golang (X)ChaCha20 stream cipher. (Mirror)
☆63May 2, 2023Updated 3 years ago
Alternatives and similar repositories for chacha20
Users that are interested in chacha20 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A golang implementation of djb's chacha20 cipher☆14Dec 1, 2016Updated 9 years ago
- High Assurance Cryptographic Software☆10Sep 1, 2026Updated 2 months ago
- Chacha20Poly1305 AEAD☆17Mar 15, 2015Updated 11 years ago
- ChaCha20Poly1305 and XChaCha20Poly1305 AEAD implementations☆21Nov 24, 2020Updated 5 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- ☆21Dec 16, 2022Updated 3 years ago
- [work in progress] Python framework for supporting cryptographic game-hopping proofs☆13Oct 19, 2022Updated 4 years ago
- A pure Go implementation of the ChaCha20 stream cipher.☆45Nov 7, 2015Updated 11 years ago
- A blake2s java implementation☆19Jan 31, 2016Updated 10 years ago
- ChaCha20 and XChaCha20 stream ciphers☆75Jul 9, 2018Updated 8 years ago
- A statistic driven minecraft killaura detection KI☆10Mar 23, 2017Updated 9 years ago
- ☆14Apr 14, 2025Updated last year
- CBOR Information Resources☆14Feb 16, 2026Updated 8 months ago
- naive bayes based text classifier, machine learning☆11Feb 18, 2013Updated 13 years ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- Implementations of do255e and do255s in C and assembly☆26May 3, 2021Updated 5 years ago
- Authenticated encryption for streams in Go☆31Jun 30, 2026Updated 4 months ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- A cryptographically secure pseudorandom number generator cli tool printing in a wide variety of byte encodings (hex, base64,..) and for m…☆15Sep 25, 2023Updated 3 years ago
- Official SQISignHD code, version under continuous development.☆13Jul 18, 2025Updated last year
- Implementation of the single-step key derivation function (KDF) as described in NIST Special Publication 800-56C Rev1 supporting messages…☆10Oct 5, 2026Updated last month
- An efficient memset implementation for Golang. [Not maintained].☆32Sep 4, 2019Updated 7 years ago
- ☆17Updated this week
- Chacha20 in Javascript☆24Apr 15, 2021Updated 5 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Post-quantum Wireguard (Theory)☆12Sep 9, 2020Updated 6 years ago
- CDLS: Proving Knowledge of Committed Discrete Logarithms with Soundness☆12Apr 30, 2026Updated 6 months ago
- A minimal RedJubjub implementation for use in Zebra.☆30Sep 25, 2026Updated last month
- A pure Java implementation of BLAKE2 (RFC 7693)☆14Sep 12, 2023Updated 3 years ago
- Quick-n-dirty standalone Java implementation of ChaCha20 (256-bit key, 64- or 96-bit nonce)☆23Sep 25, 2020Updated 6 years ago
- XMSS (eXtended Merkle Signature Scheme ) in golang☆14Jun 3, 2019Updated 7 years ago
- Guidelines, procedures, and templates used by the IETF Moderators team.☆29Jul 29, 2026Updated 3 months ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Skein/Threefish/Fortuna implementations for ZRTP4J used by Jitsi☆14May 21, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Grawlox is a profanity filter which offers methods for detecting and replacing swearwords.☆11Jul 16, 2017Updated 9 years ago
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- Xoodyak, a lightweight and versatile cryptographic scheme implemented in Rust.☆30Sep 29, 2026Updated last month
- Stronger and Faster Side-Channel Protections for CSIDH☆21Dec 20, 2020Updated 5 years ago
- A framework for automated search for independent-biclique attacks☆14Jun 30, 2015Updated 11 years ago
- Optimized (fast) Java Keccak/SHA3/SHAKED implementation☆14Oct 12, 2020Updated 6 years ago
- libsodium-jna is a java library that binds to libsodium C crypto APIs with Java Native Access (JNA)☆58Sep 27, 2026Updated last month