Protocol Buffers, JSON, XML data serialization system for OCaml
☆39Aug 5, 2022Updated 4 years ago
Alternatives and similar repositories for piqi-ocaml
Users that are interested in piqi-ocaml are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- An OCaml library for describing Protobuf messages☆30Feb 4, 2021Updated 5 years ago
- Parsing of the Content-Type header in pure OCaml☆20Nov 24, 2020Updated 5 years ago
- ☆12Apr 9, 2020Updated 6 years ago
- Curve25519 in OCaml.☆16Sep 4, 2018Updated 8 years ago
- RSS and Atom feed parsing☆38Mar 6, 2026Updated 8 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Port of the Mirage OS module to the FreeBSD kernel, aka. project "Mirage/kFreeBSD".☆13Aug 31, 2012Updated 14 years ago
- A protoc plugin for generating OCaml code from protobuf (.proto) files.☆17Nov 30, 2019Updated 6 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- TLS client program☆11Jun 10, 2020Updated 6 years ago
- experiments with Brr/Note☆13Aug 27, 2021Updated 5 years ago
- Ocaml bindings to Argon2☆33Aug 1, 2024Updated 2 years ago
- Websockets implementation for httpaf☆32Jun 23, 2019Updated 7 years ago
- ☆15Dec 11, 2020Updated 5 years ago
- Yet another type combinator library☆56Mar 10, 2022Updated 4 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- [DEPRECATED (use avro-simple)] Runtime library and schema compiler for the Avro serialization format.☆21Jul 7, 2026Updated 3 months ago
- Ocaml bindings for lmdb.☆50Aug 30, 2026Updated 2 months ago
- automatic ci configuration for the people☆36Nov 20, 2019Updated 6 years ago
- heterogenous Map over a GADT☆42Dec 17, 2024Updated last year
- Lwt-compatible IMAP4rev1 client library for OCaml☆41Dec 29, 2020Updated 5 years ago
- Google Protocol Buffers runtime implemented in OCaml☆10Sep 27, 2015Updated 11 years ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- Portable implementation of the Irmin Watch API☆17Oct 9, 2026Updated 3 weeks ago
- ☆40Sep 13, 2026Updated last month
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Erlang style process/actor model library in OCaml☆16Apr 23, 2023Updated 3 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- A library for parsing, manipulating, and serializing data structured as JSON.☆20Updated this week
- ZeroMQ bindings for OCaml☆85May 19, 2024Updated 2 years ago
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- ☆15Aug 16, 2020Updated 6 years ago
- Pure OCaml implementation of libXdiff (Rabin's fingerprint)☆21Nov 26, 2024Updated last year
- Pure OCaml library to read and write tar files☆55Jun 24, 2026Updated 4 months ago
- Trivial/Tagless Polytypic Functions☆24Apr 14, 2020Updated 6 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Lookup and load installed OCaml modules☆17Aug 13, 2026Updated 2 months ago
- A safer C FFI for OCaml☆18Dec 13, 2018Updated 7 years ago
- A gRPC implementation written in pure OCaml/Reason☆16Apr 12, 2019Updated 7 years ago
- Bencode (.torrent file format) reader/writer in OCaml☆24Apr 24, 2024Updated 2 years ago
- A jabber logger and web interface☆12Oct 27, 2026Updated last week
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated 2 weeks ago
- OCaml library to work with DWARF format☆39Dec 1, 2025Updated 11 months ago