libsodium-jna is a java library that binds to libsodium C crypto APIs with Java Native Access (JNA)
☆58Sep 27, 2026Updated last month
Alternatives and similar repositories for libsodium-jna
Users that are interested in libsodium-jna are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Java libsodium bindings☆12Sep 3, 2017Updated 9 years ago
- A Java implementation of the Libsodium crypto library. For the lazy dev.☆157Jun 17, 2025Updated last year
- Libhydrogen implemented in Java.☆20Mar 15, 2021Updated 5 years ago
- A pure Java implementation of BLAKE2 (RFC 7693)☆14Sep 12, 2023Updated 3 years ago
- Implementation of the single-step key derivation function (KDF) as described in NIST Special Publication 800-56C Rev1 supporting messages…☆10Oct 5, 2026Updated last month
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- The Romulus family of lightweight cryptographic algorithms (authenticated encryption and hashing).☆10Sep 20, 2022Updated 4 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- TokenTools is the successor project to a C program I wrote called CardRand, allowing Linux to use the random number generator in cryptogr…☆16May 15, 2017Updated 9 years ago
- Chacha20Poly1305 AEAD☆17Mar 15, 2015Updated 11 years ago
- Play2 plugin for Hikari, the high-performance JDBC connection pool☆12Jan 19, 2014Updated 12 years ago
- Pure Java implementation of EdDSA☆233Aug 12, 2023Updated 3 years ago
- Global-scale overlay network router, designed for connecting cloud network infrastructure.☆14Dec 13, 2020Updated 5 years ago
- HiAE - A High-Throughput Authenticated Encryption Algorithm for Cross-Platform Efficiency.☆19May 27, 2026Updated 5 months ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- ☆24May 14, 2025Updated last year
- Java member resolution library.☆24Jun 30, 2026Updated 4 months ago
- Base58 Encode Decode☆20Jan 19, 2022Updated 4 years ago
- A blake2s java implementation☆19Jan 31, 2016Updated 10 years ago
- TweetNaCl in Java - a port of TweetNaCl-js☆52Feb 3, 2023Updated 3 years ago
- An unoptimized BLAKE3 implementation in Java☆32Aug 19, 2021Updated 5 years ago
- Deoxys-II-256-128 MRAE primitives for Rust☆24Apr 17, 2024Updated 2 years ago
- Java implementation of FIPS 202, SHA3-xxxx, SHAKE128, SHAKE256☆20Oct 13, 2020Updated 6 years ago
- PCG — Java Implementation. High quality fast random number generator☆14Jun 15, 2021Updated 5 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Pure Java implementation of curve25519, salsa20, hsalsa20, xsalsa20 and poly1305 cryptographic primitives, along with a NaCl "Box" implem…☆112Oct 16, 2023Updated 3 years ago
- A completely free, open, self-hosted alternative to things like IPAPI or GeoPlugin – but with the ability to add plugins and customize th…☆13Jan 13, 2026Updated 9 months ago
- FIPS-204 (ML-DSA) implementation in Go☆25Jul 10, 2026Updated 3 months ago
- Specification for the AEGIS family of authenticated encryption algorithms.☆23Oct 23, 2026Updated 2 weeks ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Xoodyak, a lightweight and versatile cryptographic scheme implemented in Rust.☆30Sep 29, 2026Updated last month
- Parallel Byzantine Fault Tolerance (R&D)☆11Dec 14, 2017Updated 8 years ago
- Epub/mobi build scripts for books available on the Internet☆11Apr 26, 2017Updated 9 years ago
- Implementation and simulations for the "Reducing Metadata Leakage from Encrypted Data and Communication with PURBs" paper☆30Oct 26, 2023Updated 3 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- CHIP-8 interpreter written in Rust☆11May 23, 2020Updated 6 years ago
- ChaCha20 + Poly1305☆27Apr 30, 2016Updated 10 years ago
- AES-GEM (AES Galois Extended Mode) implementation.☆14May 19, 2026Updated 5 months ago
- ☆23Updated this week
- Java implementation of the ClassiCube and BetaCraft protocol☆13Updated this week
- Implementation of Kuznechik cipher Russian standard GOST R 3412-2015 - 128 bit block size / 256 bit key - 8,16, 32, 64, 128-bit x86 versi…☆10Jun 27, 2016Updated 10 years ago
- Curve ecGFp5☆73Mar 31, 2022Updated 4 years ago