X509 (RFC5280) handling in OCaml
☆52Sep 24, 2026Updated last month
Alternatives and similar repositories for ocaml-x509
Users that are interested in ocaml-x509 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- Entropy driver for MirageOS -- this has been imported into https://github.com/mirage/mirage-crypto☆11Feb 24, 2020Updated 6 years ago
- ☆40Sep 13, 2026Updated last month
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- A small command-line tool to help with mechanical edition of opam files☆11Aug 3, 2026Updated 3 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- IO memory page library for Mirage backends☆10Mar 5, 2025Updated last year
- Scheduling build jobs on regular intervals, collecting artifacts☆13Jun 15, 2026Updated 4 months ago
- A HTTP client relying solely on the OCaml standard library, for use when bootstrapping opam☆13Jul 8, 2019Updated 7 years ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- A port of Eric Lippert's flathead Z-machine interpreter to MirageOS☆10Sep 27, 2019Updated 7 years ago
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- Cross-runtime object interface generation☆35Oct 28, 2021Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Small command-line tools for making certificates with OCaml x509/nocrypto toolstack.☆39Feb 17, 2024Updated 2 years ago
- Simple templating based on XML ropes☆12Sep 4, 2015Updated 11 years ago
- Embed typed ASN.1 grammars in OCaml☆36Sep 14, 2026Updated last month
- MirageOS unikernel to test networking☆16Apr 3, 2023Updated 3 years ago
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated 2 weeks ago
- OCaml based XMPP implementation☆26Dec 27, 2015Updated 10 years ago
- ☆23May 25, 2025Updated last year
- Functional Priority Search Queues for OCaml☆53Mar 30, 2024Updated 2 years ago
- File paths for OCaml☆29Jul 29, 2025Updated last year
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- A dashboard displaying useful data from MirageOS project and its related repositories.☆13Sep 7, 2016Updated 10 years ago
- MirageOS Syslog Unikernel☆11Oct 30, 2016Updated 10 years ago
- TLS in pure OCaml☆321Oct 21, 2026Updated 2 weeks ago
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- RSS and Atom feed parsing☆38Mar 6, 2026Updated 8 months ago
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- Duration☆17Apr 16, 2026Updated 6 months ago
- OpenType font decoder for OCaml☆20Aug 13, 2026Updated 2 months ago
- heterogenous Map over a GADT☆42Dec 17, 2024Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Experimental portable bitmap framebuffer graphics for MirageOS☆17Jul 14, 2020Updated 6 years ago
- An ocaml library for using BPF/AF_SOCKET in a platform independent way.☆17Jul 24, 2023Updated 3 years ago
- Unix Filesystem passthrough for MirageOS☆16Oct 30, 2019Updated 7 years ago
- Universally unique identifiers (UUIDs) for OCaml☆48Jul 29, 2025Updated last year
- OCaml cryptographic library☆111Apr 17, 2020Updated 6 years ago
- Unicode character database decoder for OCaml☆17Sep 17, 2026Updated last month
- Membership protocol for Mirage unikernel clusters based on SWIM☆18Mar 14, 2016Updated 10 years ago