Map OCaml arrays onto C-like structs
☆115Sep 5, 2026Updated last month
Alternatives and similar repositories for ocaml-cstruct
Users that are interested in ocaml-cstruct are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- RFC3986 URI parsing library for OCaml☆99Nov 24, 2025Updated 11 months ago
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- Library to provide a fast integer (x64 arch) or allocated int32 (x84 arch)☆24Jul 29, 2026Updated 3 months ago
- ☆15Aug 16, 2020Updated 6 years ago
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- OCaml cryptographic library☆111Apr 17, 2020Updated 6 years ago
- OCaml implementation of the DNS protocol☆120Sep 13, 2026Updated last month
- Universally unique identifiers (UUIDs) for OCaml☆48Jul 29, 2025Updated last year
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- Dereference URIs into communication channels for Async or Lwt☆86Nov 24, 2025Updated 11 months ago
- Streaming XML codec for OCaml☆55Aug 13, 2026Updated 2 months ago
- Read and write FAT format filesystems from OCaml☆25May 31, 2025Updated last year
- Ocamlbuild helpers for C stubs☆12Oct 24, 2018Updated 8 years ago
- Library for binding to C libraries using pure OCaml☆412Nov 6, 2025Updated 11 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Websockets implementation for httpaf☆32Jun 23, 2019Updated 7 years ago
- Pure OCaml library to read and write tar files☆55Jun 24, 2026Updated 4 months ago
- Yet another type combinator library☆56Mar 10, 2022Updated 4 years ago
- HMAC-based Extract-and-Expand Key Derivation Function (HKDF) (RFC 5869)☆12Sep 4, 2024Updated 2 years ago
- Light library to deal with RPCs in OCaml☆106Apr 4, 2026Updated 6 months ago
- Implementation of SMTP protocols in OCaml☆48Oct 7, 2026Updated 3 weeks ago
- Port of HTTP/AF & H2 with Mirage and mimic☆30Sep 15, 2026Updated last month
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- A protoc plugin for generating OCaml code from protobuf (.proto) files.☆17Nov 30, 2019Updated 6 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- An OCaml library for parsing documentation comments written in 'odoc markup', a superset of 'ocamldoc markup'.☆16Oct 19, 2023Updated 3 years ago
- X509 (RFC5280) handling in OCaml☆52Sep 24, 2026Updated last month
- HTML validation on command line☆18Oct 4, 2019Updated 7 years ago
- RSS and Atom feed parsing☆38Mar 6, 2026Updated 7 months ago
- The transitory OCaml software packager☆69Sep 8, 2026Updated last month
- An embeddable Lua 2.5 interpreter implemented in OCaml☆139May 23, 2026Updated 5 months ago
- Scalable LRU caches for OCaml☆46Oct 25, 2022Updated 4 years ago
- OCaml SSL bindings.☆58Oct 8, 2026Updated 3 weeks ago
- A simple implementation of Discrete Interval Encoding Trees☆28Apr 16, 2022Updated 4 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- OCaml ppx to include binary data from a file as a string☆82Aug 24, 2024Updated 2 years ago
- Implementation of the openflow protocol in OCaml☆12Sep 28, 2010Updated 16 years ago
- OpenType font decoder for OCaml☆20Aug 13, 2026Updated 2 months ago
- Unix Filesystem passthrough for MirageOS☆16Oct 30, 2019Updated 6 years ago
- Error-recovering streaming HTML5 and XML parsers☆149Oct 6, 2024Updated 2 years ago
- iperf like tool on MirageOS☆11May 27, 2026Updated 5 months ago