Light library to deal with RPCs in OCaml
☆106Apr 4, 2026Updated 7 months ago
Alternatives and similar repositories for ocaml-rpc
Users that are interested in ocaml-rpc are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- OCaml bindings for jech/dht☆25Jun 16, 2020Updated 6 years ago
- Cap'n Proto RPC implementation☆120Sep 13, 2026Updated last month
- Ocaml SHA 1 and 2 family implementation using a really fast C implementation☆32Jan 23, 2023Updated 3 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Pure OCaml implementation of the "vchan" shared-memory communication protocol☆46Mar 6, 2025Updated last year
- RFC3986 URI parsing library for OCaml☆99Nov 24, 2025Updated 11 months ago
- Efficient Bloom filters for OCaml☆38Jan 3, 2022Updated 4 years ago
- Map OCaml arrays onto C-like structs☆115Sep 5, 2026Updated 2 months ago
- OCaml library for resizable arrays and strings☆26Jun 23, 2026Updated 4 months ago
- A Mirage filesystem library☆47Sep 16, 2021Updated 5 years ago
- CUID generator for OCaml.☆18May 7, 2022Updated 4 years ago
- Print OCaml values based on their runtime representation☆30Jun 7, 2022Updated 4 years ago
- [beta] persistent memoization of computations, e.g. for repeatable tests and benchmarks☆17Apr 7, 2026Updated 7 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- Infrastructure to collect metrics from OCaml applications.☆46Jun 16, 2025Updated last year
- OCaml/MPI interface☆29Mar 8, 2026Updated 7 months ago
- Thin OCaml bindings to various low-level system APIs not covered by Unix module☆55Sep 29, 2026Updated last month
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- OCaml binary heap implementation by Jean-Christophe Filliatre☆18Nov 29, 2020Updated 5 years ago
- Adaptive Radix Tree in OCaml☆52May 8, 2026Updated 5 months ago
- Pure OCaml library to read and write tar files☆55Jun 24, 2026Updated 4 months ago
- Serialization library built for speed and memory efficiency☆142Oct 13, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- NanoID implementation for OCaml.☆21Mar 30, 2023Updated 3 years ago
- Mergeable queues☆19Mar 24, 2015Updated 11 years ago
- Extensible binary data format, like JSON but faster☆43Jun 17, 2022Updated 4 years ago
- Reusable runtime library for network protocols☆48Mar 12, 2026Updated 7 months ago
- OCaml PPX extension for automatically generating Irmin types☆11Jan 14, 2020Updated 6 years ago
- Procord is a portable OCaml library to delegate tasks to other processes.☆27Sep 2, 2014Updated 12 years ago
- Functional Priority Search Queues for OCaml☆53Mar 30, 2024Updated 2 years ago
- ImpFS, a new filesystem.☆22Feb 6, 2022Updated 4 years ago
- Library to provide a fast integer (x64 arch) or allocated int32 (x84 arch)☆24Jul 29, 2026Updated 3 months ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Library to provide Erlang style distributed computations. This library is inspired by Cloud Haskell.☆58Nov 25, 2019Updated 6 years ago
- Parallelize _anything_ //☆54Oct 5, 2023Updated 3 years ago
- ZeroMQ bindings for OCaml☆85May 19, 2024Updated 2 years ago
- ppx_mysql☆32Aug 29, 2025Updated last year
- Enables HTTP file uploads and form processing in OCaml web applications.☆13Jun 19, 2024Updated 2 years ago
- Convert a cmi file back to an mli interface☆20Jan 18, 2015Updated 11 years ago
- ☆11Apr 22, 2016Updated 10 years ago