Cap'n Proto RPC implementation
☆120Sep 13, 2026Updated last month
Alternatives and similar repositories for capnp-rpc
Users that are interested in capnp-rpc are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- OCaml code generator plugin for the Cap'n Proto serialization framework☆106Jul 19, 2023Updated 3 years ago
- HTML validation on command line☆18Oct 4, 2019Updated 7 years ago
- Password based key derivation functions from PKCS#5, RFC 2898☆21Jul 15, 2024Updated 2 years ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- POSIX sendmsg bindings for OCaml☆16Nov 5, 2016Updated 10 years ago
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- Light library to deal with RPCs in OCaml☆106Apr 4, 2026Updated 7 months ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- ☆11Apr 22, 2016Updated 10 years ago
- ZeroMQ bindings for OCaml☆85May 19, 2024Updated 2 years ago
- ☆40Sep 13, 2026Updated last month
- Adaptive Radix Tree in OCaml☆52May 8, 2026Updated 5 months ago
- Ocaml bindings for lmdb.☆50Aug 30, 2026Updated 2 months ago
- A DSL to invoke otherworldly functors☆64Aug 25, 2022Updated 4 years ago
- [beta] persistent memoization of computations, e.g. for repeatable tests and benchmarks☆17Apr 7, 2026Updated 7 months ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- Dig into an opam switch for doc☆10Apr 8, 2022Updated 4 years ago
- Infrastructure to collect metrics from OCaml applications.☆46Jun 16, 2025Updated last year
- OCaml bindings for jech/dht☆25Jun 16, 2020Updated 6 years ago
- OCaml embedded eBPF assembler☆24Feb 14, 2022Updated 4 years ago
- Yet another type combinator library☆56Mar 10, 2022Updated 4 years ago
- A protoc plugin for generating OCaml code from protobuf (.proto) files.☆17Nov 30, 2019Updated 6 years ago
- Efficient Bloom filters for OCaml☆38Jan 3, 2022Updated 4 years ago
- ☆36Jul 16, 2022Updated 4 years ago
- A simple tool and library to embed files and directories inside an OCaml executables☆20Apr 11, 2022Updated 4 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- An OCaml clustering library☆20Apr 26, 2021Updated 5 years ago
- Agnostic benchmark in OCaml (proof-of-concept)☆44Aug 29, 2026Updated 2 months ago
- Synonym of angkor☆25Mar 4, 2025Updated last year
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- safe FFI between OCaml and Rust (experimental)☆68Aug 23, 2020Updated 6 years ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- Helpers for using topkg with jbuilder☆15Oct 12, 2017Updated 9 years ago
- Trivial/Tagless Polytypic Functions☆24Apr 14, 2020Updated 6 years ago
- Scalable LRU caches for OCaml☆46Oct 25, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- automatic ci configuration for the people☆36Nov 20, 2019Updated 6 years ago
- WiP: RFC 4880 (OpenPGP) library and utilities in OCaml☆24Oct 1, 2018Updated 8 years ago
- Gasoline is an OCaml library providing application templates. Applications written with Gasoline are parametrised by the command line, en…☆16Feb 8, 2018Updated 8 years ago
- The Noise Protocol Framework, with types☆26Dec 8, 2021Updated 4 years ago
- Make interactive text-oriented user-interfaces for OCaml☆23Feb 5, 2020Updated 6 years ago
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- Fast msgpack library for OCaml☆28Jun 8, 2021Updated 5 years ago