AES-GCM-SIV implementations (128 and 256 bit)
☆121Jul 1, 2019Updated 7 years ago
Alternatives and similar repositories for AES-GCM-SIV
Users that are interested in AES-GCM-SIV are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- AVX2 Chacha implementation☆16Nov 23, 2013Updated 12 years ago
- AVX implementation of the Skinny block cipher☆12Apr 24, 2022Updated 4 years ago
- GOSTBOX -- A 95-byte program for the 256-byte Streebog/Kuznyechik S-Box.☆17Feb 20, 2021Updated 5 years ago
- The best AES cipher built upon tiny-aes-c. Replace tiny-aes-c code blocks with something else if you want to run it on enterprise servers…☆12Mar 29, 2025Updated last year
- Materials accompanying "Implementing an Elliptic Curve in Go"☆13Jul 29, 2017Updated 9 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago
- SIDH C reference implementation☆13Jan 25, 2017Updated 9 years ago
- Package fourq implements FourQ, a high-speed elliptic curve at the 128-bit security level.☆54Apr 24, 2026Updated 5 months ago
- A standalone AES-KW (AES Key Wrap) implementation.☆14Dec 31, 2023Updated 2 years ago
- ☆14Aug 19, 2022Updated 4 years ago
- BLAKE2 AVX2 implementations☆23Dec 22, 2019Updated 6 years ago
- Standalone AES-GCM library (pulled out of mbed TLS)☆35Apr 28, 2016Updated 10 years ago
- A list of certificates shipped by various vendors and Open Source Projects☆38Nov 26, 2015Updated 10 years ago
- Capsicum shim and utilities for Go.☆10Oct 13, 2017Updated 8 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- ChaCha20 + Poly1305☆28Apr 30, 2016Updated 10 years ago
- BAT KEM/Signature Reference Implementation☆25Dec 28, 2021Updated 4 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Bouncy Castle FIPS Java API Examples☆11Aug 13, 2021Updated 5 years ago
- Experimental implementation of KEMTLS in Rustls☆36Apr 22, 2026Updated 5 months ago
- A Java implementation of AES-GCM-SIV (RFC 8452).☆37Apr 18, 2019Updated 7 years ago
- An implementation of the axolotl ratchet based on libsodium.☆23Oct 4, 2022Updated 3 years ago
- Multiplication using AVX512 and AVX512IFMA instructions☆26Nov 9, 2015Updated 10 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Classical simulator for Kuperberg's quantum collimation sieve, generalized to arbitrary finite cyclic groups and focused on CSIDH-512.☆15Jun 18, 2019Updated 7 years ago
- An RFC5297-compliant C implementation of AES-SIV☆20Oct 15, 2020Updated 5 years ago
- FPGA implementation of a cryptographically secure physical unclonable function based on learning parity with noise problem.☆17Oct 25, 2017Updated 8 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- NORX implementation in Rust☆17Apr 8, 2015Updated 11 years ago
- Links to stuff arising from or related to the HACS workshop.☆34Feb 9, 2018Updated 8 years ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago
- Implementation of the Fish and Begol signature schemes☆14Jul 3, 2017Updated 9 years ago
- Simple implementation of 256 bit AES encryption in GCM mode.☆23Jan 21, 2019Updated 7 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Post-quantum Wireguard (Theory)☆13Sep 9, 2020Updated 6 years ago
- A pure-go implementation of the Axolotl Ratchet, extracted from pond☆21Feb 8, 2017Updated 9 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- ☆12May 7, 2021Updated 5 years ago
- Hide/Block files in filesystem☆14Nov 23, 2021Updated 4 years ago
- A tool for linear and differential cryptanalysis of block ciphers written in Rust☆15Sep 28, 2022Updated 4 years ago
- Reference implementations of post-quantum cryptographic primitives☆32Feb 16, 2026Updated 7 months ago