πΏοΈ A pure golang implementation of TFHE Fully Homomorphic Encryption Scheme
β109Nov 5, 2025Updated 11 months ago
Alternatives and similar repositories for go-tfhe
Users that are interested in go-tfhe are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Go implementation of (MK)TFHE schemeβ42Oct 21, 2026Updated 2 weeks ago
- A minimal implementation of ZKPs of Ethereum block execution using Reth. Supports both Ethereum and OP Stack.β13Jul 2, 2025Updated last year
- Lightweight Go library that provides comprehensive string manipulation, type conversion, formatting, and error handling with a fluid API,β¦β21Oct 8, 2026Updated 3 weeks ago
- A library for lattice-based multiparty homomorphic encryption in Goβ1,461Updated this week
- a zig sdk that allows your code to run in a zkvmβ16Sep 11, 2026Updated last month
- Managed hosting for WordPress and PHP on Cloudways β’ AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Proof-of-concept implementation for the paper "Homomorphic Encryption for Large Integers from Nested Residue Number Systems", presented aβ¦β28Jun 4, 2025Updated last year
- TPM 2.0 TSS keyfile libraryβ24Sep 2, 2026Updated 2 months ago
- A Linux daemon serving an API to compile, interpret and execute source code in containers using containerd.β13Apr 9, 2025Updated last year
- π¦ A pure rust implementation of the TFHE Fully Homomorphic Encryption Schemeβ42Jun 22, 2026Updated 4 months ago
- Libp2p Playground - mess around with GossipSub & DHTsβ10Mar 2, 2026Updated 8 months ago
- In this repo I implement a stark prover for learning purposesβ14May 22, 2025Updated last year
- gnark is a fast, open-source library for zero-knowledge proof protocols written in Go.β12Updated this week
- Zstandard for Golang Stdlib (do not use) - https://github.com/golang/go/issues/62513β15Sep 29, 2026Updated last month
- High-level, easy-to-use listeners and clients for I2P and onion URL's from Go. Provides only the most widely-used functions in a basic waβ¦β16Oct 21, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer β’ AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Multi-Key Homomophic Encryption from TFHEβ66May 20, 2021Updated 5 years ago
- Tor client(not a relay, not an exit) in pure Go.β11Jul 31, 2026Updated 3 months ago
- Verifying Cairo Programs in SP1β14Oct 16, 2024Updated 2 years ago
- IO engine library supports BufferedIO/DirectIO/AsyncIO and provides a unified common unix-like system file operation interfaceβ11Apr 30, 2019Updated 7 years ago
- A curated list of educational materials, guides, and research papers for beginners interested in learning about Fully Homomorphic Encryptβ¦β13Aug 8, 2024Updated 2 years ago
- β11Apr 2, 2024Updated 2 years ago
- A backend agnostic modular FHE library over the Torus using bivariate polynomial representationβ91Updated this week
- ALPHA ALPHA AI EXPERIMENT -- Go bindings for pglite (Postgres wasm)β16Mar 24, 2026Updated 7 months ago
- β12Sep 8, 2025Updated last year
- GPU virtual machines on DigitalOcean Gradient AI β’ AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- A FIDO Device Onboard library with minimal dependenciesβ35Oct 19, 2026Updated 2 weeks ago
- This repo implements Mahi-Mahi consensus protocol. It builds on the the https://github.com/MystenLabs/mysticeti code baseβ15Oct 1, 2026Updated last month
- π΅ Schnorr Signatures over Ristretto255 in pure Goβ101Apr 24, 2025Updated last year
- A Fork of Golang TLS Library with Kernel TLS Implementationβ14Jan 19, 2025Updated last year
- A monorepo for vOPRF-based secure nullifiersβ24Apr 13, 2025Updated last year
- A zero-knowledge protocol for anonymous interactions.β13Aug 27, 2025Updated last year
- π§ Implemented Keys, Algorithms (RFC9053), COSE (RFC9052) and CWT (RFC8392) in Go.β24Sep 1, 2026Updated 2 months ago
- SquashFS implementation in pure Go (read/write)β20Apr 2, 2026Updated 7 months ago
- Implementation of an IPC client and librariesβ18Jan 11, 2024Updated 2 years ago
- Managed hosting for WordPress and PHP on Cloudways β’ AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Typescript implementation of Yamuxβ19Mar 4, 2026Updated 7 months ago
- A modular library for designing and optimising homomorphic encryption schemesβ30Oct 13, 2026Updated 3 weeks ago
- Source code for the paper "Transformer-based Language Models and Homomorphic Encryption: an intersection with BERT-tiny"β36Oct 25, 2025Updated last year
- Lightweight s3 client with zero dependenciesβ17Oct 2, 2026Updated last month
- SWID and CoSWID manipulation libraryβ10Oct 4, 2026Updated 3 weeks ago
- RLN circuits in Noirβ13Nov 18, 2023Updated 2 years ago
- Groth16 zkSNARK implementation in Julia - modular zero-knowledge proof system built from scratch for learning and research. Prove everythβ¦β17May 12, 2026Updated 5 months ago