OCaml implementation of the DNS protocol
☆120Nov 3, 2026Updated this week
Alternatives and similar repositories for ocaml-dns
Users that are interested in ocaml-dns are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- RFC3986 URI parsing library for OCaml☆99Nov 24, 2025Updated 11 months ago
- IO memory page library for Mirage backends☆10Mar 5, 2025Updated last year
- Dereference URIs into communication channels for Async or Lwt☆86Nov 24, 2025Updated 11 months ago
- Library for manipulating ISO images☆13Jun 28, 2019Updated 7 years ago
- An implementation of happy eyeballs (RFC 8305) in OCaml with lwt☆24Oct 21, 2026Updated 2 weeks ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Emit Logs via syslog☆11Feb 10, 2025Updated last year
- Monotonic wall-clock time for OCaml☆33Aug 13, 2026Updated 2 months ago
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- Development OPAM repository for work-in-progress packages☆16Jun 24, 2024Updated 2 years ago
- X509 (RFC5280) handling in OCaml☆52Sep 24, 2026Updated last month
- Infrastructure to collect metrics from OCaml applications.☆46Jun 16, 2025Updated last year
- Pure OCaml implementation of the "vchan" shared-memory communication protocol☆46Mar 6, 2025Updated last year
- Map OCaml arrays onto C-like structs☆115Sep 5, 2026Updated 2 months ago
- Reflect the essence of OCaml types as values☆15Sep 3, 2026Updated 2 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A small command-line tool to help with mechanical edition of opam files☆11Aug 3, 2026Updated 3 months ago
- What do you mean?☆49Oct 27, 2026Updated last week
- An Irmin backend for a web browser's IndexedDB store☆33Jan 2, 2025Updated last year
- A DHCP server for UNIX systems based on charrua-core.☆11May 24, 2017Updated 9 years ago
- DKIM support on e-mail☆11Oct 9, 2026Updated 3 weeks ago
- OCaml library to access Maildir folders☆19Feb 25, 2019Updated 7 years ago
- J'ai plus mal à la tête maintenant☆29Oct 21, 2026Updated 2 weeks ago
- Adaptive Radix Tree in OCaml☆52May 8, 2026Updated 5 months ago
- A high-performance server for Irmin☆24Oct 1, 2022Updated 4 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- OCaml parser for RFC 3164 Syslog messages☆25Jun 3, 2023Updated 3 years ago
- A simple library for manipulating Master Boot Records☆17Mar 6, 2025Updated last year
- ☆40Sep 13, 2026Updated last month
- Duration☆17Apr 16, 2026Updated 6 months ago
- Unicode text for OCaml☆14Feb 19, 2018Updated 8 years ago
- Implementation of SMTP protocols in OCaml☆48Oct 7, 2026Updated 3 weeks ago
- MirageOS unikernel to test networking☆16Apr 3, 2023Updated 3 years ago
- ☆18Mar 12, 2016Updated 10 years ago
- Lazy prefix trees in OCaml☆22Jan 22, 2020Updated 6 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Flow implementations for Mirage☆13Feb 5, 2025Updated last year
- ☆15Aug 16, 2020Updated 6 years ago
- QOI image codec for OCaml (unreleased)☆11Aug 13, 2026Updated 2 months ago
- Simple templating based on XML ropes☆12Sep 4, 2015Updated 11 years ago
- Optimised functions to read and write int16/32/64 from strings, bytes and bigarrays, based on primitives added in version 4.01.☆14Jun 27, 2022Updated 4 years ago
- TLS in pure OCaml☆321Oct 21, 2026Updated 2 weeks ago
- Bot posting reports on opam-repository pull-request using a web hook☆17Apr 1, 2020Updated 6 years ago