A small and easy to use HPKE implementation in Go.
☆20Sep 17, 2026Updated last month
Alternatives and similar repositories for go-hpke-compact
Users that are interested in go-hpke-compact are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Implementation of draft-irtf-cfrg-hpke☆30May 11, 2023Updated 3 years ago
- ☆12May 7, 2021Updated 5 years ago
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- Oblivious HTTP☆26Jan 2, 2024Updated 2 years ago
- BLST-Verification☆23Apr 22, 2026Updated 5 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Efficient Anonymous Tokens with Private Metadata Bit☆16Mar 7, 2023Updated 3 years ago
- Go implementation of RFC9497, Oblivious Pseudorandom Functions and Verifiable variants.☆16Updated this week
- ☆12Jan 19, 2024Updated 2 years ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Crypto Forum Research Group's draft HPKE: Hybrid Public Key Encryption in Go☆17Nov 5, 2019Updated 6 years ago
- BLS working standard draft☆39Aug 8, 2019Updated 7 years ago
- 🎄🖋 A Rust implementation of Merkle signing☆15Jul 10, 2020Updated 6 years ago
- Models for authenticated key exchange in Tamarin☆12Oct 9, 2019Updated 7 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Parses https://eprint.iacr.org/eprint-bin/search.pl?last=365&title=1 and sends you an email with the latest papers☆15Nov 11, 2020Updated 5 years ago
- Javascript implementation of the Ristretto255 group operations, built on top of the popular TweetNaCl.js crypto library☆35Dec 13, 2023Updated 2 years ago
- A privacy-preserving digital version of punch cards used in store loyalty programs☆11Apr 19, 2021Updated 5 years ago
- HTTPS-based Pluggable Transport for Tor☆12Aug 6, 2018Updated 8 years ago
- ☆44Sep 29, 2021Updated 5 years ago
- A Zig implementation of EdDSA signatures with blind keys.☆17Apr 11, 2026Updated 6 months ago
- Public working documents (e.g., Internet drafts)☆27Jun 8, 2018Updated 8 years ago
- A simple libp2p DHT crawler☆16Jan 6, 2022Updated 4 years ago
- Implementation and simulations for the "Reducing Metadata Leakage from Encrypted Data and Communication with PURBs" paper☆30Oct 26, 2023Updated 2 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- ABE GPSW scheme using BLS pairing implemented in Rust.☆17May 23, 2023Updated 3 years ago
- Deterministic/nonce-reuse resistant authenticated encryption scheme using XChaCha20, implemented on libsodium.☆31Aug 5, 2024Updated 2 years ago
- An implementation of a verifiable oblivious pseudorandom function (RFC 9497)☆88Apr 6, 2026Updated 6 months ago
- Oblivious DoH server in Go☆66Apr 17, 2022Updated 4 years ago
- Schnorr signatures over big curves for Ledger devices. group arithmetic & key derivation for unusual elliptic curves.☆13Apr 9, 2020Updated 6 years ago
- [RFC9380] Hash to curves - Rust reference implementation☆27Mar 10, 2024Updated 2 years ago
- Blind RSA signatures for OpenSSL/BoringSSL.☆17Sep 25, 2026Updated 3 weeks ago
- ☆12Apr 23, 2026Updated 5 months ago
- An RFC5297-compliant C implementation of AES-SIV☆20Oct 15, 2020Updated 6 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Vector Commitments with Constant-Sized, Updatable Proofs and Linear-Sized Public Parameters☆12Jun 3, 2021Updated 5 years ago
- OPAQUE asymmetric PAKE, and its threshold implementation. Experimental, not audited.☆16Jun 16, 2021Updated 5 years ago
- Rust implementation of Zcash multi-signautres☆13Jun 23, 2019Updated 7 years ago
- library providing OPRF and Threshold OPRF based on libsodium☆36Sep 1, 2026Updated last month
- Hashing to Elliptic Curves☆80Sep 8, 2024Updated 2 years ago
- An EXPERIMENTAL Go implementation of the CPace PAKE, instantiated with the ristretto255 group.☆29Feb 11, 2021Updated 5 years ago
- implements invertible bloom filters in golang☆16Feb 3, 2020Updated 6 years ago