Implementations of a fast Message-Authentication Code
☆123Sep 28, 2022Updated 4 years ago
Alternatives and similar repositories for poly1305-donna
Users that are interested in poly1305-donna are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Optimized implementations of Poly1305, a fast message-authentication-code☆47Feb 6, 2015Updated 11 years ago
- Portable 8439: ChaCha20-Poly1305 (RFC 8439) in portable & fast C99☆43Jan 30, 2022Updated 4 years ago
- Generator and Internet Draft (I-D) documenting test vectors for the stream cipher ChaCha.☆12Apr 21, 2016Updated 10 years ago
- Implementations of a fast Elliptic-curve Digital Signature Algorithm☆193Apr 21, 2020Updated 6 years ago
- A fork of floodyberry's ed25519-donna modified to support the Ristretto prime-order group☆15Jan 15, 2021Updated 5 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Reference implementation of the BLZZRD variant of the BLISS Ring-LWE Signature Scheme☆17Oct 11, 2016Updated 10 years ago
- AVX2 Chacha implementation☆16Nov 23, 2013Updated 12 years ago
- Implementations of a fast Elliptic-curve Diffie-Hellman primitive☆30Apr 13, 2015Updated 11 years ago
- Naehrig, Niederhagen and Schwabe's pairings code, massaged into a shared library.☆19Apr 19, 2016Updated 10 years ago
- Committing ChaCha20-BLAKE3, XChaCha20-BLAKE3, and XChaCha20-BLAKE3-SIV AEAD implementations.☆13Apr 11, 2022Updated 4 years ago
- Implementations of some lightweight block ciphers in C☆19Mar 25, 2018Updated 8 years ago
- A collection of cryptographic primitives targeted at embedded use.☆345Oct 29, 2023Updated 3 years ago
- An implementation of the Skein hash function for ARMv7 with NEON☆14Nov 16, 2011Updated 14 years ago
- Collection of test vectors for cryptographic operations☆14Dec 24, 2015Updated 10 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A simpler alternative to the Noise protocol framework.☆25Jan 6, 2021Updated 5 years ago
- An Experimental Rust Crate for Post-Quantum Code-Signing Certificates.☆27Dec 11, 2021Updated 4 years ago
- tinypy is a minimalist implementation of python☆16Dec 30, 2010Updated 15 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- A well-written BSD licensed C language TLS implementation☆19Jul 26, 2014Updated 12 years ago
- AES GCM : Authenticated Encryption with Associated Data (AEAD) algorithm in Go language☆11Jan 5, 2016Updated 10 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- FLECC_IN_C is a FLexible Elliptic Curve Cryptography library written IN C☆18Nov 17, 2017Updated 8 years ago
- HMAC-SHA-256 C++11 library designed for embedded systems☆12Oct 19, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Self-contained educational implementation of the BLISS-B Bimodal Lattice Signature Scheme☆18Feb 26, 2016Updated 10 years ago
- Multiplication using AVX512 and AVX512IFMA instructions☆26Nov 9, 2015Updated 10 years ago
- Optimized implementation of the Picnic signature scheme☆84Sep 2, 2022Updated 4 years ago
- Mirror of http://sourceforge.net/p/ed448goldilocks/code/ci/master/tree/☆32Jun 29, 2015Updated 11 years ago
- Faster Montgomery and Joye ladder formulas for short Weierstrass elliptic curves☆22Jul 1, 2020Updated 6 years ago
- Bindings for the NaCL implementation of Salsa20 and XSalsa20 by D. J. Bernstein☆32Jan 17, 2020Updated 6 years ago
- mirror of djb's "NaCl: Networking and Cryptography library"☆50Mar 4, 2011Updated 15 years ago
- Mirror of SUPERCOP, the "System for Unified Performance Evaluation Related to Cryptographic Operations and Primitives"☆106Jun 23, 2017Updated 9 years ago
- A C++ implementation of ChaCha20 & Poly1305 stream cipher described in RFC - 8439.☆25Oct 21, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- A dead simple library to simulate Minecraft biomes in pure Java☆11Jun 15, 2023Updated 3 years ago
- Experimental committing AEAD designed by Soatok.☆11Sep 10, 2020Updated 6 years ago
- RFC 7539 compliant ChaCha20-Poly1305 AEAD implementation in plain C99☆41Oct 21, 2020Updated 6 years ago
- Simple ChaCha20Poly1305@Bitcoin C implementation☆31Mar 22, 2019Updated 7 years ago
- A Python implementation of the SPHINCS-256 scheme☆15Feb 23, 2016Updated 10 years ago
- ☆12Apr 5, 2019Updated 7 years ago
- A small C library for the XChaCha20 stream cipher☆41May 27, 2023Updated 3 years ago