A collection of cryptographic primitives targeted at embedded use.
☆346Oct 29, 2023Updated 3 years ago
Alternatives and similar repositories for cifra
Users that are interested in cifra are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- ECDH and ECDSA for 8-bit, 32-bit, and 64-bit processors.☆1,442Oct 9, 2026Updated 3 weeks ago
- TLS 1.3 implementation in C (master supports RFC8446 as well as draft-26, -27, -28)☆642Updated this week
- Authenticated Encryption Based on the Masked Even-Mansour (MEM) Construction☆28Apr 20, 2018Updated 8 years ago
- Implementations of a fast Message-Authentication Code☆123Sep 28, 2022Updated 4 years ago
- High Speed elliptic curve signature system using a 260-bit Granger Moss Prime.☆14Sep 24, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Implementations of a fast Elliptic-curve Diffie-Hellman primitive☆349Dec 17, 2021Updated 4 years ago
- Implementations of a fast Elliptic-curve Digital Signature Algorithm☆193Apr 21, 2020Updated 6 years ago
- Reference implementations (software)☆85Nov 11, 2016Updated 9 years ago
- Don't use this repo, use the new monorepo instead:☆511May 27, 2026Updated 5 months ago
- An easy to use, easy to deploy crypto library☆797Updated this week
- Experimental High Assurance Cryptographic Library☆21Feb 1, 2016Updated 10 years ago
- A simpler alternative to the Noise protocol framework.☆25Jan 6, 2021Updated 5 years ago
- A standalone AES-KW (AES Key Wrap) implementation.☆14Dec 31, 2023Updated 2 years ago
- A collection of all my single-header libraries.☆18Dec 22, 2023Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Mirror of http://sourceforge.net/p/ed448goldilocks/code/ci/master/tree/☆32Jun 29, 2015Updated 11 years ago
- NORX implementation in Rust☆17Apr 8, 2015Updated 11 years ago
- A lightweight, secure, easy-to-use crypto library suitable for constrained environments.☆794Sep 28, 2026Updated last month
- Memory-hard scheme Argon2☆211Jan 9, 2021Updated 5 years ago
- An RFC5297-compliant C implementation of AES-SIV☆21Oct 15, 2020Updated 6 years ago
- Authenticated Blowfish-encrypted pipe☆24Feb 16, 2018Updated 8 years ago
- Optimized block functions for the ChaCha stream cipher☆52Jan 22, 2020Updated 6 years ago
- An implementation of the axolotl ratchet based on libsodium.☆23Oct 4, 2022Updated 4 years ago
- A public domain constant-time implementation of ChaCha20 on 8-bit AVR microcontroller.☆35Jun 28, 2018Updated 8 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Mirror of SUPERCOP, the "System for Unified Performance Evaluation Related to Cryptographic Operations and Primitives"☆106Jun 23, 2017Updated 9 years ago
- C-language software library of the Diffie-Hellman functions X25519 and X448 (RFC-7748) for 64-bit architectures.☆44Nov 10, 2023Updated 2 years ago
- Single C file TLS 1.2/1.3 implementation, using tomcrypt as crypto library☆684Oct 26, 2026Updated last week
- Lightweight cryptographic hash functions (reference code)☆16May 2, 2014Updated 12 years ago
- tinycrypt is a library of cryptographic algorithms with a focus on small, simple implementation.☆522Mar 5, 2024Updated 2 years ago
- A well-written BSD licensed C language TLS implementation☆19Jul 26, 2014Updated 12 years ago
- Fast, constant-time and masked AES assembly implementations for ARM Cortex-M3 and M4☆97Oct 19, 2023Updated 3 years ago
- Standalone AES-GCM library (pulled out of mbed TLS)☆35Apr 28, 2016Updated 10 years ago
- Bare metal core dump☆11Feb 23, 2019Updated 7 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Single header SPIR-V compressor for C and C++☆33Sep 29, 2016Updated 10 years ago
- Highly efficient implementation of elliptic curve 25519☆164Oct 5, 2022Updated 4 years ago
- A C implementation of Spritz, a spongy RC4-like stream cipher and hash function.☆28Jan 1, 2026Updated 10 months ago
- Encrypt strings and files symmetrically using Argon2id key derivation + AES-256 (GCM) or ChaCha20-Poly1305.☆10Aug 18, 2025Updated last year
- RFC 7539 compliant ChaCha20-Poly1305 AEAD implementation in plain C99☆41Oct 21, 2020Updated 6 years ago
- data compression library for embedded/real-time systems☆1,553May 19, 2024Updated 2 years ago
- High-speed secure pseudorandom function for short messages☆772Mar 7, 2026Updated 7 months ago