A go implementation of the STUN client (RFC 3489 and RFC 5389)
☆721Oct 12, 2026Updated 3 weeks ago
Alternatives and similar repositories for go-stun
Users that are interested in go-stun are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Fast RFC 5389 STUN implementation in go☆491May 17, 2021Updated 5 years ago
- Go implementation of STUN, TURN and ICE Protocols☆229Nov 19, 2017Updated 8 years ago
- A Go implementation of STUN☆864Updated this week
- A Go language client for the NAT-PMP internet protocol for port mapping and discovering the external IP address of a firewall.☆136Sep 4, 2026Updated last month
- Fast TURN and STUN server: cross-platform, hot reload, flexible config☆386Nov 1, 2020Updated 6 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A simple TUN/TAP library written in native Go.☆2,168Jul 30, 2024Updated 2 years ago
- Pion TURN, an API for building TURN clients and servers☆2,270Updated this week
- A crypto-secure Reliable-UDP library for Golang with FEC support.☆4,554Updated this week
- UPnP client library for Go (#golang)☆463Apr 27, 2025Updated last year
- A golang TURN dialer☆38Aug 2, 2017Updated 9 years ago
- Simple STUN server in go☆103Apr 29, 2021Updated 5 years ago
- WIP RFC 8445 ICE implementation in go☆100May 26, 2021Updated 5 years ago
- Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest …☆1,618May 12, 2026Updated 5 months ago
- libp2p implementation in Go☆6,902Updated this week
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Use anacrolix/go-libutp instead☆179Sep 8, 2026Updated last month
- Package stun provides basic functions for the manipulation of messages used in the Session Traversal Utilities for NAT (STUN), Traversal …☆37Jul 7, 2018Updated 8 years ago
- STUN and ICE implementations for the Go programming language☆53Jan 10, 2018Updated 8 years ago
- A production-ready QUIC implementation in pure Go☆11,823Updated this week
- A stream multiplexing library for Golang with minimal memory usage.☆1,614Updated this week
- reuse tcp/udp ports in golang☆807Aug 21, 2025Updated last year
- ☆17Nov 5, 2012Updated 13 years ago
- Kademlia/Mainline DHT node in Go.☆831Dec 26, 2020Updated 5 years ago
- A Python STUN client for getting NAT type and external IP☆451May 30, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A Go implementation of ICE☆622Updated this week
- WebRTC for Go☆454Mar 12, 2020Updated 6 years ago
- IPv4 and IPv6 userland network stack☆3,111Dec 10, 2019Updated 6 years ago
- DNS library in Go☆8,799Oct 1, 2026Updated last month
- A simple implements UPnP protocol for Go(Golang) library. Add port mapping for NAT devices. 在内网中搜索网关设备,检查网关是否支持upnp协议,若支持,添加端口映射。☆157Apr 29, 2022Updated 4 years ago
- Golang connection multiplexing library☆2,707Oct 12, 2026Updated 3 weeks ago
- RFC 5766 TURN implementation in go☆116May 8, 2020Updated 6 years ago
- NAT port mapping library for Go☆45Feb 13, 2020Updated 6 years ago
- coturn TURN server project☆14,533Updated this week
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Pure Go implementation of the WebRTC API☆16,872Updated this week
- Provides packet processing capabilities for Go☆6,798Mar 19, 2025Updated last year
- Reed-Solomon Erasure Coding in Go☆2,097Sep 25, 2026Updated last month
- RFC 4566 SDP implementation in go☆112May 3, 2020Updated 6 years ago
- Package vpx provides Go bindings for libvpx-1.6.0, the WebM Project VP8/VP9 codec implementation.☆196Feb 3, 2022Updated 4 years ago
- LevelDB key/value database in Go.☆6,316May 14, 2024Updated 2 years ago
- An HTTP proxy library for Go☆6,772Updated this week