A golang library for discovering the address of a LAN gateway.
☆250Sep 4, 2026Updated last month
Alternatives and similar repositories for gateway
Users that are interested in gateway are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A Go language client for the NAT-PMP internet protocol for port mapping and discovering the external IP address of a firewall.☆136Sep 4, 2026Updated last month
- Go implementation of bcrypt_pbkdf(3) from OpenBSD☆15Jun 27, 2026Updated 4 months ago
- ☆23Jan 17, 2015Updated 11 years ago
- Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.☆391Sep 23, 2026Updated last month
- Naively change a UDP stream to TCP.☆13Mar 18, 2017Updated 9 years ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- A simple TUN/TAP library written in native Go.☆2,168Jul 30, 2024Updated 2 years ago
- Golang wrappers of the C libvnc library//libvncserver.sourceforge.net/☆11Jan 8, 2014Updated 12 years ago
- UPnP client library for Go (#golang)☆463Apr 27, 2025Updated last year
- psutil for golang☆11,940Updated this week
- Run go programs as a service on major platforms.☆4,851Aug 29, 2026Updated 2 months ago
- Go package to minify HTML (alpha-quality)☆15Mar 30, 2024Updated 2 years ago
- Simple OS keychain bindings for password storage in Go (Golang)☆25May 16, 2017Updated 9 years ago
- Go library for generating XOAuth2 strings (for use in XOAUTH2 SASL auth schemes for IMAP/SMTP)☆12Sep 17, 2012Updated 14 years ago
- ICMP ping library for Go inspired by AnyEvent::FastPing Perl module☆584Jun 24, 2021Updated 5 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- ICMP Ping library for Go☆1,417Dec 2, 2024Updated last year
- A tun interface for windows ,drawin and linux written in golang.☆65May 25, 2016Updated 10 years ago
- An opinionated interface to your local Internet Gateway Device.☆78Dec 3, 2018Updated 7 years ago
- a cross platfrom Go library to place an icon and menu in the notification area☆3,729Jul 3, 2024Updated 2 years ago
- Go implementation of a Hash Array Map Trie☆28Oct 19, 2020Updated 6 years ago
- A go implementation of the STUN client (RFC 3489 and RFC 5389)☆721Oct 12, 2026Updated 3 weeks ago
- Provides packet processing capabilities for Go☆6,798Mar 19, 2025Updated last year
- Media search's code☆14Sep 15, 2018Updated 8 years ago
- win32 ole implementation for golang☆1,322Oct 12, 2026Updated 3 weeks ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Minimal Go UPnP InternetGatewayDevice library☆12Jul 14, 2020Updated 6 years ago
- Use anacrolix/go-libutp instead☆179Sep 8, 2026Updated last month
- A(nother) Bittorrent client written in the go programming language☆845Sep 4, 2026Updated last month
- SCTP wrapper for golang☆14Mar 12, 2017Updated 9 years ago
- Simple mDNS client/server library in Golang☆1,395Oct 19, 2026Updated 2 weeks ago
- NAT port mapping library for Go☆45Feb 13, 2020Updated 6 years ago
- GO binary I/O☆18Nov 10, 2019Updated 6 years ago
- v2rayW is a web client on v2ray☆19Aug 24, 2026Updated 2 months ago
- Serve HTML templates from go-bindata☆31Jan 23, 2017Updated 9 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- GopherLua: VM and compiler for Lua in Go☆6,998Apr 1, 2026Updated 7 months ago
- Build self-updating Golang programs☆2,271Jun 24, 2022Updated 4 years ago
- Optimized Go Compression Packages☆5,708Updated this week
- A Go language binding for encoding and decoding data in the bencode format that is used by the BitTorrent peer-to-peer file sharing proto…☆292Oct 11, 2026Updated 3 weeks ago
- Go wrapper of libutp reference uTP C implementation☆106Sep 11, 2026Updated last month
- Cross-platform filesystem notifications for Go.☆10,809May 11, 2026Updated 5 months ago
- PTY interface for Go☆2,106Jun 1, 2026Updated 5 months ago