Simple network namespace handling for go.
☆447May 20, 2026Updated 4 months ago
Alternatives and similar repositories for netns
Users that are interested in netns are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Simple netlink library for go.☆3,312Oct 2, 2026Updated last week
- Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK). MIT Licensed.☆1,082Updated this week
- cgroups package for Go☆1,195Sep 24, 2026Updated 2 weeks ago
- Go wrapper around iptables utility☆1,220Oct 15, 2024Updated last year
- This repository contains a Go module to interact with Linux nftables (the iptables successor).☆1,370Jul 3, 2026Updated 3 months ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- An OVSDB Client Library written in Golang☆212Oct 5, 2026Updated last week
- DHCPv6 and DHCPv4 packet library, client and server written in Go☆844Sep 1, 2026Updated last month
- ebpf-go is a pure-Go library to read, modify and load eBPF programs and attach them to various hooks in the Linux kernel.☆8,000Updated this week
- traffic control in pure go - it allows to read and alter queues, filters and classes☆532Sep 24, 2026Updated 2 weeks ago
- Utilities for manipulating POSIX capabilities in Go.☆114Jul 23, 2024Updated 2 years ago
- IPVS networking for containers (package derived from moby/libnetwork)☆110Feb 12, 2024Updated 2 years ago
- Go bindings for creating BPF programs.☆2,179Aug 31, 2023Updated 3 years ago
- Container Network Interface - networking for Linux containers☆6,135Sep 14, 2026Updated 3 weeks ago
- BGP implemented in the Go Programming Language☆4,115Updated this week
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Pure-Go Conntrack implementation; for humans.☆164Nov 12, 2025Updated 10 months ago
- A generic CNI library to provide APIs for CNI plugin interactions☆162Sep 3, 2026Updated last month
- networking for containers☆2,208Oct 20, 2023Updated 2 years ago
- Provides packet processing capabilities for Go☆6,793Mar 19, 2025Updated last year
- A simple TUN/TAP library written in native Go.☆2,167Jul 30, 2024Updated 2 years ago
- Go packages which enable interacting with Open vSwitch and related tools. Apache 2.0 Licensed.☆337Jul 3, 2026Updated 3 months ago
- OpenFlow Controller written in go.☆61May 11, 2025Updated last year
- Linux networking in Go☆598Aug 8, 2020Updated 6 years ago
- Some reference and example networking plugins, maintained by the CNI team.☆2,581Updated this week
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Go toolset for the VPP.☆262Updated this week
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆237May 24, 2026Updated 4 months ago
- ☆702Updated this week
- Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.☆424Feb 21, 2022Updated 4 years ago
- Node Resource Interface☆409Sep 9, 2026Updated last month
- DNS library in Go☆8,777Oct 1, 2026Updated last week
- Package ospf3 implements OSPFv3 (OSPF for IPv6) as described in RFC5340. MIT Licensed.☆20Feb 2, 2021Updated 5 years ago
- Package arp implements the ARP protocol, as described in RFC 826. MIT Licensed.☆392Sep 23, 2026Updated 2 weeks ago
- Sample controller using wrangler☆13Jan 4, 2022Updated 4 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- eBPF-based Networking, Security, and Observability☆25,628Updated this week
- Container Runtime Interface (CRI) – a plugin interface which enables kubelet to use a wide variety of container runtimes.☆477Updated this week
- Go bindings to systemd socket activation, journal, D-Bus, and unit files☆2,717Jul 23, 2026Updated 2 months ago
- A smart proxy to connect docker containers.☆397Oct 13, 2014Updated 11 years ago
- eBPF Utilities, Maps, and more☆254Mar 15, 2023Updated 3 years ago
- A simple ethtool "like" library for Go☆148Sep 14, 2026Updated 3 weeks ago
- c-binding free API for golang to communicate with the conntrack subsystem☆156Aug 22, 2026Updated last month