go library for CBOR Object Signing and Encryption (COSE)
☆67Oct 3, 2026Updated 2 weeks ago
Alternatives and similar repositories for go-cose
Users that are interested in go-cose are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- GitHub Actions for signing and verifying artifacts with Notation☆20Jan 12, 2026Updated 9 months ago
- SCITT API Emulator☆10Nov 22, 2024Updated last year
- An Architecture for Trustworthy Digital Supply Chain Transparency Services☆18Oct 19, 2025Updated 11 months ago
- Supply Chain Integrity Transparency and Trust ledger application using Confidential Consortium Framework (CCF)☆49Updated this week
- A collection of libraries for supporting sign and verify OCI artifacts. Based on Notary Project specifications.☆45Updated this week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Commercial quality COSE_Sign1 implementation in C for constrained environment. Works with MbtedTLS and OpenSSL Crypto.☆33May 5, 2026Updated 5 months ago
- ☆65May 15, 2024Updated 2 years ago
- RATS Architecture☆17Oct 27, 2025Updated 11 months ago
- Cross tooling and interoperability specifications☆178May 20, 2025Updated last year
- CoseSignTool is a platform-agnostic command line application to COSE sign files and validate COSE signatures. CoseHandler is a library o…☆55Sep 30, 2026Updated 2 weeks ago
- A CLI tool to sign and verify artifacts☆500Sep 25, 2026Updated 3 weeks ago
- API for TPM attestation and enrollment for certificates☆27Updated this week
- Sensor Measurement Lists (SenML) in Go☆16Mar 11, 2024Updated 2 years ago
- ORAS Go library☆294Updated this week
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- This repo is used for managing conversations about Veraison features☆53Jan 16, 2024Updated 2 years ago
- go library for CBOR Object Signing and Encryption (COSE)☆40Aug 18, 2022Updated 4 years ago
- IETF RATS terms cheat sheet☆12Feb 4, 2023Updated 3 years ago
- Attestation verification services based on Veraison components☆50Updated this week
- This project aims to standardize the representation and management of EOL and EOS product information across the industry.☆30Mar 4, 2024Updated 2 years ago
- Multi-language implementation of the Presentation Exchange protocol.☆10Nov 30, 2020Updated 5 years ago
- 📧 Implemented Keys, Algorithms (RFC9053), COSE (RFC9052) and CWT (RFC8392) in Go.☆24Sep 1, 2026Updated last month
- ORAS Python SDK☆70Oct 2, 2026Updated 2 weeks ago
- Witness Examples☆12Feb 27, 2024Updated 2 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Implementation of the Arm CCA attestation token in Rust☆15Updated this week
- ORAS (OCI registry as storage) container storage interface☆17Jun 5, 2024Updated 2 years ago
- Yet Another Data Access Layer: Accessing S3, POSIX in the same way. Deeply inspired by Databend's OpenDAL☆19Dec 9, 2022Updated 3 years ago
- Go implementation of The Update Framework heavily influenced by python-tuf☆14Mar 7, 2024Updated 2 years ago
- ORAS website and documentation☆25Updated this week
- ☆25Aug 6, 2026Updated 2 months ago
- go-ima is a tool that checks if a file has been tampered with. It is useful in ensuring integrity in CI systems☆14Sep 28, 2023Updated 3 years ago
- CBOR version of the JOSE specifications☆14Apr 4, 2017Updated 9 years ago
- vmnet based gvisor tcpip stack☆12Jan 22, 2024Updated 2 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Pure Go Permanent Storage For Open Telemetry Metrics, Traces and Logs, based on Compressed Roaring B-Tree Bitmaps, using Typescript as Q…☆17May 7, 2024Updated 2 years ago
- Comprehensive, powerful, commercial-quality CBOR encoder/ decoder that is still suited for small devices.☆241Updated this week
- Container Image Signing & Verifying on Ethereum [Testnet]☆17Mar 15, 2022Updated 4 years ago
- ☆32Dec 1, 2019Updated 6 years ago
- A proof-of-concept for how the SLSA Source Track could be implemented.☆19Updated this week
- WebAuthn server library decoupled from http for easy intergration, provides WebAuthn registration and authentication for clients using FI…☆46Aug 24, 2020Updated 6 years ago
- Implementation of cryptographic primitives in Go☆13Mar 13, 2023Updated 3 years ago