Suite of Tinkerbell Actions for use in Tinkerbell Workflows
☆37Sep 30, 2026Updated last week
Alternatives and similar repositories for actions
Users that are interested in actions are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- In-memory Operating System Installation Environment for Executing Tinkerbell Workflows☆131Jul 16, 2026Updated 2 months ago
- DHCP and iPXE Server☆343Dec 2, 2025Updated 10 months ago
- Instance Metadata Service☆117Dec 2, 2025Updated 10 months ago
- Cluster API Infrastructure Provider☆133Sep 30, 2026Updated last week
- Workflow Engine for provisioning Bare Metal☆986Dec 2, 2025Updated 10 months ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- ¯\_(ツ)_/¯☆13Jan 11, 2020Updated 6 years ago
- ☆14Apr 19, 2015Updated 11 years ago
- Crossplane provider for Cloud-init templating☆13Mar 13, 2023Updated 3 years ago
- A Modern automation platform☆183May 20, 2020Updated 6 years ago
- Package rfc4193 implements Unique Local IPv6 Unicast Address prefix generation, as described in RFC 4193. MIT Licensed.☆13May 12, 2020Updated 6 years ago
- A bare metal provider for the Kubernetes Cluster API☆13Dec 1, 2019Updated 6 years ago
- Cluster API Provider for KubeVirt☆185Sep 30, 2026Updated last week
- Experimental Terraform provider for Tinkerbell☆24May 18, 2022Updated 4 years ago
- Sharing of recipes and stories with the cloud-native family☆10Oct 11, 2020Updated 5 years ago
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- A simple honk twitter bot that reply honk slash command☆18Oct 27, 2020Updated 5 years ago
- Develop a Cloud Native application with python, fastapi and celery with Okteto☆15Nov 28, 2023Updated 2 years ago
- Package tftp implements a TFTP server, as described in RFC 1350. MIT Licensed.☆11Jun 19, 2015Updated 11 years ago
- cdk8s config management plugins support for ArgoCD☆18May 3, 2024Updated 2 years ago
- New way to think about distros☆14Nov 18, 2019Updated 6 years ago
- ☆14Dec 8, 2025Updated 10 months ago
- Redis constructs for cdk8s☆13Oct 3, 2026Updated last week
- Hub for Mozilla Looker models☆18Oct 4, 2026Updated last week
- ☆12Feb 2, 2026Updated 8 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- ☆12Apr 4, 2022Updated 4 years ago
- Package mptcp provides detection functionality for active, multipath TCP connections from a remote client to the current host. MIT Licen…☆17May 19, 2015Updated 11 years ago
- Package block enables programmatic access to block devices. MIT Licensed.☆22Oct 25, 2018Updated 7 years ago
- Example deployments of the Tinkerbell Stack for use as playground environments☆143Updated this week
- A node adapter for the fs-db mixin for js-git.☆18Jun 4, 2021Updated 5 years ago
- A tool to help you upgrade Cluster API v1alpha2 clusters☆32Sep 24, 2021Updated 5 years ago
- Packet filter written in Rust☆10Feb 20, 2022Updated 4 years ago
- A versioned collection of snippets showing how to use client-go☆10Sep 3, 2017Updated 9 years ago
- An in-memory installation environment for bare metal.☆99Oct 30, 2021Updated 4 years ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Minimal WSL distro for Rancher Desktop☆23Oct 3, 2026Updated last week
- Service implementation for a Kubernetes Dynamic Webhook controller for interacting with Anchore☆65Updated this week
- Package ospf3 implements OSPFv3 (OSPF for IPv6) as described in RFC5340. MIT Licensed.☆20Feb 2, 2021Updated 5 years ago
- Dockerized setup of SSH with a Certificate Authority and Principals configured☆16Apr 20, 2022Updated 4 years ago
- gRPC API definitions for µONOS☆17Sep 9, 2024Updated 2 years ago
- A P4 implementation of a 5G UPF for BMv2☆15Oct 11, 2021Updated 5 years ago
- GCC 7.x & 8.x compiler & Binutils build scripts☆15Oct 26, 2020Updated 5 years ago