Pure Java implementation of EdDSA
☆233Aug 12, 2023Updated 3 years ago
Alternatives and similar repositories for ed25519-java
Users that are interested in ed25519-java are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Pure Java implementation of Ed25519☆23Mar 3, 2023Updated 3 years ago
- Pure Java and JNI backed Curve25519 implementation.☆239Apr 29, 2022Updated 4 years ago
- Pure Java implementation of curve25519, salsa20, hsalsa20, xsalsa20 and poly1305 cryptographic primitives, along with a NaCl "Box" implem…☆112Oct 16, 2023Updated 3 years ago
- Java URN as in RFC 2141☆22Updated this week
- libsodium-jna is a java library that binds to libsodium C crypto APIs with Java Native Access (JNA)☆58Sep 27, 2026Updated last month
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A Java library for working with Bitcoin Cash☆13Apr 13, 2018Updated 8 years ago
- Applet for testing ecc curves☆25Mar 20, 2019Updated 7 years ago
- Plain Java implementation of the Noise protocol☆151Mar 28, 2024Updated 2 years ago
- A statistic driven minecraft killaura detection KI☆10Mar 23, 2017Updated 9 years ago
- A Java port of TweetNaCl from the original C☆27May 31, 2026Updated 4 months ago
- BIP32-Ed25519 HD wallets for java☆17Feb 23, 2019Updated 7 years ago
- TweetNaCl in Java - a port of TweetNaCl-js☆52Feb 3, 2023Updated 3 years ago
- Java binding to the Networking and Cryptography (NaCl) library with the awesomeness of libsodium☆220Sep 12, 2023Updated 3 years ago
- Open source JavaScript Bitcoin, Testnet and Litecoin wallet☆13May 17, 2017Updated 9 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Java implementation of the BLAKE2b cryptographic hash function☆84Nov 21, 2022Updated 3 years ago
- A blake2s java implementation☆19Jan 31, 2016Updated 10 years ago
- Chacha20Poly1305 AEAD☆17Mar 15, 2015Updated 11 years ago
- Portable C implementation of Ed25519, a high-speed high-security public-key signature system.☆576Oct 2, 2022Updated 4 years ago
- Pure Java implementation of group operations on ristretto255 and Curve25519☆31Apr 18, 2023Updated 3 years ago
- Java implementation of multiaddr☆20Updated this week
- A pure Java implementation of BLAKE2 (RFC 7693)☆14Sep 12, 2023Updated 3 years ago
- Fixes the recent exploit of CustomPayload packet that causes server to crash☆13Mar 6, 2018Updated 8 years ago
- Execute commands only if a condition is met.☆11Dec 28, 2023Updated 2 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Bouncy Castle Java Distribution (Mirror)☆2,709Updated this week
- A standalone Java 7 implementation of HMAC-based key derivation function (HKDF) defined in RFC 5869 first described by Hugo Krawczyk. HKD…☆73Feb 12, 2024Updated 2 years ago
- Implementations of a fast Elliptic-curve Digital Signature Algorithm☆193Apr 21, 2020Updated 6 years ago
- Assorted I2P tools and scripts☆18May 7, 2017Updated 9 years ago
- A Java implementation of Multihash☆53Sep 8, 2026Updated last month
- Ed25519 for Swift 3.x☆18May 15, 2018Updated 8 years ago
- A pure-Java implementation of the NaCl cryptography library☆39Feb 24, 2026Updated 8 months ago
- ☆36Jul 5, 2018Updated 8 years ago
- Simple anti-tamper embedded into a simple string encryption.☆10Mar 7, 2019Updated 7 years ago
- Open source password manager - Proton Pass • AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- Cross platform password manager.☆17Jul 21, 2023Updated 3 years ago
- Obfuscated/clearable in memory string management☆46Aug 16, 2023Updated 3 years ago
- openwallet supported crypto library☆22Dec 3, 2023Updated 2 years ago
- Java implementation of FIPS 202, SHA3-xxxx, SHAKE128, SHAKE256☆20Oct 13, 2020Updated 6 years ago
- Semux Core☆77May 6, 2021Updated 5 years ago
- naive bayes based text classifier, machine learning☆11Feb 18, 2013Updated 13 years ago
- A Barebones Java client for AWS S3☆22Oct 20, 2026Updated last week