A standalone Java 7 implementation of HMAC-based key derivation function (HKDF) defined in RFC 5869 first described by Hugo Krawczyk. HKDF follows the "extract-then-expand" paradigm which is compatible to NIST 800-56C Rev. 1 two step KDF
☆73Feb 12, 2024Updated 2 years ago
Alternatives and similar repositories for hkdf
Users that are interested in hkdf are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Implementation of the single-step key derivation function (KDF) as described in NIST Special Publication 800-56C Rev1 supporting messages…☆10Updated this week
- A shared preference implementation for confidential data in Android. Per default uses AES-GCM, BCrypt and HKDF as cryptographic primitive…☆308Apr 1, 2023Updated 3 years ago
- A Java implementation of AES-GCM-SIV (RFC 8452).☆37Apr 18, 2019Updated 7 years ago
- Cymric - Portable secure random number generator☆21Mar 10, 2014Updated 12 years ago
- Java implementation of the authenticated encryption algorithm Ascon☆20Oct 24, 2023Updated 2 years ago
- Simple, predictable pricing with DigitalOcean hosting • AdAlways know what you'll pay with monthly caps and flat pricing. Enterprise-grade infrastructure trusted by 600k+ customers.
- A cryptographically secure pseudorandom number generator cli tool printing in a wide variety of byte encodings (hex, base64,..) and for m…☆15Sep 25, 2023Updated 3 years ago
- Optimized (fast) Java Keccak/SHA3/SHAKED implementation☆14Oct 12, 2020Updated 5 years ago
- Implementing the blind RSA scheme in Java☆15Nov 2, 2025Updated 11 months ago
- Committing ChaCha20-BLAKE3, XChaCha20-BLAKE3, and XChaCha20-BLAKE3-SIV AEAD implementations.☆13Apr 11, 2022Updated 4 years ago
- Java library for packaging native libraries, executables, and resources for runtime within jar files☆19Dec 3, 2025Updated 10 months ago
- Tapestry CSRF Protection☆11Sep 23, 2025Updated last year
- An unoptimized BLAKE3 implementation in Java☆32Aug 19, 2021Updated 5 years ago
- Many best in class pseudo random generators grouped into one simple library.☆15Jan 1, 2026Updated 9 months ago
- Scalable Java Disque client☆36Jul 2, 2016Updated 10 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Py-SSA-Lib: Python implementation of the multichannel singular spectrum analysis (MSSA) and singular spectrum analysis (SSA)☆14Sep 22, 2026Updated 2 weeks ago
- A pure-Java implementation of the NaCl cryptography library☆39Feb 24, 2026Updated 7 months ago
- ☆24May 14, 2025Updated last year
- A modern cryptographic library for .NET 8+ based on libsodium and inspired by Monocypher.☆62Sep 5, 2026Updated last month
- Java implementation of the BLAKE2b cryptographic hash function☆84Nov 21, 2022Updated 3 years ago
- RFC 5297 SIV mode of operation in Java☆52Updated this week
- Enhanced TestNG integration with Xray Test Management for Jira☆10Sep 11, 2026Updated 3 weeks ago
- Specification for the AEGIS family of authenticated encryption algorithms.☆23Oct 2, 2026Updated last week
- Apache Spark based framework for analysis A/B experiments☆15Nov 3, 2024Updated last year
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- A random data generator to produce realistic data files for multiple file types (e.g. csv, log, json)☆14May 18, 2023Updated 3 years ago
- The bare minimum code that one will have to write to build a working sync adapter for an android app.☆10Dec 22, 2017Updated 8 years ago
- Entelgy Integration Testing Tool☆10Jul 13, 2017Updated 9 years ago
- Companion repo of Bazel Blog posts: https://tulipemoutarde.be/posts/bazel-for-mobile-apps-part-1/☆14Jul 18, 2018Updated 8 years ago
- Pure Java implementation of EdDSA☆233Aug 12, 2023Updated 3 years ago
- Jakarta Authentication☆27Updated this week
- This project aim to convert video files to different encrypted pieces and play via only in built player,just like offline download videos…☆13Jan 28, 2019Updated 7 years ago
- Kotlin Multiplatform library implements Myers algorithm for diff calculations.☆11Aug 23, 2020Updated 6 years ago
- A Java standalone implementation of the bcrypt password hash function. Based on the Blowfish cipher it is the default password hash algor…☆577Mar 30, 2025Updated last year
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- A Java templating engine, similar in syntax to Jinja.☆12May 22, 2020Updated 6 years ago
- Service that manages backfill state, calling into other services to do batched work☆38Oct 1, 2026Updated last week
- Proof of concept of a "linker plugin" enabling some reflection for Scala.js☆12Oct 18, 2016Updated 9 years ago
- A collection of cds software artefacts in Java language☆13Feb 28, 2025Updated last year
- Security functionality for interoperability/interaction with core services.☆14Jan 27, 2025Updated last year
- ☆23Sep 16, 2026Updated 3 weeks ago
- Encrypts long values (64 bit) and UUIDs (128 bit)☆10Feb 6, 2023Updated 3 years ago