Libnice is an implementation of the IETF's Interactive Connectivity Establishment (ICE) standard (RFC 5245) and the Session Traversal Utilities for NAT (STUN) standard (RFC 5389). It provides a GLib-based library, libnice and a Glib-free library, libstun as well as GStreamer elements. ICE is useful for applications that want to establish peer-…
☆74Apr 8, 2015Updated 11 years ago
Alternatives and similar repositories for libnice
Users that are interested in libnice are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A lightweight user land implementation of the UDP/IPv4 stack designed to plug into the netmap framework. The 's' stands for speed.☆10Dec 11, 2024Updated last year
- P2P Video Streaming Project☆13Apr 16, 2013Updated 13 years ago
- Toolkit library for asynchronous network IO with protocol stacks including SIP, SDP, RTP, STUN, TURN, ICE, BFCP and DNS.☆41Mar 30, 2013Updated 13 years ago
- a list of ip route for gfw-blocked websites☆11Jun 8, 2011Updated 15 years ago
- Implementation of RFC5766 and RFC5389☆78Jul 20, 2017Updated 9 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- [DEPRECATED] SIP Swiss army knife☆19Oct 25, 2019Updated 7 years ago
- Standalone WebRTC-based NAT traversal☆97Aug 10, 2018Updated 8 years ago
- EXPERIMENTAL, INCOMPLETE: Node and browserify compatible integration layer for the Janus WebRTC gateway☆15Feb 21, 2014Updated 12 years ago
- STUN & TURN client demo and api with python and C☆97Apr 19, 2012Updated 14 years ago
- FSO Website☆10Apr 16, 2015Updated 11 years ago
- Low-latency live streaming PoC☆11Jul 30, 2019Updated 7 years ago
- Minimalistic STUN client☆20Apr 22, 2015Updated 11 years ago
- Miscellaneous excellent public domain C code from Sean Barrett.☆19Feb 13, 2014Updated 12 years ago
- Libraries for NAT traversal and hole punching☆73Dec 26, 2016Updated 9 years ago
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- PJSIP is Open Source SIP, Media, and NAT Traversal Library☆503Dec 16, 2020Updated 5 years ago
- perform a static stateless 2-way NAT with iptables☆14Dec 27, 2014Updated 11 years ago
- [DEPRECATED] Kernel-based media relay for Kamailio☆37Feb 15, 2017Updated 9 years ago
- Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest …☆1,618May 12, 2026Updated 5 months ago
- clone repo https://sourceforge.net/p/mcumediaserver/code/HEAD/tree/ doc: https://github.com/atyenoria/MCU-Media-Server/blob/master/Inst…☆11Sep 4, 2016Updated 10 years ago
- digital audio processing on GPU using OpenCL☆12May 23, 2015Updated 11 years ago
- Video Conferencing Server, based on openmcu-ru☆15May 1, 2014Updated 12 years ago
- Hawk HTTP Authorization for Django Rest Framework☆19Jul 28, 2020Updated 6 years ago
- A cross-platform game library in the public domain☆15Aug 12, 2019Updated 7 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A theme for Sublime accompanying the Facebook color scheme☆14Dec 4, 2013Updated 12 years ago
- A program that tunnels TCP/IP connections in a variety of ways, including through HTTP and SOCKS5 proxy servers.☆34Mar 20, 2016Updated 10 years ago
- libmaxminddb binding for Ruby☆10Updated this week
- A simple, lightweight, public-domain secure random number generator☆17Feb 21, 2015Updated 11 years ago
- A modified version of Sipdroid v2.9 with support for AAC and Opus as well as file streaming (wav/aac/mp4/mp3) and packet duplication/inte…☆14Feb 19, 2014Updated 12 years ago
- WebRTC mirror☆20Jul 21, 2012Updated 14 years ago
- libjingle clone of the original svn with some local patches.☆317Feb 23, 2013Updated 13 years ago
- C++ implementation of SIP, ICE, TURN and related protocols.☆796Updated this week
- 局域网通讯的软件,支持文字、语音聊天、文件、文件夹传送功能。☆14Aug 22, 2019Updated 7 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A Python STUN client for getting NAT type and external IP☆451May 30, 2025Updated last year
- Package stun provides basic functions for the manipulation of messages used in the Session Traversal Utilities for NAT (STUN), Traversal …☆37Jul 7, 2018Updated 8 years ago
- Configurations for tinc on routers, for bypassing GFW in China. Can be used to replace OpenVPN solutions.☆17Oct 20, 2014Updated 12 years ago
- standalone audio conferencing server based on resiprocate/recon 1.8 release series☆16Mar 7, 2018Updated 8 years ago
- qq bot that bridges qqgroups and IRC channels☆13Dec 27, 2012Updated 13 years ago
- Path finding and following in Unreal Engine☆12Jan 8, 2023Updated 3 years ago
- C library for efficient string matching with Aho-Corasick☆21Jan 20, 2012Updated 14 years ago