A java library for implementing Time-based One Time Passwords for Multi-Factor Authentication.
☆554Jul 30, 2024Updated 2 years ago
Alternatives and similar repositories for java-totp
Users that are interested in java-totp are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A one-time password (HOTP/TOTP) library for Java☆505Oct 1, 2026Updated 2 weeks ago
- Two Factor Authentication Java code implementing the Time-based One-time Password Algorithm☆330Dec 9, 2022Updated 3 years ago
- A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).☆243Jul 3, 2026Updated 3 months ago
- Google Authenticator Server side code☆1,106Aug 14, 2026Updated 2 months ago
- Maven plugin with jooq, liquibase and postgres☆11Aug 15, 2023Updated 3 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- This is an example nats-wrapper for Java!☆11Mar 18, 2023Updated 3 years ago
- Java library for representing, parsing and encoding URNs as in RFC2141 and RFC8141 (Maintained by @claussni)☆36Dec 30, 2025Updated 9 months ago
- ☆50Nov 8, 2024Updated last year
- All your APIs belong to me - API Security Demos☆33Jul 30, 2025Updated last year
- Google Authenticator compatible 2-Factor Auth in Java☆35Apr 12, 2019Updated 7 years ago
- Set of alternative routing implementations for Javalin 5.x, 6.x & 7.x☆22Aug 12, 2026Updated 2 months ago
- ☆14Mar 15, 2024Updated 2 years ago
- Distributed currencies system made with Lettuce (Redis)☆34Aug 20, 2026Updated last month
- Apache maven☆33Oct 8, 2026Updated last week
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Java library to detect files' MIME types☆60Oct 8, 2023Updated 3 years ago
- A portable Java library for WebAuthn(Passkeys) server side verification☆595Oct 8, 2026Updated last week
- Java Barcode Image Generation Library☆29Jul 28, 2025Updated last year
- ☆176Nov 7, 2018Updated 7 years ago
- In this project, we will use LocalStack to locally simulate some services provided by AWS Cloud such as OpenSearch, S3, and Secrets Manag…☆11Jan 21, 2026Updated 8 months ago
- A high performance caching library for Java☆17,892Updated this week
- An example using JobRunr, Spring Data and DocxStamper to generate all the salary slips of Acme Corp☆13Aug 4, 2023Updated 3 years ago
- Server-side Web Authentication library for Java https://www.w3.org/TR/webauthn/#rp-operations☆565Updated this week
- Lightweight, high performance Java caching☆745Jul 22, 2025Updated last year
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Very simple serializer built for my purposes. Currently has built-in support for MessagePack and BSON.☆12May 2, 2020Updated 6 years ago
- Memory Store is a full-featured indexed Java Collection capable of ultra-fast data lookup.☆22Oct 12, 2023Updated 3 years ago
- [EXPERIMENTAL - IN DEVELOPMENT] Use Cranelift to compile Wasm☆32Aug 3, 2026Updated 2 months ago
- Experimental compound SQL framework with type-safe DSL API generated at compile-time from annotation based schema diff☆52Jun 13, 2026Updated 4 months ago
- User Management Application build with Spring Boot, Thymeleaf & MySQL Database☆12Dec 20, 2024Updated last year
- Tutorial/hands-on lab for getting started with Docker Swarm☆10Nov 9, 2016Updated 9 years ago
- Customized version of the spring authorization server☆82Jan 25, 2026Updated 8 months ago
- Microservice arch deployed as monolith☆76Mar 31, 2026Updated 6 months ago
- Config library #216 - this one uses Lombok though. POJOs from/to YAML/XML/Properties/INI/TOML/HJSON/JSON.☆133Apr 27, 2026Updated 5 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Mirror of https://bitbucket.org/snakeyaml/snakeyaml-engine☆18Oct 3, 2026Updated 2 weeks ago
- Useful thread-safe collections with performance in mind for Java 8+.☆31Sep 25, 2026Updated 3 weeks ago
- ☆41May 3, 2026Updated 5 months ago
- Squiggle SQL - little Java library for dynamic generation of SQL queries.☆18Mar 24, 2024Updated 2 years ago
- Password policy enforcement for Java.☆319Apr 6, 2026Updated 6 months ago
- Reactive X Coroutine X Performance Test ⚡️☆14Aug 1, 2021Updated 5 years ago
- Tomato Architecture - A pragmatic approach to software development☆20Nov 19, 2025Updated 10 months ago