A one-time password (HOTP/TOTP) library for Java
☆505Oct 1, 2026Updated 2 weeks ago
Alternatives and similar repositories for java-otp
Users that are interested in java-otp are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A java library for implementing Time-based One Time Passwords for Multi-Factor Authentication.☆554Jul 30, 2024Updated 2 years ago
- A small and easy-to-use one-time password generator library for Java implementing RFC 4226 (HOTP) and RFC 6238 (TOTP).☆243Jul 3, 2026Updated 3 months ago
- Google Authenticator Server side code☆1,106Aug 14, 2026Updated 2 months ago
- Two Factor Authentication Java code implementing the Time-based One-time Password Algorithm☆330Dec 9, 2022Updated 3 years ago
- Spring Security Login with Google Authenticator (Time-based One-time Password Algorithm, TOTP)☆85Oct 4, 2026Updated 2 weeks ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Send push notifications asynchronously in your vertx application with OneSignal.☆16Oct 12, 2020Updated 6 years ago
- TOTP算法,基于时间戳和共同密钥生成动态验证码的算法☆78Aug 9, 2017Updated 9 years ago
- Time-Based One-Time Password Algorithm Java Library☆20Apr 16, 2018Updated 8 years ago
- Lightweight, high performance Java caching☆745Jul 22, 2025Updated last year
- Official Java Client for Ipregistry, a Fast, Reliable IP Geolocation and Threat Data API.☆16Aug 17, 2026Updated 2 months ago
- Easy Graphql Testing in Java☆26Nov 13, 2025Updated 11 months ago
- Gradle plugin for installing Git hooks.☆13Jun 17, 2023Updated 3 years ago
- A Java library for reversibly obfuscating numerical identifiers (e.g. 1234 ↔ 4TQCNTL)☆39May 12, 2021Updated 5 years ago
- This is an essential example to build react-native app using Typescript and Redux Saga☆13Jun 24, 2019Updated 7 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- java and spring boot examples☆17Jan 4, 2026Updated 9 months ago
- Java rate limiting library based on token-bucket algorithm.☆2,813Oct 4, 2026Updated 2 weeks ago
- This repository contains instructions to develop a secure, enterprise-grade Ionic/Cordova based hybrid mobile app that connects to CouchD…☆15Apr 20, 2019Updated 7 years ago
- Java 9-28 Hackery, destroys module system + reflection filters☆58Aug 25, 2026Updated last month
- A Java library for quickly and efficiently parsing and writing UUIDs☆175Jan 14, 2023Updated 3 years ago
- JHipster Works with Spring Native!☆24Mar 2, 2022Updated 4 years ago
- Cloudant SDK for Java☆28Updated this week
- Integration between Micronaut and JMS☆17Updated this week
- Java library for representing, parsing and encoding URNs as in RFC2141 and RFC8141 (Maintained by @claussni)☆36Dec 30, 2025Updated 9 months ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- 光 HikariCP・A solid, high-performance, JDBC connection pool at last.☆21,239Jun 14, 2026Updated 4 months ago
- Analyze Slack Channel history by counting threads with specified keywords☆12Feb 3, 2022Updated 4 years ago
- AWT Color Factory☆11Aug 2, 2020Updated 6 years ago
- PowerAuth Server component is the back-end counterpart of PowerAuth Mobile SDK that holds device registrations and verifies MFA signature…☆22Updated this week
- A light yet complete and fast packet injector for Spigot servers.☆13Oct 26, 2024Updated last year
- Resilience4j is a fault tolerance library designed for Java8 and functional programming☆10,787Oct 7, 2026Updated last week
- eckes' TOTP Java soft token☆24Oct 23, 2020Updated 5 years ago
- Lightweight slime library to implement the Slime World Format described in DevBlog 5# from Hypixel.☆31Jan 9, 2025Updated last year
- Fault tolerance and resilience patterns for the JVM☆4,314Dec 28, 2025Updated 9 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Java cryptographic library that supports Argon2, bcrypt, scrypt and PBKDF2 aimed to protect passwords in databases. Easy to use by design…☆435Apr 16, 2026Updated 6 months ago
- Minimal and smart URI builder for Java☆20Dec 7, 2023Updated 2 years ago
- Native Operating System and Hardware Information☆5,271Updated this week
- Runtime code generation for the Java virtual machine.☆6,897Updated this week
- Server-side Web Authentication library for Java https://www.w3.org/TR/webauthn/#rp-operations☆565Updated this week
- Small Netty-based server application that consumes AMQP messages from a broker and forwards it to websocket clients☆16Feb 9, 2012Updated 14 years ago
- An example using JobRunr, Spring Data and DocxStamper to generate all the salary slips of Acme Corp☆13Aug 4, 2023Updated 3 years ago