Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.
β1,122Jul 23, 2024Updated 2 years ago
Alternatives and similar repositories for http-status-codes
Users that are interested in http-status-codes are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Create HTTP Errorsβ1,559Jun 1, 2026Updated 4 months ago
- π· Super-agent driven library for testing node.js HTTP servers using a fluent API. Maintained for @forwardemail, @ladjs, @spamscanner, β¦β14,401Updated this week
- TypeScript execution and REPL for node.jsβ13,115Jul 18, 2024Updated 2 years ago
- Loads environment variables from .env for nodejs projects.β20,548Updated this week
- Generate RFC-compliant UUIDs in JavaScriptβ15,340Updated this week
- Managed Kubernetes at scale on DigitalOcean β’ AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- The most powerful data validation library for JSβ21,166Updated this week
- JsonWebToken implementation for node.js http://self-issued.info/docs/draft-ietf-oauth-json-web-token.htmlβ18,181Jun 25, 2026Updated 3 months ago
- π² super fast, all natural json loggerβ18,252Oct 6, 2026Updated last week
- Environment variable validation for Node, Bun, and other compatible JS runtimesβ1,589Sep 20, 2026Updated 3 weeks ago
- Git hooks made easy πΆ woof!β35,354Mar 19, 2026Updated 6 months ago
- A logger for just about everything.β24,526Jul 20, 2026Updated 2 months ago
- Help secure Express apps with various HTTP headersβ10,736Oct 4, 2026Updated 2 weeks ago
- Parse and stringify URL query stringsβ6,907Sep 1, 2026Updated last month
- A Jest transformer with source map support that lets you use Jest to test projects written in TypeScript.β7,071Updated this week
- Open source password manager - Proton Pass β’ AdSecurely store, share, and autofill your credentials with Proton Pass, the end-to-end encrypted password manager trusted by millions.
- Dead simple Object schema validationβ23,657Updated this week
- String validationβ23,738Sep 11, 2026Updated last month
- π Cross platform setting of environment scriptsβ6,521Nov 16, 2025Updated 11 months ago
- HTTP server mocking and expectations library for Node.jsβ13,128Updated this week
- Load node modules according to tsconfig paths, in run-time or via API.β1,908Feb 23, 2026Updated 7 months ago
- Monorepo for all the tooling which enables ESLint to support TypeScriptβ16,427Updated this week
- TypeScript-first schema validation with static type inferenceβ44,148Updated this week
- ESLint plugin with rules that help validate proper imports.β5,953Aug 23, 2026Updated last month
- Tiny millisecond conversion utilityβ5,560May 20, 2026Updated 4 months ago
- GPUs on demand by Runpod - Special Offer Available β’ AdRun AI, ML, and HPC workloads on powerful cloud GPUsβwithout limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- Delightful JavaScript Testing.β45,485Updated this week
- π«π© β Run tasks like formatters and linters against staged git filesβ14,742Sep 26, 2026Updated 3 weeks ago
- Decorator-based property validation for classes.β11,844Mar 25, 2026Updated 6 months ago
- Check your npm module for unused dependenciesβ4,912Feb 27, 2025Updated last year
- The ultimate javascript content-type utility.β1,478Jun 2, 2026Updated 4 months ago
- A collection of essential TypeScript typesβ17,458Updated this week
- Node.js CORS middlewareβ6,194Jun 2, 2026Updated 4 months ago
- A `rm -rf` util for nodejsβ5,854May 15, 2026Updated 5 months ago
- yargs the modern, pirate-themed successor to optimist.β11,505Updated this week
- Deploy on Railway without the complexity - Free Credits Offer β’ AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- β‘οΈ TypeScript Execute | The easiest way to run TypeScript in Node.jsβ12,167Sep 25, 2026Updated 3 weeks ago
- β³ Modern JavaScript date utility library βοΈβ36,647Sep 22, 2026Updated 3 weeks ago
- HTTP request logger middleware for node.jsβ8,201Updated this week
- π Human-friendly and powerful HTTP request library for Node.jsβ14,953Updated this week
- The fastest JSON schema Validator. Supports JSON Schema draft-04/06/07/2019-09/2020-12 and JSON Type Definition (RFC8927)β14,865Sep 6, 2026Updated last month
- TypeScript & JavaScript ORM for Node.js β supports PostgreSQL, MySQL, MariaDB, SQLite, SQL Server, Oracle, and more.β36,665Updated this week
- A CLI tool to run multiple npm-scripts in parallel or sequential.β5,834Aug 15, 2024Updated 2 years ago