Utility to interact with HTTP status code in Node.js
☆483Jan 21, 2026Updated 9 months ago
Alternatives and similar repositories for node-http-status
Users that are interested in node-http-status are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are …☆1,120Jul 23, 2024Updated 2 years ago
- 🕷 Super-agent driven library for testing node.js HTTP servers using a fluent API. Maintained for @forwardemail, @ladjs, @spamscanner, …☆14,406Oct 13, 2026Updated 2 weeks ago
- Simple JavaScript options parser inspired by yargs☆21Sep 13, 2026Updated last month
- Help secure Express apps with various HTTP headers☆10,742Updated this week
- HTTP request logger middleware for node.js☆8,202Oct 16, 2026Updated last week
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Loads environment variables from .env for nodejs projects.☆20,556Oct 22, 2026Updated last week
- JsonWebToken implementation for node.js http://self-issued.info/docs/draft-ietf-oauth-json-web-token.html☆18,182Jun 25, 2026Updated 4 months ago
- An express.js middleware for validator.js.☆6,234Oct 3, 2026Updated 3 weeks ago
- Resolve a directory that is either local, global or in the user's home directory.☆14Aug 5, 2017Updated 9 years ago
- Return true if the file is (or the file path has) a dotfile.☆14May 30, 2017Updated 9 years ago
- HTTP status utility☆283Jan 3, 2026Updated 9 months ago
- A tiny JavaScript debugging utility modelled after Node.js core's debugging technique. Works in Node.js and web browsers☆11,458Oct 14, 2026Updated 2 weeks ago
- String validation☆23,744Sep 11, 2026Updated last month
- A logger for just about everything.☆24,527Jul 20, 2026Updated 3 months ago
- Simple, predictable pricing with DigitalOcean hosting • AdAlways know what you'll pay with monthly caps and flat pricing. Enterprise-grade infrastructure trusted by 600k+ customers.
- wait-on is a cross-platform command line utility and Node.js API which will wait for files, ports, sockets, and http(s) resources to beco…☆1,988Oct 20, 2026Updated last week
- Git hooks made easy 🐶 woof!☆35,371Mar 19, 2026Updated 7 months ago
- 🚰 Convert streaming iterables to Node.js streams☆23Aug 17, 2023Updated 3 years ago
- The most powerful data validation library for JS☆21,166Updated this week
- ✉️ Send e-mails with Node.JS – easy as cake!☆17,697Updated this week
- HTTP server mocking and expectations library for Node.js☆13,134Oct 20, 2026Updated last week
- Create HTTP Errors☆1,560Jun 1, 2026Updated 4 months ago
- 🚫💩 — Run tasks like formatters and linters against staged git files☆14,752Sep 26, 2026Updated last month
- 🔀 Cross platform setting of environment scripts☆6,520Nov 16, 2025Updated 11 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- TypeScript execution and REPL for node.js☆13,118Jul 18, 2024Updated 2 years ago
- Node.js CORS middleware☆6,194Jun 2, 2026Updated 4 months ago
- Node.js compression middleware☆2,806Oct 1, 2026Updated 3 weeks ago
- Like `require-in-the-middle`, but for ESM import☆173Updated this week
- Generate RFC-compliant UUIDs in JavaScript☆15,345Oct 23, 2026Updated last week
- 🐈 CLI app helper☆3,719Jul 21, 2026Updated 3 months ago
- A function to extract any colors from a string☆11Apr 5, 2020Updated 6 years ago
- Find newer versions of package dependencies than what your package.json allows☆10,323Updated this week
- 🌲 super fast, all natural json logger☆18,275Oct 6, 2026Updated 3 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Basic rate-limiting middleware for the Express web server☆3,315Updated this week
- Full featured CSV parser with simple api and tested against large datasets.☆4,287Oct 22, 2026Updated last week
- 🚀 Realtime Monitoring solution for Node.js/Express.js apps, inspired by status.github.com, sponsored by https://dynobase.dev☆3,614Feb 16, 2026Updated 8 months ago
- glob functionality for node.js☆8,708Updated this week
- Tiny millisecond conversion utility☆5,559May 20, 2026Updated 5 months ago
- The future of Node.js REST development☆10,689Updated this week
- Bluebird is a full featured promise library with unmatched performance.☆20,468Nov 7, 2024Updated last year