async/await support for ExpressJS
β901Sep 5, 2022Updated 4 years ago
Alternatives and similar repositories for express-async-errors
Users that are interested in express-async-errors are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- π· Super-agent driven library for testing node.js HTTP servers using a fluent API. Maintained for @forwardemail, @ladjs, @spamscanner, β¦β14,410Updated this week
- HTTP request logger middleware for node.jsβ8,202Oct 16, 2026Updated 2 weeks ago
- Async Error Handling Middleware for Expressβ581Sep 27, 2023Updated 3 years ago
- JsonWebToken implementation for node.js http://self-issued.info/docs/draft-ietf-oauth-json-web-token.htmlβ18,182Jun 25, 2026Updated 4 months ago
- bcrypt for NodeJsβ7,805Apr 14, 2026Updated 6 months ago
- GPUs on demand by Runpod - Special Offer Available β’ AdRun AI, ML, and HPC workloads on powerful cloud GPUsβwithout limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- Loads environment variables from .env for nodejs projects.β20,557Updated this week
- mongoose-unique-validator is a plugin which adds pre-save validation for unique fields within a Mongoose schema.β543Jul 28, 2026Updated 3 months ago
- Basic rate-limiting middleware for the Express web serverβ3,314Updated this week
- Node.js middleware for handling `multipart/form-data`.β12,090Oct 22, 2026Updated last week
- Help secure Express apps with various HTTP headersβ10,744Updated this week
- Adds middleware to your express app to serve the Swagger UI bound to your Swagger document. This acts as living documentation for your APβ¦β1,494Jan 25, 2025Updated last year
- Node.js CORS middlewareβ6,194Jun 2, 2026Updated 5 months ago
- The most powerful data validation library for JSβ21,166Updated this week
- Premium Queue package for handling distributed jobs and messages in NodeJS.β16,260Oct 17, 2026Updated 2 weeks ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits β’ AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- Compiles your TS app and restarts when files are modified.β3,425Jun 14, 2024Updated 2 years ago
- Let's pretend we have a real MongoDBβ240Mar 1, 2023Updated 3 years ago
- A joi validation middleware for Express.β1,347Sep 29, 2026Updated last month
- A logger for just about everything.β24,529Jul 20, 2026Updated 3 months ago
- An express.js middleware for validator.js.β6,234Oct 3, 2026Updated last month
- Monitor for any changes in your node.js application and automatically restart the server - perfect for developmentβ26,660Updated this week
- Node.js Application Configurationβ6,434Sep 20, 2026Updated last month
- Manage & spin up mongodb server binaries with zero(or slight) configuration for tests.β2,854Updated this week
- TypeScript execution and REPL for node.jsβ13,117Jul 18, 2024Updated 2 years ago
- AI Agents on DigitalOcean Gradient AI Platform β’ AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- connect/express middleware that validates a JsonWebToken (JWT) and set the req.user with the attributesβ4,510Jun 25, 2026Updated 4 months ago
- A query builder for PostgreSQL, MySQL, CockroachDB, SQL Server, SQLite3 and Oracle, designed to be flexible, portable, and fun to use.β20,342Jun 26, 2026Updated 4 months ago
- MongoDB object modeling designed to work in an asynchronous environment.β27,457Updated this week
- Atomic and non-atomic counters and rate limiting tools. Limit resource access at any scale.β3,597Oct 19, 2026Updated 2 weeks ago
- Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are β¦β1,121Jul 23, 2024Updated 2 years ago
- Generate RFC-compliant UUIDs in JavaScriptβ15,345Updated this week
- TypeScript & JavaScript ORM for Node.js β supports PostgreSQL, MySQL, MariaDB, SQLite, SQL Server, Oracle, and more.β36,665Updated this week
- String validationβ23,745Sep 11, 2026Updated last month
- β³ Modern JavaScript date utility library βοΈβ36,658Oct 26, 2026Updated last week
- Deploy to Railway using AI coding agents - Free Credits Offer β’ AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Feature-rich ORM for modern Node.js and TypeScript, it supports PostgreSQL (with JSON and JSONB support), MySQL, MariaDB, SQLite, MS SQL β¦β30,343Updated this week
- Simple, unobtrusive authentication for Node.js.β23,521Aug 16, 2024Updated 2 years ago
- Runtime type checking for React props and similar objectsβ4,445May 17, 2024Updated 2 years ago
- π Cross platform setting of environment scriptsβ6,521Nov 16, 2025Updated 11 months ago
- Delightful JavaScript Testing.β45,472Updated this week
- ESLint rules for Node Securityβ2,380Updated this week
- π² super fast, all natural json loggerβ18,285Oct 6, 2026Updated 3 weeks ago