Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest RFCs including 5389, 5769, and 5780. Also includes backwards compatibility for RFC 3489. Compiles on Linux, MacOS, BSD, Solaris, and Win32 with Cygwin. Windows binaries avaialble from www.stunprotocol.org.
☆1,618May 12, 2026Updated 5 months ago
Alternatives and similar repositories for stunserver
Users that are interested in stunserver are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- coturn TURN server project☆14,534Updated this week
- An implementation of the IETF’s Interactive Connectivity Establishment (ICE) standard — this is an official read-only mirror of the upstr…☆650Sep 1, 2026Updated 2 months ago
- STUN server using node.js☆486Dec 30, 2022Updated 3 years ago
- A go implementation of the STUN client (RFC 3489 and RFC 5389)☆721Oct 12, 2026Updated 3 weeks ago
- Import of https://code.google.com/p/rfc5766-turn-server/☆527Oct 19, 2015Updated 11 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Fast RFC 5389 STUN implementation in go☆490May 17, 2021Updated 5 years ago
- A Python STUN client for getting NAT type and external IP☆451May 30, 2025Updated last year
- STUN client for NAT discovery.☆15Apr 19, 2014Updated 12 years ago
- A Go implementation of STUN☆864Updated this week
- JUICE is a UDP Interactive Connectivity Establishment library☆635Updated this week
- Pion TURN, an API for building TURN clients and servers☆2,272Oct 27, 2026Updated last week
- Janus WebRTC Server☆9,199Updated this week
- A cross-platform WebRTC client framework based on GStreamer☆1,819Mar 15, 2022Updated 4 years ago
- libice是一个c/c++库,它实现了RFC5245规范定义的交互式连接建立(ICE)协议, 适用于实时通信领域,比如音视频实时通信。☆124Sep 13, 2022Updated 4 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Open Source Communication Provider based on WebRTC and Cloud technologies☆3,132Updated this week
- travel across kinds of NATs, including symmetric NATs☆275Jul 4, 2019Updated 7 years ago
- STUN Client done in C☆44Mar 6, 2014Updated 12 years ago
- [ARCHIVED] Contents migrated to monorepo: https://github.com/Kurento/kurento☆3,052Jan 25, 2023Updated 3 years ago
- Library for SRTP (Secure Realtime Transport Protocol)☆1,403Updated this week
- JSTUN☆146Nov 29, 2025Updated 11 months ago
- Go implementation of STUN, TURN and ICE Protocols☆229Nov 19, 2017Updated 8 years ago
- A Java implementation of the ICE protocol☆484Oct 28, 2026Updated last week
- simple socket.io server for webrtc signaling☆1,298Nov 16, 2020Updated 5 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- libjingle clone of the original svn with some local patches.☆317Feb 23, 2013Updated 13 years ago
- STUN & TURN client demo and api with python and C☆97Apr 19, 2012Updated 14 years ago
- Libnice is an implementation of the IETF's Interactive Connectivity Establishment (ICE) standard (RFC 5245) and the Session Traversal Uti…☆74Apr 8, 2015Updated 11 years ago
- appr.tc has been shutdown. Please use the Dockerfile to run your own test/dev instance.☆4,217Apr 24, 2024Updated 2 years ago
- The only tool/technique to punch holes through firewalls/NATs where multiple clients & server can be behind separate NATs without any 3rd…☆3,940Dec 26, 2025Updated 10 months ago
- Fast TURN and STUN server: cross-platform, hot reload, flexible config☆385Nov 1, 2020Updated 6 years ago
- Pure Go implementation of the WebRTC API☆16,881Updated this week
- Simple STUN server in go☆103Apr 29, 2021Updated 5 years ago
- C++ implementation of SIP, ICE, TURN and related protocols.☆796Updated this week
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- WebRTC Web demos and samples☆14,646Jul 14, 2026Updated 3 months ago
- WebRTC, WebRTC and WebRTC. Everything here is all about WebRTC!!☆12,053Jun 15, 2022Updated 4 years ago
- Cutting Edge WebRTC Video Conferencing☆7,412Updated this week
- RTSP/RTP/RTMP/FLV/HLS/MPEG-TS/MPEG-PS/MPEG-DASH/MP4/fMP4/MKV/WebM☆3,530Oct 10, 2026Updated 3 weeks ago
- Implementation of RFC5766 and RFC5389☆78Jul 20, 2017Updated 9 years ago
- Simplest WebRTC ever☆4,682Aug 14, 2022Updated 4 years ago
- SRS is a simple, high-performance, AI-driven real-time media server supporting RTMP, WebRTC, HLS, HTTP-FLV, HTTP-TS, SRT, MPEG-DASH, and …☆29,427Updated this week