A Python STUN client for getting NAT type and external IP
☆451May 30, 2025Updated last year
Alternatives and similar repositories for pystun
Users that are interested in pystun are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- travel across kinds of NATs, including symmetric NATs☆275Jul 4, 2019Updated 7 years ago
- This script will determine what kind of NAT you are sitting behind.☆14Sep 5, 2014Updated 12 years ago
- Version 1.2. This is the source code to STUNTMAN - an open source STUN server and client code by john selbie. Compliant with the latest …☆1,617May 12, 2026Updated 5 months ago
- Python实现NAT穿透+STUN+TURN+P2P聊天 | Python P2P chat☆444Jun 28, 2017Updated 9 years ago
- IceNAT☆34Mar 8, 2015Updated 11 years ago
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- STUN & TURN client demo and api with python and C☆97Apr 19, 2012Updated 14 years ago
- Cross-platform NAT (Network Address Translation) type discovery tool (algorithms defined in RFC 3489)☆69Apr 28, 2017Updated 9 years ago
- Fast RFC 5389 STUN implementation in go☆492May 17, 2021Updated 5 years ago
- p2p tunnel,(udp mode work with kcp,https://github.com/skywind3000/kcp)☆2,166Dec 14, 2021Updated 4 years ago
- A kernel module to turn MASQUERADE into full cone SNAT☆451Jan 29, 2022Updated 4 years ago
- Implementation of RFC5766 and RFC5389☆79Jul 20, 2017Updated 9 years ago
- JSTUN☆146Nov 29, 2025Updated 10 months ago
- ☆18Mar 4, 2014Updated 12 years ago
- Libnice is an implementation of the IETF's Interactive Connectivity Establishment (ICE) standard (RFC 5245) and the Session Traversal Uti…☆74Apr 8, 2015Updated 11 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- 测试当前网络的 NAT 类型(STUN)☆4,880Updated this week
- An implementation of the IETF’s Interactive Connectivity Establishment (ICE) standard — this is an official read-only mirror of the upstr…☆645Sep 1, 2026Updated last month
- coturn TURN server project☆14,476Updated this week
- a simple GUI internet viedo downloader☆31Feb 8, 2017Updated 9 years ago
- Import of https://code.google.com/p/rfc5766-turn-server/☆528Oct 19, 2015Updated 10 years ago
- some kcptun relevant tools☆125Jan 18, 2017Updated 9 years ago
- NCD scripting language, tun2socks proxifier, P2P VPN☆1,931Aug 22, 2021Updated 5 years ago
- STUN and TURN library☆44Oct 31, 2018Updated 7 years ago
- Toolkit library for asynchronous network IO with protocol stacks including SIP, SDP, RTP, STUN, TURN, ICE, BFCP and DNS.☆41Mar 30, 2013Updated 13 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Netfilter and iptables extension for full cone NAT ported to OpenWrt.☆158Dec 3, 2021Updated 4 years ago
- Experiments about p2p networking issues☆21Oct 31, 2011Updated 14 years ago
- Session Traversal Utilities for NAT (STUN) client for Node.js.☆43Jun 8, 2015Updated 11 years ago
- ☆40Nov 10, 2021Updated 4 years ago
- A Go implementation of STUN☆861Updated this week
- A development branch of the n2n p2p vpn software☆882Sep 4, 2021Updated 5 years ago
- A Tunnel which Improves your Network Quality on a High-latency Lossy Link by using Forward Error Correction, possible for All Traffics(TC…☆5,177Jul 31, 2026Updated 2 months ago
- A simple demo of P2P communication over middle boxes such as NAT☆447Jul 3, 2022Updated 4 years ago
- KCP - A Fast and Reliable ARQ Protocol☆16,937Jun 23, 2026Updated 3 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- 利用Travis CI、Github构建Python在线编译打包环境,自动生成windowsEXE二进制文件☆10Apr 24, 2023Updated 3 years ago
- A stream multiplexing library for Golang with minimal memory usage.☆1,609May 15, 2026Updated 4 months ago
- Fast TURN and STUN server: cross-platform, hot reload, flexible config☆387Nov 1, 2020Updated 5 years ago
- A Tunnel which Turns UDP Traffic into Encrypted UDP/FakeTCP/ICMP Traffic by using Raw Socket,helps you Bypass UDP FireWalls(or Unstable U…☆8,573Oct 12, 2025Updated last year
- Python tun/tap client☆23Oct 20, 2021Updated 4 years ago
- A crypto-secure Reliable-UDP library for Golang with FEC support.☆4,554May 15, 2026Updated 4 months ago
- Libnatpmp with Java support☆39Apr 3, 2025Updated last year