An RFC 6902 (JSON Patch) and reverse, plus RFC 7386 (JSON Merge Patch), implementation in Java using Jackson (2.2.x)
☆694Mar 25, 2024Updated 2 years ago
Alternatives and similar repositories for json-patch
Users that are interested in json-patch are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- This is an implementation of RFC 6902 JSON Patch written in Java☆589Updated this week
- JSON Pointer (RFC 6901) and numeric JSON equivalence for Jackson (2.2.x)☆24Nov 28, 2018Updated 7 years ago
- A JSON Schema validation implementation in pure Java, which aims for correctness and performance, in that order☆1,638Jul 17, 2024Updated 2 years ago
- (DEPRECATED for Jackson 3) Module for generating JSON Schema (v3) definitions from POJOs☆387Oct 18, 2026Updated last week
- Java JsonPath implementation☆9,453Feb 22, 2026Updated 8 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A BSON implementation of RFC 6902 to compute the difference between two BSON documents☆40Oct 3, 2024Updated 2 years ago
- Write JSON unit tests in less code. Great for testing REST interfaces.☆1,060Jul 28, 2024Updated 2 years ago
- Fault tolerance and resilience patterns for the JVM☆4,319Dec 28, 2025Updated 10 months ago
- Awaitility is a small Java DSL for synchronizing asynchronous operations☆4,034Apr 17, 2026Updated 6 months ago
- (DEPRECATED) -- moved under `jackson-dataformats-text`☆14Dec 24, 2017Updated 8 years ago
- Implementation of mustache.js for Java☆1,959Oct 16, 2026Updated 2 weeks ago
- Java runtime metadata analysis☆4,759Jun 17, 2024Updated 2 years ago
- A high performance caching library for Java☆17,921Updated this week
- vʌvr (formerly called Javaslang) is a non-commercial, non-profit object-functional library that runs with Java 8+. It aims to reduce the …☆6,181Updated this week
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Unified Queries for Java☆4,971May 28, 2026Updated 5 months ago
- A Persistent Java Collections Library☆790Oct 20, 2026Updated last week
- A streaming JsonPath processor in Java☆318Jun 3, 2024Updated 2 years ago
- Resilience4j is a fault tolerance library designed for Java8 and functional programming☆10,799Updated this week
- An in-memory file system for Java☆2,563Oct 22, 2026Updated last week
- JSON to JSON transformation library written in Java.☆1,673Updated this week
- Gradle based multi module project using Spring-Boot and Spring4Vaadin☆12Feb 3, 2017Updated 9 years ago
- Pojomatic provides configurable implementations of the equals(Object), hashCode() and toString() methods inherited from java.lang.Object.☆29Nov 15, 2018Updated 7 years ago
- A fast Java JSON schema validator that supports draft V4, V6, V7, V2019-09 and V2020-12☆1,086Updated this week
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- Java RQL parser☆10Jul 24, 2025Updated last year
- Testcontainers is a Java library that supports JUnit tests, providing lightweight, throwaway instances of common databases, Selenium web …☆8,760Updated this week
- The easiest way to integrate Maven into your project!☆1,568Dec 18, 2021Updated 4 years ago
- Compare JSON in your Unit Tests☆1,007Updated this week
- Java DSL for easy testing of REST services☆7,146Updated this week
- GraphQL Java implementation☆6,223Updated this week
- Library to diff and merge Java objects with ease☆968Mar 17, 2022Updated 4 years ago
- 🏗 Build container images for your Java applications.☆14,452Oct 16, 2026Updated 2 weeks ago
- Capturing JVM- and application-level metrics. So you know what's going on.☆7,848Updated this week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Reactor Bill Of Materials (tracking reactor-core, reactor-netty and more)☆3,692Updated this week
- An annotation processor for generating type-safe bean mappers☆7,696Oct 16, 2026Updated 2 weeks ago
- Runtime code generation for the Java virtual machine.☆6,900Oct 23, 2026Updated last week
- Java implementation of the SemVer Specification☆463Jan 30, 2024Updated 2 years ago
- Feign makes writing java http clients easier☆9,802Updated this week
- Intelligent object mapping☆2,354Oct 22, 2026Updated last week
- Reactive Streams Specification for the JVM☆4,880Mar 13, 2024Updated 2 years ago