Java implementation of the SemVer Specification
☆465Jan 30, 2024Updated 2 years ago
Alternatives and similar repositories for jsemver
Users that are interested in jsemver are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Semantic versioning for Java apps.☆255Aug 5, 2022Updated 4 years ago
- Java library relying on semver.org principles to check binary code compatibility☆140Jun 24, 2015Updated 11 years ago
- Semantic versioning for Java apps.☆118Updated this week
- A Java Implementation of http://semver.org/☆16Mar 31, 2013Updated 13 years ago
- Tools for working with generic types☆627Updated this week
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Plugin Framework for Java (PF4J)☆2,759Updated this week
- Plugin Framework for Wicket (PF4J - Wicket integration)☆34Jul 7, 2022Updated 4 years ago
- Java memoization library☆21Jun 21, 2026Updated 3 months ago
- Git plugin for Gradle☆561Oct 5, 2018Updated 8 years ago
- Java generics runtime resolver☆52Sep 29, 2026Updated last week
- ☆16Oct 15, 2018Updated 7 years ago
- Modular & injectable foundation for building JVM microservices☆24Oct 12, 2022Updated 3 years ago
- Gradle plugin introducing a provided dependency configuration and marking a dependency as optional.☆141May 7, 2026Updated 5 months ago
- Non-Snapshot Maven Plugin☆11Nov 3, 2023Updated 2 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- configuration library for JVM languages using HOCON files☆6,313Updated this week
- System to speed up dependency resolution when using Maven snapshots #hubspot-open-source☆14Feb 26, 2023Updated 3 years ago
- Publishing related plugins☆100Sep 4, 2026Updated last month
- ShrinkWrap Resolvers☆160Updated this week
- Helps you to find or define Maven UIDs for any JAR file and generate corresponding artifact install scripts.☆12Jul 16, 2024Updated 2 years ago
- Java annotation processor to create immutable objects and builders, for records too. Sweep boilerplate code under the rug!☆3,575Sep 24, 2026Updated 2 weeks ago
- RxJava-Optional is an library that allows developers to use Optional using RxJava☆55Dec 12, 2015Updated 10 years ago
- Picocli is a modern framework for building powerful, user-friendly, GraalVM-enabled command line apps with ease. It supports colors, auto…☆5,427Aug 16, 2026Updated last month
- Java URN as in RFC 2141☆22Updated this week
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- vʌvr (formerly called Javaslang) is a non-commercial, non-profit object-functional library that runs with Java 8+. It aims to reduce the …☆6,179Updated this week
- Low-overhead, non-blocking I/O, external Process implementation for Java☆741Jul 10, 2026Updated 3 months ago
- Query Builder for OSQL (OrientDB query language)☆34Oct 13, 2020Updated 5 years ago
- Gradle plugin for creating fat/uber JARs, transforming files, relocating packages, and optimizing with R8/ProGuard. The Gradle counterpar…☆4,241Updated this week
- Java Annotation Indexer☆454Oct 1, 2026Updated last week
- ClassLoader per Test runner for JUnit 4.12+ based on myfaces-test "TestPerClassLoaderRunner".☆10Feb 14, 2016Updated 10 years ago
- A Java application launcher and class loader which can load and run classes directly from Maven repositories and resolve dependencies at …☆103Nov 25, 2017Updated 8 years ago
- An RFC 6902 (JSON Patch) and reverse, plus RFC 7386 (JSON Merge Patch), implementation in Java using Jackson (2.2.x)☆694Mar 25, 2024Updated 2 years ago
- A high performance caching library for Java☆17,882Updated this week
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Jansi is a small java library that allows you to use ANSI escape sequences to format your console output which works even on windows.☆1,202Mar 27, 2026Updated 6 months ago
- A file system implementation to access the contents of Java modules in a unified way.☆41Jun 18, 2026Updated 3 months ago
- ☆113Oct 13, 2020Updated 5 years ago
- An uber-fast parallelized Java classpath scanner and module scanner.☆3,015Updated this week
- Defines a common event store Java interface and provides some adapters (like for Greg Young's event store) and implementations (like in-m…☆17Aug 8, 2026Updated 2 months ago
- Implementation of a concurrent map with weak keys and a detached thread local storage.☆121Nov 20, 2024Updated last year
- An OSS clone of javadoc.io☆11Sep 13, 2026Updated 3 weeks ago