(DEPRECATED for Jackson 3) Module for generating JSON Schema (v3) definitions from POJOs
☆387Oct 18, 2026Updated last week
Alternatives and similar repositories for jackson-module-jsonSchema
Users that are interested in jackson-module-jsonSchema are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Generate JSON Schema with Polymorphism using Jackson annotations☆254Apr 5, 2023Updated 3 years ago
- Java JSON Schema Generator – creating JSON Schema (Draft 6, Draft 7, Draft 2019-09, or Draft 2020-12) from Java classes☆573Jun 23, 2026Updated 4 months ago
- A JSON Schema validation implementation in pure Java, which aims for correctness and performance, in that order☆1,638Jul 17, 2024Updated 2 years ago
- A generator from Java Types to JSON-Schema using Jackson.☆121Jul 15, 2022Updated 4 years ago
- JSON Schema validator for java, based on the org.json API☆900Aug 1, 2025Updated last year
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- (DEPRECATED) -- moved under `jackson-dataformats-binary`☆40Feb 4, 2017Updated 9 years ago
- (DEPRECATED) -- moved as a sub-project of `jackson-dataformats-text`☆140Dec 24, 2017Updated 8 years ago
- Bill of materials POM for Jackson projects☆71Oct 23, 2026Updated last week
- Extension module to properly support full datatype set of Joda datetime library☆148Oct 22, 2026Updated last week
- (DEPRECATED) -- moved under `jackson-dataformats-binary☆45Feb 4, 2017Updated 9 years ago
- (DEPRECATED) -- moved under `jackson-datatypes-misc` https://github.com/FasterXML/jackson-datatypes-misc/☆20Jul 21, 2020Updated 6 years ago
- A fast Java JSON schema validator that supports draft V4, V6, V7, V2019-09 and V2020-12☆1,086Updated this week
- An RFC 6902 (JSON Patch) and reverse, plus RFC 7386 (JSON Merge Patch), implementation in Java using Jackson (2.2.x)☆694Mar 25, 2024Updated 2 years ago
- Uber-project for foundational modules of Jackson that build directly on core components but nothing else; not including data format or da…☆179Oct 18, 2026Updated last week
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Generate Java types from JSON or JSON Schema and annotate those types for data-binding with Jackson, Gson, etc☆6,378May 2, 2026Updated 5 months ago
- (DEPRECATED!!!) Moved to: https://github.com/FasterXML/jackson-modules-base/☆45Dec 24, 2017Updated 8 years ago
- (DEPRECATED) -- moved under `jackson-modules-base`☆28Jun 5, 2016Updated 10 years ago
- Library for introspecting generic type information of types, member/static methods, fields. Especially useful for POJO/Bean introspection…☆266Oct 11, 2026Updated 2 weeks ago
- (DEPRECATED) -- moved under `jackson-modules-base`☆92Nov 2, 2019Updated 6 years ago
- A Jackson-powered implementation of JSR353☆23Jul 30, 2019Updated 7 years ago
- Jackson project that contains various collection-oriented datatype libraries: Eclipse Collections, Guava, HPPC, PCollections☆91Updated this week
- Stand-alone data-binding module designed as a light-weight (and -featured) alternative to `jackson-databind`: will only deal with "Maps, …☆266Oct 18, 2026Updated last week
- StoreMate☆23Jun 10, 2022Updated 4 years ago
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Implementation of mustache.js for Java☆1,959Oct 16, 2026Updated 2 weeks ago
- JSON Pointer (RFC 6901) and numeric JSON equivalence for Jackson (2.2.x)☆24Nov 28, 2018Updated 7 years ago
- StaxMate: Automatic Shifting for Streaming XML Processing☆45May 30, 2026Updated 5 months ago
- Swagger Spec to Java POJOs☆870Sep 9, 2026Updated last month
- Uber-project for standard Jackson binary format backends: avro, cbor, ion, protobuf, smile☆348Updated this week
- Java JsonPath implementation☆9,453Feb 22, 2026Updated 8 months ago
- Logback JSON encoder and appenders☆2,529Jul 15, 2026Updated 3 months ago
- Distributed data store for transient (temporary, time-bound) data. Based on ClusterMate/StoreMate☆21Jun 22, 2022Updated 4 years ago
- (DEPRECATED) -- moved under `jackson-modules-java8` repo: https://github.com/FasterXML/jackson-modules-java8☆94Nov 6, 2019Updated 6 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Tools for working with generic types☆626Updated this week
- Java runtime metadata analysis☆4,759Jun 17, 2024Updated 2 years ago
- (DEPRECATED) -- moved under `jackson-datatypes-collections`☆69Jan 20, 2025Updated last year
- An uber-fast parallelized Java classpath scanner and module scanner.☆3,021Updated this week
- Compare JSON in your Unit Tests☆1,007Updated this week
- The Jdbi library provides convenient, idiomatic access to relational databases in Java and other JVM technologies such as Kotlin, Clojure…☆2,143Oct 16, 2026Updated 2 weeks ago
- Write JSON unit tests in less code. Great for testing REST interfaces.☆1,060Jul 28, 2024Updated 2 years ago