Parse and print size and time units in human-readable format
☆247Apr 15, 2026Updated 6 months ago
Alternatives and similar repositories for go-units
Users that are interested in go-units are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- Utility package to work with network connections☆231Oct 8, 2026Updated 3 weeks ago
- OpenContainer tool set☆12Oct 11, 2016Updated 10 years ago
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- fifo pkg for Go☆87Oct 12, 2026Updated 2 weeks ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- DEPRECATED: Please see https://github.com/docker/docker/tree/master/client☆261Apr 17, 2018Updated 8 years ago
- Go Humans! (formatters for units to human friendly sizes)☆4,851Oct 13, 2026Updated 2 weeks ago
- collection of utilities for file manipulation in golang☆13Oct 4, 2023Updated 3 years ago
- ☆927Jul 23, 2026Updated 3 months ago
- Wrapper types for sync/atomic which enforce atomic access☆1,458Oct 20, 2026Updated last week
- A Go (golang) library for parsing and verifying versions and version constraints.☆1,775Oct 16, 2026Updated 2 weeks ago
- Generates a GitHub issue description for go-fuzz findings☆11Dec 3, 2015Updated 10 years ago
- Multi-host replacement for cron☆17May 3, 2021Updated 5 years ago
- Go packages with small patches autogenerated (used for canonical/json)☆18Apr 27, 2020Updated 6 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Composable event distribution for Go☆136Sep 28, 2026Updated last month
- Go bindings to systemd socket activation, journal, D-Bus, and unit files☆2,719Jul 23, 2026Updated 3 months ago
- Mutex for debugging deadlocks☆12Jun 18, 2019Updated 7 years ago
- Selected Go-internal packages factored out from the standard library☆993Oct 5, 2026Updated 3 weeks ago
- semver library in Go☆366Jul 22, 2026Updated 3 months ago
- Pretty printing for Go values☆1,409Jul 26, 2024Updated 2 years ago
- Go package providing information about the number of CPUs in the system☆34Updated this week
- Mergo: merging Go structs and maps since 2013☆3,108Oct 12, 2026Updated 2 weeks ago
- The Universal Filesystem Abstraction for Go☆6,714Updated this week
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- Human readable byte formatter☆224Updated this week
- Type adapters for common Go protobuf messages☆18Oct 24, 2024Updated 2 years ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Golang implementation of Radix trees☆946Jul 6, 2024Updated 2 years ago
- Partial port of Python difflib package to Go☆429May 30, 2023Updated 3 years ago
- Proposed filepath.SecureJoin implementation☆113Jun 18, 2026Updated 4 months ago
- Helpful unit multipliers and functions for Go☆131Aug 19, 2026Updated 2 months ago
- Work with Semantic Versions in Go☆1,443Aug 14, 2026Updated 2 months ago
- Package for comparing Go values in tests☆4,681Jun 18, 2026Updated 4 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Distributed key/value store abstraction library☆849Jun 4, 2026Updated 4 months ago
- Common digest package used across the container ecosystem☆224Oct 15, 2026Updated 2 weeks ago
- automatically trigger a profile in your golang (go) application when a condition is matched.☆15Oct 2, 2020Updated 6 years ago
- Optimized Go Compression Packages☆5,707Updated this week
- CPU feature identification for Go☆1,221Oct 20, 2026Updated last week
- An immutable radix tree implementation in Golang☆1,107Updated this week
- Implements a deep pretty printer for Go data structures to aid in debugging☆6,425Apr 6, 2024Updated 2 years ago