Pure Go implementation of BLAKE3 with AVX2 and SSE4.1 acceleration
☆497Oct 20, 2026Updated 2 weeks ago
Alternatives and similar repositories for blake3
Users that are interested in blake3 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- An AVX-512 accelerated implementation of the BLAKE3 cryptographic hash function☆425Aug 13, 2025Updated last year
- XXH3 algorithm in Go☆590Oct 19, 2026Updated 2 weeks ago
- Generate x86 Assembly with Go☆2,995Updated this week
- Native Go version of HighwayHash with optimized assembly implementations on Intel and ARM. Able to process over 10 GB/sec on a single cor…☆957Mar 21, 2026Updated 7 months ago
- the official Rust and C implementations of the BLAKE3 cryptographic hash function☆6,504Oct 1, 2026Updated last month
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Optimized Go Compression Packages☆5,708Updated this week
- A Go implementation of the 64-bit xxHash algorithm (XXH64)☆2,149Jul 3, 2024Updated 2 years ago
- Implementation of https://www.ietf.org/archive/id/draft-denis-aegis-aead-00.html / https://competitions.cr.yp.to/round3/aegisv11.pdf☆15Mar 25, 2025Updated last year
- Software sandbox for storage of sensitive information in memory.☆2,765May 8, 2026Updated 5 months ago
- Fast hashing using pure Go implementation of BLAKE2b with SIMD instructions☆255Nov 27, 2017Updated 8 years ago
- Implementation of do255e and do255s in Go☆23Dec 14, 2020Updated 5 years ago
- Go library providing algorithms optimized to leverage the characteristics of modern CPUs☆929Jun 25, 2026Updated 4 months ago
- Golang port of simdjson: parsing gigabytes of JSON per second☆2,044Aug 26, 2025Updated last year
- Go implementation of SipHash-2-4, a fast short-input PRF created by Jean-Philippe Aumasson and Daniel J. Bernstein.☆297Apr 27, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Go library implementing binary fuse and xor filters☆766Jan 26, 2026Updated 9 months ago
- Elliptic curve Go reference implementation☆26Feb 5, 2025Updated last year
- Accelerate SHA256 computations in pure Go using AVX512, SHA Extensions for x86 and ARM64 for ARM. On AVX512 it provides an up to 8x impr…☆1,042May 24, 2023Updated 3 years ago
- filippo.io/edwards25519 — A safer, faster, and more powerful low-level edwards25519 Go implementation.☆189Feb 17, 2026Updated 8 months ago
- Go implementation of the Noise Protocol Framework☆583Feb 18, 2024Updated 2 years ago
- An EXPERIMENTAL Go implementation of the CPace PAKE, instantiated with the ristretto255 group.☆29Feb 11, 2021Updated 5 years ago
- uint128 for Go☆266Nov 16, 2024Updated last year
- A tweakable block cipher☆31May 17, 2024Updated 2 years ago
- CIRCL: Cloudflare Interoperable Reusable Cryptographic Library☆1,733Oct 26, 2026Updated last week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Experimental committing AEAD designed by Soatok.☆11Sep 10, 2020Updated 6 years ago
- CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, a…☆1,102Updated this week
- The BLAKE3 paper: specifications, analysis, and design rationale☆202Sep 1, 2026Updated 2 months ago
- Go implementation of libhydrogen - a lightweight, easy-to-use crypto library☆24Mar 23, 2017Updated 9 years ago
- POLYVAL per RFC 8452☆10Aug 5, 2023Updated 3 years ago
- Go Assembler Formatter☆320Apr 4, 2022Updated 4 years ago
- A high performance memory-bound Go cache☆7,005Sep 21, 2026Updated last month
- discohash☆15Oct 30, 2021Updated 5 years ago
- High-performance Curve25519/ristretto255 for Go.☆80Jul 10, 2026Updated 3 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- xxh3 fast hash function☆105Mar 17, 2019Updated 7 years ago
- CPU feature identification for Go☆1,221Oct 20, 2026Updated last week
- A library for calling C functions from Go without Cgo☆4,081Updated this week
- Roaring bitmaps in Go (golang), used by InfluxDB, Bleve, DataDog☆2,953Updated this week
- Go package containing implementations of efficient encoding, decoding, and validation APIs.☆1,055Jun 25, 2026Updated 4 months ago
- An AVX/AVX2/x64/pure-Go implementation of the ChaCha20 stream cipher for Golang. [Deprecated].☆11Mar 15, 2018Updated 8 years ago
- wazero: the zero dependency WebAssembly runtime for Go developers☆6,446Oct 19, 2026Updated 2 weeks ago