A Swift framework for working with compression, archives and containers.
☆278Jul 1, 2026Updated 3 months ago
Alternatives and similar repositories for SWCompression
Users that are interested in SWCompression are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Read and write bits and bytes in Swift.☆33Jul 1, 2026Updated 3 months ago
- PLzmaSDK is (Portable, Patched, Package, cross-P-latform) Lzma SDK.☆110Sep 21, 2026Updated last month
- Effortless ZIP Handling in Swift☆2,747Sep 12, 2026Updated last month
- A small, dependency-free HTTP/1.1 server framework in Swift for macOS, iOS and tvOS. Run a web server inside your app or tool: routing, J…☆14Oct 15, 2026Updated 2 weeks ago
- Swift library wraps unrar C++ library provided by rarlib.☆42Jun 30, 2026Updated 4 months ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A Swift package for creating and extracting Tar files.☆15May 25, 2023Updated 3 years ago
- untar and tar files on iOS and OS X. Also supports gzip tars.☆89Aug 10, 2020Updated 6 years ago
- xxHash framework in Swift.☆35Dec 17, 2021Updated 4 years ago
- Compression/Decompression support for Swift NIO ByteBuffer☆29Oct 9, 2026Updated 3 weeks ago
- ObjC wrapper around the 7zip/LZMA SDK☆41Jul 26, 2019Updated 7 years ago
- Swift language bindings for WinRT APIs in the the Windows.Foundation namespace☆11Oct 16, 2025Updated last year
- Easy XML parsing using Codable protocols in Swift☆878May 13, 2026Updated 5 months ago
- Swift libcompression wrapper as an extension for the Data type (GZIP, ZLIB, LZFSE, LZMA, LZ4, deflate, RFC-1950, RFC-1951, RFC-1952)☆302Oct 7, 2026Updated 3 weeks ago
- This is a simple Mac Catalyst example showcasing how to build a dropdown menu toolbar button using AppKit.☆31Apr 9, 2022Updated 4 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Easily read RAR archives on Mac and iOS☆323Oct 12, 2023Updated 3 years ago
- Swift package that enables gzip/gunzip Data using zlib☆594May 10, 2026Updated 5 months ago
- Custom UIKit Text Editor Component for Catalyst☆17Apr 28, 2023Updated 3 years ago
- Swift framework for zipping and unzipping files.☆2,605Aug 5, 2024Updated 2 years ago
- Deflate Compression for Swift☆40Jun 18, 2019Updated 7 years ago
- HTTP client library built on SwiftNIO☆1,082Updated this week
- SwiftSoup: Pure Swift HTML Parser, with best of DOM, CSS, and jquery (Supports Linux, iOS, Mac, tvOS, watchOS)☆5,129Oct 16, 2026Updated 2 weeks ago
- Add beautiful progress bars to your loops.☆349Jan 16, 2024Updated 2 years ago
- waifu2x apple 平台超分库☆11Feb 8, 2025Updated last year
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Excel spreadsheet (XLSX) format parser written in pure Swift☆906Mar 25, 2024Updated 2 years ago
- Swift Package for Decoding RSS Feeds.☆70Oct 21, 2026Updated last week
- Non-blocking wrapper for libsqlite3-dev using SwiftNIO☆78Oct 16, 2026Updated 2 weeks ago
- Swift Package for Server-Side and Command-Line Access to CloudKit Web Services☆269Sep 15, 2026Updated last month
- Swift library which can generate output compatible with OpenAPI 3.1.0☆12Aug 27, 2026Updated 2 months ago
- Swift library to extract 7zip archive using LZMA SDK☆13Oct 7, 2026Updated 3 weeks ago
- Async and concurrent versions of Swift’s forEach, map, flatMap, and compactMap APIs.☆778Apr 13, 2023Updated 3 years ago
- The pure swift interface to JavaScriptCore for iOS, macOS, tvOS, and Linux☆90Jan 24, 2026Updated 9 months ago
- zstd/brotli/lz4 swift kit☆14Mar 13, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Call hidden/private API in style! The Swift way.☆787Oct 2, 2021Updated 5 years ago
- HTML5 spec-compliant character encoder/decoder for Swift☆173Aug 24, 2022Updated 4 years ago
- ZipArchive is a simple utility class for zipping and unzipping files on iOS, macOS and tvOS.☆5,605Oct 31, 2025Updated last year
- A Sweet and Swifty YAML parser.☆1,272Oct 13, 2026Updated 2 weeks ago
- Tar file extract utility written in Swift☆10May 20, 2022Updated 4 years ago
- A library for turning nebulous data into well-structured data, with a focus on composition, performance, generality, and ergonomics.☆1,000Oct 23, 2026Updated last week
- SwiftUI for terminal applications☆1,538Jul 9, 2024Updated 2 years ago