Swift libcompression wrapper as an extension for the Data type (GZIP, ZLIB, LZFSE, LZMA, LZ4, deflate, RFC-1950, RFC-1951, RFC-1952)
☆302Oct 7, 2026Updated 3 weeks ago
Alternatives and similar repositories for DataCompression
Users that are interested in DataCompression are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Deflate Compression for Swift☆40Jun 18, 2019Updated 7 years ago
- Swift package that enables gzip/gunzip Data using zlib☆594May 10, 2026Updated 5 months ago
- Effortless ZIP Handling in Swift☆2,747Sep 12, 2026Updated last month
- A Swift framework for working with compression, archives and containers.☆278Jul 1, 2026Updated 3 months ago
- Swift framework for zipping and unzipping files.☆2,605Aug 5, 2024Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- A nicer way to handle files & folders in Swift☆2,636May 30, 2025Updated last year
- SwiftSoup: Pure Swift HTML Parser, with best of DOM, CSS, and jquery (Supports Linux, iOS, Mac, tvOS, watchOS)☆5,129Oct 16, 2026Updated 2 weeks ago
- Easy Cryptography for Server-Side Swift☆11Aug 2, 2018Updated 8 years ago
- Better Codable through Property Wrappers☆1,803Nov 23, 2023Updated 2 years ago
- A toolkit for SQLite databases, with a focus on application development☆8,717Sep 29, 2026Updated last month
- Excel spreadsheet (XLSX) format parser written in pure Swift☆906Mar 25, 2024Updated 2 years ago
- Lightweight In App Purchases Swift framework for iOS 8.0+, tvOS 9.0+ and macOS 10.10+ ⛺☆6,669Jun 28, 2024Updated 2 years ago
- Simple Swift wrapper for Keychain that works on iOS, watchOS, tvOS and macOS.☆8,260May 31, 2024Updated 2 years ago
- CryptoSwift is a growing collection of standard and secure cryptographic algorithms implemented in Swift☆10,577Aug 19, 2026Updated 2 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Nothing but Cache.☆3,139Aug 30, 2025Updated last year
- A super fast and easy-to-use layout library for iOS. FrameLayoutKit supports complex layouts, including chaining and nesting layout with …☆84Jul 9, 2025Updated last year
- Event-driven network application framework for high performance protocol servers & clients, non-blocking.☆8,540Oct 19, 2026Updated last week
- Websockets in swift for iOS and OSX☆8,637May 16, 2024Updated 2 years ago
- An encoder and decoder for CKRecord☆395Sep 2, 2024Updated 2 years ago
- Automatic CloudKit synchronization☆524Jun 25, 2022Updated 4 years ago
- 🌐 Makes Internet connectivity detection more robust by detecting Wi-Fi networks without Internet access.☆1,686Dec 2, 2024Updated last year
- Parse and validate App Store receipt files☆361Jun 26, 2025Updated last year
- SwiftEntryKit is a presentation library for iOS. It can be used to easily display overlays within your iOS apps.☆6,742May 12, 2024Updated 2 years ago
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- Effortlessly synchronize UserDefaults over iCloud.☆954Aug 16, 2026Updated 2 months ago
- A type-safe, Swift-language layer over SQLite3.☆10,186Updated this week
- 💻 A fast and flexible O(n) difference algorithm framework for Swift collection.☆3,666Jun 23, 2026Updated 4 months ago
- A collection of Swift utilities as documented on cocoawithlove.com☆622Aug 27, 2021Updated 5 years ago
- RSA public/private key encryption in Swift☆1,304Jan 11, 2025Updated last year
- Delightful, robust, cross-platform and chainable file-pathing functions.☆959Jun 3, 2026Updated 4 months ago
- A modern library to swizzle elegantly in Swift.☆1,025Jun 11, 2026Updated 4 months ago
- Easily script with third-party Swift dependencies.☆1,890Jun 3, 2026Updated 4 months ago
- Universal API for request permission and get its statuses.☆5,811Sep 12, 2026Updated last month
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Simple and expressive file management in Swift☆2,355Apr 9, 2024Updated 2 years ago
- Beautiful, easy attributed strings in Swift☆3,544Jul 21, 2024Updated 2 years ago
- 🔒 Swift Obfuscator that protects iOS apps against reverse engineering attacks.☆2,549Nov 20, 2022Updated 3 years ago
- Easily persist structs, images, and data on iOS☆3,111Aug 8, 2024Updated 2 years ago
- Localization/I18n: Incrementally update/translate your Strings files from .swift, .h, .m(m), .storyboard or .xib files.☆1,401Apr 5, 2024Updated 2 years ago
- Meta-programming for Swift, stop writing boilerplate code.☆8,028Jun 11, 2026Updated 4 months ago
- This package makes your Decodable types resilient to decoding errors and allows you to inspect those errors.☆602Jun 23, 2026Updated 4 months ago