Go package providing information about the number of CPUs in the system
☆34Oct 27, 2026Updated this week
Alternatives and similar repositories for numcpus
Users that are interested in numcpus are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- sysconf and pathconf for Go, without using cgo☆151Updated this week
- ☆15Jan 24, 2022Updated 4 years ago
- Proper URL escaping as per RFC3986☆27Oct 14, 2020Updated 6 years ago
- Package pgio is a low-level toolkit building messages in the PostgreSQL wire protocol.☆15Mar 30, 2019Updated 7 years ago
- json reference for golang☆20Oct 9, 2026Updated 2 weeks ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- ☆11Dec 21, 2021Updated 4 years ago
- Civil Date and Time package for Go☆19Feb 23, 2022Updated 4 years ago
- Functions for working safely with temporary files and directories.☆14Jul 27, 2026Updated 3 months ago
- List, find and inspect operating system processes in Go☆30Updated this week
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- Effective Computation of Things☆114Aug 15, 2019Updated 7 years ago
- SquashFS implementation in pure Go (read/write)☆20Apr 2, 2026Updated 6 months ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- Package tcpopt implements encoding and decoding of TCP-level socket options☆13Mar 14, 2019Updated 7 years ago
- Tool to create a devicetree from a sopcinfo file generated by Altera☆10Feb 1, 2022Updated 4 years ago
- A fast and lightweight version of tail using inotify☆12Mar 22, 2011Updated 15 years ago
- Realtime log processing with Fluentd and NSQ☆14Mar 28, 2019Updated 7 years ago
- A Simple Kubernetes Client in Go☆19Feb 25, 2023Updated 3 years ago
- A BIP0039 implementation in Go☆10Apr 13, 2026Updated 6 months ago
- Miscellaneous functions for formatting text☆96Jul 26, 2024Updated 2 years ago
- Smart Go module dependency inspection and pruning.☆19Jun 11, 2020Updated 6 years ago
- tail files with inotify☆24Nov 6, 2023Updated 2 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Package tcpinfo implements encoding and decoding of TCP-level socket options regarding connection information☆43Sep 17, 2021Updated 5 years ago
- SHA1 implementation with collision detection.☆15Sep 30, 2026Updated 3 weeks ago
- Library to translate OTLP metric and attribute names to Prometheus metric and label names.☆16Updated this week
- Easy to use ANSI control codes☆13Sep 26, 2023Updated 3 years ago
- Package ethtool allows control of the Linux ethtool generic netlink interface. MIT Licensed.☆76Aug 1, 2026Updated 2 months ago
- jsonpointer for golang with support for structs☆53Oct 9, 2026Updated 3 weeks ago
- Vagrant boxes built using Packer☆16Jul 2, 2026Updated 3 months ago
- ☆16Apr 21, 2020Updated 6 years ago
- A native go library that manages secrets via the freedesktop.org Secret Service DBus API☆15Feb 12, 2023Updated 3 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- A terminfo package in pure go!☆56Sep 27, 2026Updated last month
- Go SSH known_hosts wrapper with host key lookup☆39Aug 27, 2026Updated 2 months ago
- Golang utlities to make your life easier with zero allocations☆50Sep 24, 2025Updated last year
- Demo robot puppy solidworks files☆13Sep 18, 2015Updated 11 years ago
- A Bolt wrapper that allows easy store hash, zset data.☆11Aug 26, 2021Updated 5 years ago
- Simple string pattern matcher for Go☆140Sep 5, 2025Updated last year
- ☆12Oct 19, 2021Updated 5 years ago