Load environment variables from `.env` or `io.Reader` in Go.
☆310Nov 10, 2025Updated 11 months ago
Alternatives and similar repositories for gotenv
Users that are interested in gotenv are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Support for streaming Protocol Buffer messages for the Go language (golang).☆66Jan 12, 2024Updated 2 years ago
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Civil Date and Time package for Go☆19Feb 23, 2022Updated 4 years ago
- logr implementation against the stdlib log package☆36Jul 14, 2022Updated 4 years ago
- ☆15Jan 24, 2022Updated 4 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Data model artifacts for Prometheus.☆80Oct 10, 2026Updated 3 weeks ago
- Effective Computation of Things☆115Aug 15, 2019Updated 7 years ago
- Package pgio is a low-level toolkit building messages in the PostgreSQL wire protocol.☆15Mar 30, 2019Updated 7 years ago
- Un-marshaling environment variables to Go structs☆103Jun 19, 2017Updated 9 years ago
- Fast, zero-configuration, static HTTP filer server.☆12Apr 16, 2025Updated last year
- Database access layer for golang☆161Oct 25, 2021Updated 5 years ago
- A Go port of Ruby's dotenv library (Loads environment variables from .env files)☆10,681Aug 4, 2026Updated 3 months ago
- Java properties scanner for Go☆340Sep 16, 2026Updated last month
- i18n Translator for Go/Golang using CLDR data + pluralization rules☆430Sep 20, 2026Updated last month
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- ☆927Jul 23, 2026Updated 3 months ago
- Go package providing information about the number of CPUs in the system☆34Updated this week
- Serve HTTP on a tailnet☆21Oct 31, 2024Updated 2 years ago
- freeze your Go dependencies with ease☆41Sep 13, 2013Updated 13 years ago
- Package waitout makes it easy to wait for some output.☆23Jun 12, 2015Updated 11 years ago
- The Universal Filesystem Abstraction for Go☆6,719Oct 30, 2026Updated last week
- concurrency utilities☆304Aug 9, 2019Updated 7 years ago
- a set of locales generated from the CLDR Project which can be used independently or within an i18n package; these were built for use wit…☆308Sep 28, 2026Updated last month
- Mergo: merging Go structs and maps since 2013☆3,107Oct 12, 2026Updated 3 weeks ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- The Snappy compression format in the Go programming language.☆1,572Jul 16, 2026Updated 3 months ago
- Errwrap is a Go (golang) library for wrapping and querying errors.☆458Oct 15, 2026Updated 3 weeks ago
- Implements a deep pretty printer for Go data structures to aid in debugging☆6,423Apr 6, 2024Updated 2 years ago
- context.Context extentions☆15Mar 13, 2019Updated 7 years ago
- Pure Go CSS Preprocessor☆500Mar 6, 2024Updated 2 years ago
- Go libraries shared across Prometheus components and libraries.☆297Updated this week
- wcwidth for golang☆726Oct 8, 2026Updated last month
- A file globbing library.☆71Updated this week
- Go library for detecting and expanding the user's home directory without cgo.☆1,416Mar 21, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Go library for the TOML file format☆2,003Aug 3, 2026Updated 3 months ago
- This is the official Golang SDK for Sensors Analytics.☆34Aug 20, 2026Updated 2 months ago
- Go Humans! (formatters for units to human friendly sizes)☆4,856Oct 13, 2026Updated 3 weeks ago
- Blackfriday: a markdown processor for Go☆5,596Jan 29, 2024Updated 2 years ago
- Go library for decoding generic map values into native Go structures and vice versa.☆8,009Jun 25, 2024Updated 2 years ago
- DEPRECATED / OLD LOCATION; moved to https://go4.org/lock; DO NOT USE THIS VERSION☆53Apr 17, 2017Updated 9 years ago
- A Go implementation of the 64-bit xxHash algorithm (XXH64)☆2,149Jul 3, 2024Updated 2 years ago