An implementation of the HPKE hybrid encryption standard (RFC 9180)
☆101Oct 28, 2026Updated this week
Alternatives and similar repositories for rust-hpke
Users that are interested in rust-hpke are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Pure Rust implementation of HPKE (https://www.rfc-editor.org/rfc/rfc9180.html)☆55Jul 21, 2026Updated 3 months ago
- An implementation of the DudeCT constant-time function tester☆30Mar 23, 2026Updated 7 months ago
- Flexible secp256k1 curve math library.☆22May 26, 2026Updated 5 months ago
- Rust crate for computing Adler-32 checksums (fork)☆12Jun 9, 2025Updated last year
- Random prime generation and primality testing library based on `crypto-bigint`.☆34Jul 16, 2026Updated 3 months ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- FN-DSA (Falcon) signature scheme☆67Jul 30, 2026Updated 3 months ago
- Hybrid Public Key Encryption☆51Jul 10, 2024Updated 2 years ago
- This is a rust implementation of an attested OHTTP gateway☆14Jun 26, 2026Updated 4 months ago
- Tool to interact with the firewall matched data feature.☆23Apr 23, 2026Updated 6 months ago
- An implementation of the append-only log described in the Certificate Transparency specification (RFC 6962)☆41May 23, 2026Updated 5 months ago
- A scalable anonymous blocklisting scheme☆13Oct 6, 2023Updated 3 years ago
- Collection of Key Encapsulation Mechanisms written in pure Rust☆120Updated this week
- cargo plugin to run commands against all combinations of features☆14Oct 17, 2026Updated last week
- Small crate for interacting with cargo registry indices☆31Oct 23, 2026Updated last week
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Generate an SPDX Software Bill of Materials for Rust crates.☆20Aug 10, 2022Updated 4 years ago
- An implementation of Messaging Layer Security (RFC 9420)☆261Updated this week
- Small, wasm-friendly, zero-dependencies Ed25519 and X25519 implementation for Rust.☆148Sep 29, 2026Updated last month
- RSA blind signatures in Rust☆35Sep 25, 2026Updated last month
- MPC protocols for threshold ECDSA☆52Feb 6, 2024Updated 2 years ago
- async ACME client for tls-alpn-01 challenge☆13Mar 1, 2025Updated last year
- Collection of sponge functions written in pure Rust☆57Aug 21, 2026Updated 2 months ago
- The free EAP version of the Cosmian Collaborative Confidential Computing platform. Try it!☆27Jun 29, 2021Updated 5 years ago
- Driver for round-based protocols in Rust☆24Jan 17, 2024Updated 2 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- Cryptography-oriented big integer library with constant-time, stack-allocated (no_std-friendly) implementations of modern formulas☆314Updated this week
- Rust library for cryptographic research☆159Dec 27, 2024Updated last year
- An experimental Rust crate for sigstore☆244Sep 28, 2026Updated last month
- Lock-free ARENA allocator and a set of lock-free data structures based on the ARENA allocator.☆17Mar 14, 2026Updated 7 months ago
- Ambient Authority☆22Jun 30, 2023Updated 3 years ago
- NIST P-256 signatures for Cortex-M4 microcontrollers☆17Mar 14, 2021Updated 5 years ago
- Anonymous Credit Tokens implementation in Rust☆29Jul 11, 2026Updated 3 months ago
- CLI for setting up sound, assembly-level constant-time verification of (rust) cryptography libraries with binsec☆16Oct 8, 2026Updated 3 weeks ago
- Faster, Smaller, Harder HPKE for Rust☆30Aug 23, 2026Updated 2 months ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- Implementation of DAP☆146Apr 24, 2026Updated 6 months ago
- Structured HTTP field values parsing and serialization. Implementation of RFC 9651 https://httpwg.org/specs/rfc9651.html☆31Updated this week
- A pure-Rust implementation of group operations on Ristretto and Curve25519☆1,206Sep 24, 2026Updated last month
- ☆33Updated this week
- Protobuf Debugging Suite☆16Oct 23, 2026Updated last week
- Collection of cryptography-related traits☆759Updated this week
- Fuzzer to automatically find side-channel (timing) vulnerabilities☆123Sep 19, 2026Updated last month