golang implementation of https://json-schema.org drafts 7 & 2019-09
☆480Dec 18, 2024Updated last year
Alternatives and similar repositories for jsonschema
Users that are interested in jsonschema are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- JSONSchema (draft 2020-12, draft 2019-09, draft-7, draft-6, draft-4) Validation using Go☆1,286Sep 21, 2026Updated 3 weeks ago
- An implementation of JSON Schema, draft v4 v6 & v7 - Go language☆2,739Jun 28, 2024Updated 2 years ago
- Maintenance has moved to https://github.com/invopop/jsonschema☆742Feb 16, 2022Updated 4 years ago
- Generates Go (golang) Structs from JSON schema.☆453Apr 2, 2024Updated 2 years ago
- A tool to generate Go data types from JSON Schema definitions.☆809Updated this week
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- golang implementation of IETF RFC6901: https://tools.ietf.org/html/rfc6901☆16May 7, 2020Updated 6 years ago
- Generate JSON Schemas from Go types☆960Apr 23, 2026Updated 5 months ago
- OpenAPI 3.0 and 3.1 and 3.2 (and Swagger v2) implementation for Go (parsing, converting, validation, and more)☆3,299Updated this week
- A Go library to apply RFC6902 patches and create and apply RFC7386 patches☆1,231Dec 15, 2025Updated 10 months ago
- Mergo: merging Go structs and maps since 2013☆3,108Aug 24, 2026Updated last month
- A parser library for Go☆3,893Oct 8, 2026Updated last week
- Validate Go Datastructures Based on How Similar They Look☆27Aug 11, 2026Updated 2 months ago
- Go library for JSON Schema Draft 2020-12 validation with enhanced outputs and multilingual error messages☆227Sep 14, 2026Updated last month
- Expression language and expression evaluation for Go☆8,042Jul 7, 2026Updated 3 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- JSON Schema mapping for Go☆191Nov 10, 2025Updated 11 months ago
- Execute JavaScript from Go☆3,498Aug 2, 2024Updated 2 years ago
- Package for comparing Go values in tests☆4,678Jun 18, 2026Updated 3 months ago
- Go error library with error portability over the network☆2,475Sep 26, 2026Updated 2 weeks ago
- A high-level interface for interacting with a Git subprocess in Go☆25Nov 3, 2024Updated last year
- Fast, portable, non-Turing complete expression evaluation with gradual typing (Go)☆3,121Updated this week
- A high performance memory-bound Go cache☆7,005Sep 21, 2026Updated 3 weeks ago
- Database migrations. CLI and Golang library.☆18,969Sep 9, 2026Updated last month
- Set JSON values very quickly in Go☆2,736May 19, 2026Updated 4 months ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Useful template functions for Go templates.☆4,746Jul 18, 2025Updated last year
- Jennifer is a code generator for Go☆3,631Oct 7, 2026Updated last week
- An entity framework for Go☆17,208Updated this week
- Fast key-value DB in Go.☆15,785Updated this week
- RocksDB/LevelDB inspired key-value database in Go☆6,057Updated this week
- Universally Unique Lexicographically Sortable Identifier (ULID) in Go☆5,047Jul 23, 2026Updated 2 months ago
- Go library for decoding generic map values into native Go structures and vice versa.☆8,016Jun 25, 2024Updated 2 years ago
- Get JSON values quickly - JSON parser for Go☆15,554Oct 5, 2026Updated last week
- Fast linters runner for Go☆19,439Updated this week
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Compile-time Dependency Injection for Go☆14,387Aug 22, 2025Updated last year
- Unified diff parser and printer for Go☆467Sep 14, 2026Updated last month
- Embed static files in Go binaries (replacement for gobuffalo/packr)☆1,181Aug 27, 2021Updated 5 years ago
- An embedded key/value database for Go.☆9,778Updated this week
- Design-first Go framework that generates API code, documentation, and clients. Define once in an elegant DSL, deploy as HTTP and gRPC ser…☆6,110Updated this week
- 🔥 Fast, strict, configurable, extensible, and beautiful linter for Go☆5,553Updated this week
- Building event-driven applications the easy way in Go.☆9,914Aug 25, 2026Updated last month