A Python Implementation of RFC3986 including validations
☆189Oct 19, 2026Updated last week
Alternatives and similar repositories for rfc3986
Users that are interested in rfc3986 are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A pure-Python, bring-your-own-I/O implementation of HTTP/1.1☆571Apr 24, 2025Updated last year
- Chromium HSTS Preload list as a Python package and updated daily.☆14Oct 1, 2026Updated last month
- SPDY for Lovers☆14Nov 8, 2013Updated 12 years ago
- Internationalized Domain Names for Python (IDNA 2008 and UTS #46)☆299Updated this week
- JSON-RPC implementation for Starlette framework☆27Jul 27, 2023Updated 3 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5☆56Aug 24, 2026Updated 2 months ago
- Pure-Python HTTP/2 header encoding☆81Updated this week
- A tiny application for understanding ASGI scope☆12Apr 9, 2020Updated 6 years ago
- MVP for updated PEP 543 proposal☆14Oct 23, 2026Updated last week
- 🔗 Immutable, Pythonic, correct URLs.☆297Mar 20, 2026Updated 7 months ago
- A minimal HTTP client. ⚙️☆551Jan 8, 2026Updated 9 months ago
- A unifying library for curio and trio, supporting both async libs for great good.☆57Aug 8, 2019Updated 7 years ago
- Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)☆46Jan 11, 2024Updated 2 years ago
- Aspirational stuff☆15May 30, 2017Updated 9 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Multi-tenant IRC bouncer (BNC), written in Go.☆14Sep 13, 2015Updated 11 years ago
- See https://github.com/django/django-docker-box☆22May 27, 2019Updated 7 years ago
- certifi-system-store, a certifi hack to use system trust store on Linux and FreeBSD☆15Jul 22, 2024Updated 2 years ago
- A simple tool that generates certificates for local testing☆35Feb 11, 2021Updated 5 years ago
- Python builder for ASGI applications on Zeit Now☆14Jun 24, 2022Updated 4 years ago
- Python bindings to the Brotli compression library☆156Oct 21, 2026Updated last week
- ☆28Oct 13, 2025Updated last year
- work in progress☆19Feb 7, 2014Updated 12 years ago
- ASGI middleware for protecting against CSRF attacks☆67Nov 15, 2024Updated last year
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- ASGI support for the Tartiflette GraphQL engine☆99Jun 26, 2023Updated 3 years ago
- Implementation of the ASGI application standard as a Twisted Resource☆11May 7, 2020Updated 6 years ago
- [No maintenance intended] Proof of concept lightweight HTTP/1.1 proxy service built with ASGI and HTTPX.☆30Sep 26, 2021Updated 5 years ago
- Pure-Python HTTP/2 framing☆68Apr 10, 2026Updated 6 months ago
- Modular, way of implementing rate-limiting in python with a few handy default implementations☆65Mar 27, 2023Updated 3 years ago
- URI template parsing per RFC6570☆246Oct 19, 2026Updated last week
- Public discussions for the Python HTTP Working Group☆12Jul 9, 2019Updated 7 years ago
- A small library that makes the OS X keychain-based certificate store available to OpenSSL in a format that OpenSSL appreciates.☆25May 8, 2021Updated 5 years ago
- Python interface to picohttpparser☆21Feb 16, 2017Updated 9 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Network protocol implementations in Python, sans I/O☆160Oct 3, 2025Updated last year
- Static file management for everyone.☆20Mar 7, 2013Updated 13 years ago
- Approximate query counts for MySQL and Django.☆11Jan 10, 2020Updated 6 years ago
- Making it easy to write async iterators in Python 3.5☆104Aug 24, 2020Updated 6 years ago
- Sniff out which async library your code is running under☆155Mar 6, 2026Updated 7 months ago
- Sentry integration for ASGI frameworks.☆73Sep 27, 2019Updated 7 years ago
- Fully featured API wrapper for coinbin.org☆12Sep 1, 2017Updated 9 years ago