simple package build system for ocaml
☆55Sep 4, 2026Updated last month
Alternatives and similar repositories for obuild
Users that are interested in obuild are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Ocamlbuild helpers for C stubs☆12Oct 24, 2018Updated 8 years ago
- ocaml inotify binding☆12Feb 1, 2013Updated 13 years ago
- small tool to create OCaml software bundles from OPAM packages, superseded by builtin functionality in opam 2☆18Aug 8, 2015Updated 11 years ago
- HTTP toolkit for OCaml (unreleased)☆19Aug 14, 2026Updated 2 months ago
- Complete, typesafe representation of Vega-Lite in OCaml☆10Nov 13, 2017Updated 8 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- A collection of tools to manage the configuration of OCaml projects☆53Aug 19, 2015Updated 11 years ago
- OpenType font decoder for OCaml☆20Aug 13, 2026Updated 2 months ago
- Semantic version handling for OCaml☆18Apr 15, 2021Updated 5 years ago
- s-expression codecs and updates for OCaml☆12Mar 23, 2017Updated 9 years ago
- OCaml library for resizable arrays and strings☆26Jun 23, 2026Updated 4 months ago
- Precise POSIX clock for OCaml☆15Mar 14, 2019Updated 7 years ago
- Monad syntax using ppx extensions☆18Mar 29, 2013Updated 13 years ago
- Profiling library☆14Jul 10, 2026Updated 3 months ago
- Index your filesystem to find duplicates☆13Mar 28, 2019Updated 7 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- OCaml implementation of sets as hash tables by Jean-Christophe Filliatre☆11Feb 13, 2025Updated last year
- Portable clock implementation for Unix and Xen☆17Apr 24, 2024Updated 2 years ago
- Performance Application Programming Interface for OCaml☆15Oct 25, 2022Updated 4 years ago
- Lwt-enabled distributed computing library☆42Dec 9, 2022Updated 3 years ago
- Future values for asynchronous programming in OCaml (unreleased)☆20Jun 18, 2020Updated 6 years ago
- Relational programming for OCaml (unreleased)☆24Jun 6, 2022Updated 4 years ago
- Lookup and load installed OCaml modules☆17Aug 13, 2026Updated 2 months ago
- Dynamic loader for OCaml☆14Dec 11, 2009Updated 16 years ago
- Inspection of internal value representations and the object graph☆33Aug 2, 2016Updated 10 years ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Moana implementation in OCaml☆16Jul 15, 2015Updated 11 years ago
- (DEPRECATED) Documentation generation for OCaml☆13Jul 16, 2018Updated 8 years ago
- Making unicode in ocaml great again☆14Apr 27, 2018Updated 8 years ago
- Sandboxed build environment for opam projects☆13Mar 2, 2016Updated 10 years ago
- Lwt-compatible IMAP4rev1 client library for OCaml☆41Dec 29, 2020Updated 5 years ago
- Easy OCaml scripts (unreleased)☆20Aug 13, 2026Updated 2 months ago
- OCaml bindings for clang☆24May 1, 2018Updated 8 years ago
- Data visualization and plotting for OCaml☆19Nov 28, 2017Updated 8 years ago
- OCaml CBOR generic decoder/encoder, RFC 7049, http://cbor.io/☆25Feb 7, 2022Updated 4 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Procord is a portable OCaml library to delegate tasks to other processes.☆27Sep 2, 2014Updated 12 years ago
- Basic OS interaction for OCaml☆72Aug 13, 2026Updated 2 months ago
- Distribute/marshal instances of ocaml extensible variant types and exceptions☆16Nov 26, 2016Updated 9 years ago
- Basic templates for new OCaml projects☆14Oct 19, 2017Updated 9 years ago
- SOCKS4a and SOCKS5 (RFC 1928; RFC 1929) handling for ocaml clients and servers☆20Jul 9, 2023Updated 3 years ago
- A safer C FFI for OCaml☆18Dec 13, 2018Updated 7 years ago
- ZIP archive and deflate codec for OCaml☆21Updated this week