CoreRAD is an extensible and observable IPv6 Neighbor Discovery Protocol router advertisement daemon. Apache 2.0 Licensed.
☆172Oct 20, 2026Updated last week
Alternatives and similar repositories for corerad
Users that are interested in corerad are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Package ethtool allows control of the Linux ethtool generic netlink interface. MIT Licensed.☆76Aug 1, 2026Updated 2 months ago
- Prometheus exporter/bridge for local services☆14Nov 27, 2022Updated 3 years ago
- Fast, multithreaded, modular and extensible DHCP server written in Go☆1,106Apr 13, 2026Updated 6 months ago
- Package rfc4193 implements Unique Local IPv6 Unicast Address prefix generation, as described in RFC 4193. MIT Licensed.☆13May 12, 2020Updated 6 years ago
- Package ndp implements the Neighbor Discovery Protocol, as described in RFC 4861. MIT Licensed.☆238Oct 16, 2026Updated 2 weeks ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- Package genetlink implements generic netlink interactions and data types. MIT Licensed.☆67Jun 3, 2026Updated 4 months ago
- Package netlink provides low-level access to Linux netlink sockets (AF_NETLINK). MIT Licensed.☆1,085Oct 14, 2026Updated 2 weeks ago
- ☆33Nov 21, 2018Updated 7 years ago
- Package ospf3 implements OSPFv3 (OSPF for IPv6) as described in RFC5340. MIT Licensed.☆20Feb 2, 2021Updated 5 years ago
- DHCPv6 and DHCPv4 packet library, client and server written in Go☆849Oct 14, 2026Updated 2 weeks ago
- Using nfqueue to accept or drop flows destined for SNI domainnames☆21Feb 24, 2025Updated last year
- Package wifiqr implements support for generating WiFi QR codes. MIT Licensed.☆14Oct 1, 2024Updated 2 years ago
- Package packet provides access to Linux packet sockets (AF_PACKET). MIT Licensed.☆108Sep 12, 2026Updated last month
- Command consrv is a SSH to serial console bridge server, originally designed for deployment on gokrazy.org devices. Apache 2.0 Licensed.☆152Oct 3, 2026Updated 3 weeks ago
- Bare Metal GPUs on DigitalOcean Gradient AI • AdPurpose-built for serious AI teams training foundational models, running large-scale inference, and pushing the boundaries of what's possible.
- Package vsock provides access to Linux VM sockets (AF_VSOCK) for communication between a hypervisor and its virtual machines. MIT Licens…☆396Oct 15, 2026Updated 2 weeks ago
- A DBus client implementation in Go.☆18Feb 4, 2025Updated last year
- Package rtnetlink provides low-level access to the Linux rtnetlink API. MIT Licensed.☆174Oct 12, 2026Updated 2 weeks ago
- GArLIC: GolAng LInux Connector: A Proc Connector library for go☆27Jun 28, 2021Updated 5 years ago
- zedhook provides a ZEDLET (ZFS Event Daemon Linkage for Executable Tasks) and zevent receiver server to monitor and log ZFS events produc…☆18Apr 29, 2022Updated 4 years ago
- Network address types☆718May 25, 2023Updated 3 years ago
- Shotizam analyzes the size of Go binaries☆613Sep 30, 2026Updated last month
- Package wgdynamic implements a client and server for the the wg-dynamic protocol. MIT Licensed.☆13Feb 25, 2023Updated 3 years ago
- A fully Go userland with Linux bootloaders! u-root can create a one-binary root file system (initramfs) containing a busybox-like set of …☆3,082Updated this week
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A pure-Go library for Linux device mapper target management☆24Mar 15, 2026Updated 7 months ago
- router7 is a small home internet router completely written in Go. It is implemented as a gokrazy appliance.☆2,772Jul 19, 2026Updated 3 months ago
- Package schedgroup provides a goroutine worker pool which schedules tasks to be performed at or after a specified time. MIT Licensed.☆139Apr 6, 2022Updated 4 years ago
- Service for interacting with BMCs☆110Nov 20, 2025Updated 11 months ago
- Local file-based atomic cache manager☆48Oct 20, 2026Updated last week
- Package raw enables reading and writing data at the device driver level for a network interface. MIT Licensed.☆423Feb 21, 2022Updated 4 years ago
- Instance Metadata Service☆118Dec 2, 2025Updated 10 months ago
- Heap dump reader & visualizer for Go 1.4☆47Jan 25, 2016Updated 10 years ago
- Command wgipamd implements an IP Address Management (IPAM) daemon for dynamic IP address assignment to WireGuard peers, using the wg-dyna…☆30Jan 2, 2020Updated 6 years ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- benchmarks for some golang IP routing table implementations☆19Updated this week
- SIIT and NAT64 for Linux☆416Updated this week
- Package tftp implements a TFTP server, as described in RFC 1350. MIT Licensed.☆11Jun 19, 2015Updated 11 years ago
- A comprehensive Tailscale Prometheus exporter that combines API metadata with live device metrics for complete network observability.☆17Oct 21, 2026Updated last week
- Tinkerbell User Documentation Website☆14Mar 12, 2024Updated 2 years ago
- Get LetsEncrypt TLS certs for internal-only TLS servers via a delegated golang.org/x/crypto/acme/autocert server.☆252Mar 6, 2020Updated 6 years ago
- The semantic desktop search engine☆30Aug 13, 2021Updated 5 years ago