A Go language client for the NAT-PMP internet protocol for port mapping and discovering the external IP address of a firewall.
☆137Sep 4, 2026Updated 2 months ago
Alternatives and similar repositories for go-nat-pmp
Users that are interested in go-nat-pmp are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- UPnP client library for Go (#golang)☆464Updated this week
- A golang library for discovering the address of a LAN gateway.☆250Sep 4, 2026Updated 2 months ago
- NAT port mapping library for Go☆45Feb 13, 2020Updated 6 years ago
- An opinionated interface to your local Internet Gateway Device.☆78Dec 3, 2018Updated 7 years ago
- A go implementation of the STUN client (RFC 3489 and RFC 5389)☆721Oct 12, 2026Updated 3 weeks ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- NAT port mapping library for Go☆22Aug 21, 2025Updated last year
- A(nother) Bittorrent client written in the go programming language☆844Sep 4, 2026Updated 2 months ago
- Kademlia/Mainline DHT node in Go.☆831Dec 26, 2020Updated 5 years ago
- Go implementation of bcrypt_pbkdf(3) from OpenBSD☆15Jun 27, 2026Updated 4 months ago
- Port mapping library for Go supporting NAT-PMP and UPnP☆40May 29, 2024Updated 2 years ago
- Golang wrappers of the C libvnc library//libvncserver.sourceforge.net/☆11Jan 8, 2014Updated 12 years ago
- Use anacrolix/go-libutp instead☆179Sep 8, 2026Updated last month
- An implementation of a libp2p transport using utp☆12Jul 16, 2021Updated 5 years ago
- A simple implements UPnP protocol for Go(Golang) library. Add port mapping for NAT devices. 在内网中搜索网关设备,检查网关是否支持upnp协议,若支持,添加端口映射。☆157Apr 29, 2022Updated 4 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- go implementation of ICE( RFC 5245)☆14Jul 3, 2018Updated 8 years ago
- An example libp2p project that uses a Kademlia DHT for peer discovery and performs rpc calls.☆22Jan 20, 2021Updated 5 years ago
- Implementation of libsodium's secretstream in Go☆23Sep 11, 2026Updated last month
- Allows run time configuration of Go's pprof features and default HTTP mux using environment variables.☆21Sep 25, 2026Updated last month
- A pure go implementation of the KVM API☆12Feb 4, 2019Updated 7 years ago
- DNS-over-TLS (DOT) resolvers for Go☆15Aug 21, 2024Updated 2 years ago
- Go sqlite3 cache☆21Sep 8, 2026Updated last month
- A tool collection about BitTorrent.☆13Mar 4, 2023Updated 3 years ago
- an object to manage sets of peers, their addresses and other metadata☆89Aug 19, 2022Updated 4 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- A BIP0039 implementation in Go☆10Apr 13, 2026Updated 6 months ago
- A pure-go implementation of the Axolotl Ratchet, extracted from pond☆21Feb 8, 2017Updated 9 years ago
- Simple OS keychain bindings for password storage in Go (Golang)☆25May 16, 2017Updated 9 years ago
- Minimal Go UPnP InternetGatewayDevice library☆12Jul 14, 2020Updated 6 years ago
- A decentralized P2P networking stack written in Go.☆1,834Feb 25, 2023Updated 3 years ago
- A Go language binding for encoding and decoding data in the bencode format that is used by the BitTorrent peer-to-peer file sharing proto…☆292Oct 11, 2026Updated 3 weeks ago
- A small UPnP client☆11Apr 1, 2015Updated 11 years ago
- Peer to Peer Library based on Noise Secure Handshake☆18Apr 23, 2024Updated 2 years ago
- Measure and throttle the rate at which data is transferred.☆261Jun 17, 2024Updated 2 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Performance focused HTTP & UDP BitTorrent tracker☆33Aug 2, 2026Updated 3 months ago
- Go implementation of a Kademlia distributed hash table☆162Jan 30, 2022Updated 4 years ago
- ☆42Mar 19, 2026Updated 7 months ago
- Go library and CLI tool for /dns4, /dns6, /dnsaddr multiaddr resolution☆32Jul 17, 2026Updated 3 months ago
- Pure Go Wayland protocol implementation.☆10Feb 16, 2026Updated 8 months ago
- dht is used by anacrolix/torrent, and is intended for use as a library in other projects both torrent related and otherwise☆363Sep 24, 2026Updated last month
- Composable and future-proof network addresses☆299Feb 23, 2026Updated 8 months ago