☆340Jan 25, 2025Updated last year
Alternatives and similar repositories for pgtype
Users that are interested in pgtype are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- ☆194Jan 25, 2025Updated last year
- PostgreSQL driver and toolkit for Go☆14,373Updated this week
- Package pgerrcode contains constants for PostgreSQL error codes.☆237Sep 7, 2025Updated last year
- Library for scanning data from a database into Go structs and more☆1,525Mar 19, 2025Updated last year
- Package pgio is a low-level toolkit building messages in the PostgreSQL wire protocol.☆15Mar 30, 2019Updated 7 years ago
- Managed Database hosting by DigitalOcean • AdPostgreSQL, MySQL, MongoDB, Kafka, Valkey, and OpenSearch available. Automatically scale up storage and focus on building your apps.
- ☆172Jan 25, 2025Updated last year
- The SQL Fan's Migrator☆1,338Aug 23, 2026Updated 2 months ago
- Go PostgreSQL driver for database/sql☆9,972Aug 20, 2026Updated 2 months ago
- Fluent SQL generation for golang☆7,988Apr 24, 2024Updated 2 years ago
- Database migrations. CLI and Golang library.☆19,000Sep 9, 2026Updated last month
- PostgreSQL logical replication library for Go.☆552Oct 3, 2026Updated 3 weeks ago
- Go package for UUIDs based on RFC 4122 and DCE 1.1: Authentication and Security Services.☆6,152Nov 14, 2024Updated last year
- Golang ORM with focus on PostgreSQL features and performance☆5,777Jul 10, 2026Updated 3 months ago
- Universally Unique Lexicographically Sortable Identifier (ULID) in Go☆5,049Updated this week
- Virtual machines for every use case on DigitalOcean • AdGet dependable uptime with 99.99% SLA, simple security tools, and predictable monthly pricing with DigitalOcean's virtual machines, called Droplets.
- Arbitrary-precision fixed-point decimal numbers in Go☆7,510Updated this week
- A Go (golang) package for representing a list of errors as a single error.☆2,591Oct 14, 2026Updated 2 weeks ago
- Go library to parse and normalize SQL queries using the PostgreSQL query parser☆866Oct 1, 2026Updated last month
- general purpose extensions to golang's database/sql☆17,742Aug 15, 2024Updated 2 years ago
- Generate type-safe Go for any Postgres query. If Postgres can run the query, pggen can generate code for it.☆317Mar 14, 2025Updated last year
- Golang linter to check the errors handling expressions☆76Jul 20, 2026Updated 3 months ago
- Goroutine leak detector☆5,301Sep 15, 2026Updated last month
- Go Struct and Field validation, including Cross Field, Cross Struct, Map, Slice and Array diving☆20,215Updated this week
- Fast linters runner for Go☆19,491Updated this week
- GPUs on demand by Runpod - Special Offer Available • AdRun AI, ML, and HPC workloads on powerful cloud GPUs—without limits or wasted spend. Deploy GPUs in under a minute and pay by the second.
- Generate type-safe code from SQL☆18,428Updated this week
- Write better integration tests! Dockertest helps you boot up ephermal docker images for your Go tests with minimal work.☆4,530Oct 23, 2026Updated last week
- A mock code autogenerator for Go☆7,174Updated this week
- Blazing fast, structured, leveled logging in Go.☆24,683Sep 16, 2026Updated last month
- Generates Go code that matches your Postgres tables☆15Jun 6, 2018Updated 8 years ago
- intrange is a program for checking for loops that could use the Go 1.22 integer range feature.☆38Oct 30, 2025Updated last year
- go generate based graphql server library☆10,769Oct 22, 2026Updated last week
- pgundolog is a system for rolling back changes to a PostgreSQL database without using transactions.☆10Sep 4, 2026Updated last month
- Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643☆98Aug 9, 2026Updated 2 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- ☆15Jan 24, 2022Updated 4 years ago
- Zero Allocation JSON Logger☆12,526Oct 14, 2026Updated 2 weeks ago
- A toolkit with common assertions and mocks that plays nicely with the standard library☆26,241Oct 19, 2026Updated 2 weeks ago
- Sql mock driver for golang to test database interactions☆6,573Jul 10, 2026Updated 3 months ago
- Testcontainers for Go is a Go package that makes it simple to create and clean up container-based dependencies for automated integration/…☆5,020Updated this week
- Package for comparing Go values in tests☆4,682Updated this week
- Go linter that checks if package imports are in a list of acceptable packages.☆204Updated this week