RFC 6902 (JSON Patch) / RFC 7396 (JSON Merge Patch) implementation for Rust
☆183Apr 30, 2026Updated 6 months ago
Alternatives and similar repositories for json-patch
Users that are interested in json-patch are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Generate JSON Schema documents from Rust code☆1,424Oct 12, 2026Updated 2 weeks ago
- JSON Pointer (RFC 6901) implementation for Rust☆50Aug 20, 2026Updated 2 months ago
- Extract differences between arbitrary datastructures☆93Mar 27, 2024Updated 2 years ago
- Traits and functions to make writing proc macros more ergonomic.☆22Jun 27, 2023Updated 3 years ago
- This crate provides custom de/serialization helpers to use in combination with serde's `with`-annotation and with the improved `serde_as`…☆868Updated this week
- Proton VPN Special Offer - Get 70% off • AdSpecial partner offer. Trusted by over 100 million users worldwide. Tested, Approved and Recommended by Experts.
- http range responses for axum☆14Sep 16, 2025Updated last year
- 🦑 Async Rust RPC and IPC where calls can pass live channels and remote objects over a single multiplexed connection.☆256Updated this week
- Asynchronous streams for Rust using async & await notation☆780Sep 5, 2026Updated last month
- A low-level MVCC file format for storing blobs.☆66Mar 6, 2024Updated 2 years ago
- Rust cache structures and easy function memoization☆2,097Oct 22, 2026Updated last week
- JOSE (JSON Web Token) Library for Rust☆188Apr 5, 2026Updated 6 months ago
- A parser and formatter for std::{SystemTime, Duration}☆401Oct 7, 2026Updated 3 weeks ago
- Async multi-producer multi-consumer channel☆948Jul 13, 2026Updated 3 months ago
- A library for creating references that carry their owner with them.☆388Oct 12, 2023Updated 3 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Wayland proxy that filters/modifies requests☆17Sep 20, 2026Updated last month
- Reusable post-processing effects for wgpu☆13Sep 13, 2024Updated 2 years ago
- Type erasure for async trait methods☆2,207Sep 21, 2026Updated last month
- Wrapper around reqwest to allow for client middleware chains.☆382May 19, 2026Updated 5 months ago
- Serde-based replacement for #[derive(Debug)]☆69Sep 30, 2024Updated 2 years ago
- Google Oauth Client Written in Rust☆39Dec 3, 2025Updated 10 months ago
- Pure Rust implementation of Javascript Object Signing and Encryption (JOSE)☆74Sep 5, 2025Updated last year
- A library for higher order functional programming with homotopy maps to construct 3D geometry☆15Oct 8, 2026Updated 3 weeks ago
- ↕️ Simple database schema migration library for rusqlite, written with performance in mind.☆117Updated this week
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Temporary file library for rust☆1,473Updated this week
- A high performance concurrent caching library for Rust☆2,717Aug 9, 2026Updated 2 months ago
- Rust JSON Schema validator and JSON coercer☆305Mar 7, 2024Updated 2 years ago
- Blazing fast concurrent HashMap for Rust.☆4,124Oct 21, 2026Updated last week
- Some more derive(Trait) options☆2,152Sep 7, 2026Updated last month
- TARGET and HOST tuples☆18Sep 8, 2026Updated last month
- An extensible Statsd client for Rust☆101Aug 26, 2026Updated 2 months ago
- Versioned data-structures for Rust☆208Feb 26, 2025Updated last year
- Converts a flat-tree to a string.☆18Jul 5, 2021Updated 5 years ago
- End-to-end encrypted cloud storage - Proton Drive • AdSpecial offer: 40% Off Yearly / 80% Off First Month. Protect your most important files, photos, and documents from prying eyes.
- Small crate for interacting with cargo registry indices☆31Oct 23, 2026Updated last week
- A certificate verification library for rustls that uses the operating system's verifier☆160Oct 1, 2026Updated 3 weeks ago
- Simple, Fast, Code first and Compile time generated OpenAPI documentation for Rust☆4,130Oct 20, 2026Updated last week
- Rust KTX texture storage format parsing☆11Aug 30, 2026Updated 2 months ago
- ☆17Aug 18, 2026Updated 2 months ago
- Compile-time type-checked builder derive☆1,204Aug 1, 2026Updated 2 months ago
- A high-performance JSON Schema validator for Rust☆830Updated this week