↕️ Simple database schema migration library for rusqlite, written with performance in mind.
☆115Oct 2, 2026Updated last week
Alternatives and similar repositories for rusqlite_migration
Users that are interested in rusqlite_migration are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Serialize/deserialize rusqlite rows☆102May 27, 2026Updated 4 months ago
- Ergonomic bindings to SQLite for Rust☆4,430Sep 25, 2026Updated 2 weeks ago
- r2d2 connection pool for sqlite☆135Sep 5, 2026Updated last month
- "Valgrind Client Request" interface for Rust☆24Updated this week
- prae is a crate that aims to provide a better way to define types that require validation.☆136Jan 31, 2023Updated 3 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- ☆44Mar 18, 2025Updated last year
- Tiny little crate to determine how large an unnameable type is.☆12Mar 29, 2025Updated last year
- Imitate the documentation build that docs.rs would do☆77Sep 30, 2026Updated last week
- Relational Database Server with Integrated Version Control☆23Dec 20, 2022Updated 3 years ago
- A flat container abstraction for Rust☆17Nov 24, 2025Updated 10 months ago
- RFC 6902 (JSON Patch) / RFC 7396 (JSON Merge Patch) implementation for Rust☆183Apr 30, 2026Updated 5 months ago
- Checksum of a directory tree☆48Jun 24, 2026Updated 3 months ago
- Job Queue based on SQLite☆48Jul 23, 2024Updated 2 years ago
- Make RSS great again☆13Jan 24, 2021Updated 5 years ago
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- High level Lean 4 FFI for Rust☆14Mar 16, 2024Updated 2 years ago
- An implementation of Piet's text interface using cosmic-text☆15Apr 23, 2024Updated 2 years ago
- Compile-time temporary directory shared by multiple crates and erased by `cargo clean`☆79Jun 24, 2026Updated 3 months ago
- Interned string and more for rust☆10Dec 29, 2021Updated 4 years ago
- ☆12Oct 31, 2024Updated last year
- Serial Line Interface Protocol (SLIP) encoder/decoder with Rust std::{Read, Write} interfaces.☆12Oct 27, 2023Updated 2 years ago
- Learn FoundationDB☆16Jul 22, 2025Updated last year
- Query string parser☆15Apr 29, 2021Updated 5 years ago
- A Rust Vector which swaps to disk based on given parameters☆45Nov 29, 2023Updated 2 years ago
- Wordpress hosting with auto-scaling - Free Trial Offer • AdFully Managed hosting for WordPress and WooCommerce businesses that need reliable, auto-scalable performance. Cloudways SafeUpdates now available.
- Efficient reference counted vector data structure is Rust☆21Aug 3, 2026Updated 2 months ago
- A lidera japanese tokenizer wrapper for javascript and typescript☆16Dec 29, 2021Updated 4 years ago
- A YAML representation library which explicitly retains provenance data☆20May 26, 2025Updated last year
- Serde with Validation☆72Aug 25, 2026Updated last month
- Webdriver client library☆15Dec 9, 2022Updated 3 years ago
- A parser for API Set Map files of Windows 10 and later☆19Jun 9, 2023Updated 3 years ago
- A cache that holds a limited number of key-value pairs☆86Apr 16, 2022Updated 4 years ago
- Map rusqlite rows to structs☆16May 1, 2024Updated 2 years ago
- An easy-to-use, incremental, multi-threaded garbage collector for Rust☆12Aug 11, 2024Updated 2 years ago
- Deploy open-source AI quickly and easily - Special Bonus Offer • AdRunpod Hub is built for open source. One-click deployment and autoscaling endpoints without provisioning your own infrastructure.
- Unbuffered and unlocked I/O streams☆45Mar 7, 2025Updated last year
- impl fallible collections in rust, quite as describe in RFC 2116☆41Jun 5, 2026Updated 4 months ago
- This week in Databend: an elastic and reliable cloud warehouse☆25Mar 6, 2023Updated 3 years ago
- Rust implementation of Stream VByte decompression algorithm☆16May 23, 2023Updated 3 years ago
- Why can't a tree be called Pluplusch?☆28Sep 27, 2026Updated last week
- GitHub Action to setup Problem Matchers for Rust.☆18Apr 9, 2026Updated 6 months ago
- Rust crate for making Read streams peekable.☆27Aug 1, 2021Updated 5 years ago