An implementation of Messaging Layer Security (RFC 9420)
☆261Oct 28, 2026Updated this week
Alternatives and similar repositories for mls-rs
Users that are interested in mls-rs are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Rust implementation of the Messaging Layer Security (MLS) protocol☆1,058Updated this week
- MLS/Proteus multiplexer abstraction with encrypted persistent storage in Rust☆51Updated this week
- Coordination of implementation and interop specific details☆134Oct 19, 2026Updated last week
- An implementation of the DudeCT constant-time function tester☆30Mar 23, 2026Updated 7 months ago
- An implementation of the HPKE hybrid encryption standard (RFC 9180)☆101Oct 2, 2026Updated 3 weeks ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- aws-lc-rs is a cryptographic library using AWS-LC for its cryptographic operations. The library strives to be API-compatible with the pop…☆669Updated this week
- Collection of Key Encapsulation Mechanisms written in pure Rust☆120Updated this week
- I-D that describes the algorithm identifiers for NIST's PQC ML-DSA for use in the Internet X.509 Public Key Infrastructure☆14Oct 30, 2025Updated last year
- MLS protocol☆243Sep 10, 2024Updated 2 years ago
- An implementation of an auditable key directory☆336Aug 13, 2026Updated 2 months ago
- An implementation of a verifiable oblivious pseudorandom function (RFC 9497)☆88Apr 6, 2026Updated 6 months ago
- An implementation of Olm and Megolm in pure Rust.☆409Updated this week
- Certification path builder and validator library (certval) and utility (pittv3) to build and validate paths☆13Updated this week
- Post-Quantum Algorithms for HPKE☆13Jul 6, 2026Updated 3 months ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- Key transparency server☆38Oct 22, 2026Updated last week
- An Implementation of the MLS (Messaging Layer Security) Standard (RFC 9420) in Kotlin☆15Mar 15, 2024Updated 2 years ago
- Implementation of Messaging Layer Security☆155Sep 21, 2026Updated last month
- Pure Rust implementation of HPKE (https://www.rfc-editor.org/rfc/rfc9180.html)☆55Jul 21, 2026Updated 3 months ago
- An implementation of the OPAQUE password-authenticated key exchange protocol☆424Jun 23, 2026Updated 4 months ago
- Rust encryption library for practical time-lock encryption.☆40Jul 13, 2026Updated 3 months ago
- Air is a free and easy-to-use secure messaging app.☆84Updated this week
- Implementation of Prio in Rust.☆122Updated this week
- Implementation of bitswap protocol for libp2p☆19Feb 3, 2026Updated 8 months ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- A set of cryptographic proofs for simple protocols, to be formalised in various tools.☆28Oct 19, 2026Updated last week
- A protocol for autonomous communication between users☆18Oct 21, 2026Updated last week
- Rustls cryptography provider built on the pure Rust crates from the RustCrypto organization☆130Oct 23, 2026Updated last week
- A Rust verification tool☆489Updated this week
- Library and proc macro to analyze memory usage of data structures in rust.☆220Jun 14, 2026Updated 4 months ago
- shared library bindings & reference implementation of XMTP (X-tensible Message Transport Protocol)☆127Updated this week
- Community Cryptography Specification Project☆683Oct 22, 2026Updated last week
- Rust tool for generating FFI definitions allowing many other languages to call Rust code☆928Updated this week
- AES-GEM (AES Galois Extended Mode) implementation.☆14May 19, 2026Updated 5 months ago
- GPU virtual machines on DigitalOcean Gradient AI • AdGet to production fast with high-performance AMD and NVIDIA GPUs you can spin up in seconds. The definition of operational simplicity.
- The formally verified crypto library for Rust☆269Updated this week
- Domino: Computer-Assisted Game-Hopping for Large-Scale Protocols☆19Updated this week
- MLS architecture☆77Mar 31, 2025Updated last year
- Make AES-GCM safe to use with random nonces, for any practical number of messages.☆19Sep 16, 2025Updated last year
- A Safe #[no_std] ASN.1 Codec Framework☆389Oct 14, 2026Updated 2 weeks ago
- Replicated state machine for latency-critical applications. Rust, io_uring, DPDK, LMAX-inspired.☆26Oct 22, 2026Updated last week
- Cryptographic protocol analysis for real-world protocols.☆135Oct 20, 2026Updated last week