[Looking for new owners/maintainers, see #88] Rust implementation of Reed-Solomon erasure coding
☆219Aug 30, 2023Updated 3 years ago
Alternatives and similar repositories for reed-solomon-erasure
Users that are interested in reed-solomon-erasure are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- Reed-Solomon GF(2^16) erasure coding with O(n log n) complexity☆101Sep 5, 2026Updated last month
- Reed-Solomon BCH encoder and decoder with support of no_std environment☆47Nov 9, 2022Updated 3 years ago
- Novel polynomial basis for a reed solomon encoder☆39Oct 23, 2026Updated last week
- Reed-Solomon Erasure Coding in Go☆2,096Sep 25, 2026Updated last month
- Rust implementation of RaptorQ (RFC6330)☆398Oct 23, 2026Updated last week
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- Reed-Solomon Erasure Code engine in Go, could more than 15GB/s per core☆301Apr 2, 2026Updated 6 months ago
- A MPMC channel based on the two lock queue algorithm☆15Oct 4, 2017Updated 9 years ago
- Aggregatable BLS sigantures☆76Sep 29, 2026Updated last month
- Stateless Blockchain on Substrate using RSA Accumulators☆64Oct 20, 2026Updated last week
- Collection of universal hashing functions☆40Oct 13, 2026Updated 2 weeks ago
- Fast, efficient, and robust memory reclamation for Rust.☆481Sep 13, 2025Updated last year
- Schnorr VRFs and signatures on the Ristretto group☆335Aug 30, 2026Updated 2 months ago
- ☆12Feb 24, 2024Updated 2 years ago
- Rust bindings to @sipa's minisketch library☆23Jul 20, 2021Updated 5 years ago
- 1-Click AI Models by DigitalOcean Gradient • AdDeploy popular AI models on DigitalOcean Gradient GPU virtual machines with just a single click. Zero configuration with optimized deployments.
- pure rust io_uring library, built on libc, thread & async friendly, misuse resistant☆1,007Jun 27, 2022Updated 4 years ago
- Heap-based async timers☆220May 20, 2026Updated 5 months ago
- Free conversion between async and sync in Rust☆53Jun 25, 2022Updated 4 years ago
- Coded Merkle Tree☆25Aug 6, 2019Updated 7 years ago
- A pure Rust implementation of BLAKE2 based on RFC 7693.☆66Jun 14, 2025Updated last year
- A Rust implementation of the Strobe protocol framework☆28Sep 20, 2026Updated last month
- Certificate transparency SCT verification library in rust☆55Jun 22, 2026Updated 4 months ago
- A Rust implementation of the Noise Protocol Framework☆1,112Jul 6, 2026Updated 3 months ago
- rust wrapper for rocksdb☆2,187Aug 16, 2026Updated 2 months ago
- Serverless GPU API endpoints on Runpod - Get Bonus Credits • AdSkip the infrastructure headaches. Auto-scaling, pay-as-you-go, no-ops approach lets you focus on innovating your application.
- An implementation of the paper "Honey Badger of BFT Protocols" in Rust. This is a modular library of consensus.☆369Jan 6, 2024Updated 2 years ago
- Rust finite field library with fixed size multi-word values☆18Jul 2, 2026Updated 3 months ago
- Crate for gathering operating system information in os-agnostic way 🦀☆13Oct 29, 2021Updated 5 years ago
- Fork of std::Arc with lots of utilities useful for FFI☆304Oct 10, 2026Updated 2 weeks ago
- Secure storage for cryptographic secrets in Rust☆255Apr 13, 2026Updated 6 months ago
- An experiment.☆4,108Jul 23, 2026Updated 3 months ago
- ☆13Aug 23, 2023Updated 3 years ago
- Native Rust port of Google's HighwayHash, which makes use of SIMD instructions for a fast and strong hash function☆184Jul 25, 2026Updated 3 months ago
- Rust implementation of Miscreant: misuse-resistant encryption library with AES-SIV (RFC 5297) and AES-PMAC-SIV support☆45Feb 28, 2021Updated 5 years ago
- Managed Kubernetes at scale on DigitalOcean • AdDigitalOcean Kubernetes includes the control plane, bandwidth allowance, container registry, automatic updates, and more for free.
- BzTree implementation for Rust☆38Aug 19, 2025Updated last year
- Leopard-RS : O(N Log N) MDS Reed-Solomon Block Erasure Code for Large Data☆174Sep 17, 2026Updated last month
- Slab allocator for Rust☆949Aug 16, 2026Updated 2 months ago
- A websocket protocol implementation.☆99Updated this week
- Support for Linux kernel aio within Tokio.☆53Jul 26, 2021Updated 5 years ago
- Rust crate for managing CPU core affinities☆232Mar 1, 2025Updated last year
- Lightweight, event-driven WebSockets for Rust.☆14Oct 28, 2021Updated 5 years ago