a Common Lisp CFFI interface to the libgit2 library mirror https://sr.ht/~rsl/cl-git/
☆55Jan 18, 2023Updated 3 years ago
Alternatives and similar repositories for cl-git
Users that are interested in cl-git are comparing it to the libraries listed below. We may earn a commission when you buy through links labeled 'Ad' on this page.
Sorting:
- A Common Lisp library for reading archive (tar, cpio, etc.) files☆34Oct 10, 2017Updated 9 years ago
- A portable Common Lisp library for running external programs from within Lisp.☆70Dec 6, 2023Updated 2 years ago
- Osicat is a lightweight operating system interface for Common Lisp☆104Oct 7, 2025Updated last year
- A Common Lisp data structure representing tabular data (think CSVs and database results)☆31Jul 3, 2023Updated 3 years ago
- Why write programs in Common Lisp but tests like Java? Meet CheckL!☆47Mar 16, 2018Updated 8 years ago
- Deploy on Railway without the complexity - Free Credits Offer • AdConnect your repo and Railway handles the rest with instant previews. Quickly provision container image services, databases, and storage volumes.
- Ease common tasks at the REPL.☆50Feb 15, 2021Updated 5 years ago
- Automatic generator for ASDF's .asd files☆18Dec 21, 2018Updated 7 years ago
- Common Lisp I/O library☆153Apr 26, 2026Updated 6 months ago
- An extensible and high level FFI☆19May 17, 2012Updated 14 years ago
- A tool for investigating memory of a process on linux.☆18Aug 19, 2016Updated 10 years ago
- A common lisp package manager (like asdf-install or mudballs) with a focus on collaboration.☆14Jul 22, 2013Updated 13 years ago
- Produce a searchable archive of an author's Usenet articles☆13Jan 20, 2013Updated 13 years ago
- An implementation of RFC 2388 in Common Lisp☆15Aug 30, 2018Updated 8 years ago
- System for semi-automatically documenting Common Lisp packages.☆36May 20, 2018Updated 8 years ago
- Deploy to Railway using AI coding agents - Free Credits Offer • AdUse Claude Code, Codex, OpenCode, and more. Autonomous software development now has the infrastructure to match with Railway.
- Download files from Common Lisp through Drakma.☆39Jan 21, 2023Updated 3 years ago
- Containers Library for Common Lisp☆72Jun 24, 2024Updated 2 years ago
- Common Lisp library for manipulating date/time objects at a higher level☆35Aug 23, 2025Updated last year
- A Common Lisp library for computing differences between files☆29Aug 9, 2013Updated 13 years ago
- Implementation of red-black trees in Common Lisp, including a persistent red-black tree that uses an append-only strategy for recording c…☆10Oct 8, 2015Updated 11 years ago
- Common Lisp library for handling bit vectors, bit vector arithmetic, and type conversions.☆56Jul 8, 2022Updated 4 years ago
- Common Lisp promise implementation (successor to cl-async-future)☆95Mar 4, 2024Updated 2 years ago
- A Common Lisp program that transforms an s-expression based database schema format medium into appropriate SQL commands for specified RDB…☆15Apr 12, 2013Updated 13 years ago
- A common lisp library to unify access to common dictionary-like data-structures☆91Apr 15, 2025Updated last year
- Managed hosting for WordPress and PHP on Cloudways • AdManaged hosting for WordPress, Magento, Laravel, or PHP apps, on multiple cloud providers. Deploy in minutes on Cloudways by DigitalOcean.
- Some of my SBCL stuff, pending merging into the official tree. Any and all branches may be rebased/reset semi-randomly, so be warned!☆12Feb 2, 2013Updated 13 years ago
- zsort is a collection of portable sorting algorithms in Common Lisp.☆29Apr 23, 2012Updated 14 years ago
- A synonym for node. An evented framework for Common Lisp with API inspiration taken liberally from Node.js☆77Oct 17, 2015Updated 11 years ago
- A Common Lisp client library for the Docker Remote API☆15Jan 3, 2015Updated 11 years ago
- An (incomplete) Common Lisp implementation of the iCalendar RFC5545 specification.☆14Apr 19, 2019Updated 7 years ago
- Search Engine Interface for Common Lisp.☆54Apr 13, 2014Updated 12 years ago
- A simple mechanism to auto-load Lisp libraries from respositories.☆14Jun 10, 2018Updated 8 years ago
- Lockless skip lists for Common Lisp; well, for now sbcl 1.0.42 or higher. Contributions for other Lisps welcome. See the README file fo…☆19Apr 6, 2022Updated 4 years ago
- LIL: abstract interfaces and supporting concrete data-structures in Common Lisp☆154Sep 10, 2025Updated last year
- AI Agents on DigitalOcean Gradient AI Platform • AdBuild production-ready AI agents using customizable tools or access multiple LLMs through a single endpoint. Create custom knowledge bases or connect external data.
- eXtensible Component Verifier and Builder for Common-Lisp (mirrored from Common-Lisp.net) https://gitlab.common-lisp.net/xcvb/xcvb☆38Dec 24, 2020Updated 5 years ago
- Common Lisp implementation of a Slime / Swank client.☆91Jan 12, 2026Updated 9 months ago
- Common Lisp implementation of RFC 4122 -- not unlike UUID☆19Oct 6, 2021Updated 5 years ago
- Array slices for Common Lisp☆18May 14, 2021Updated 5 years ago
- Common Lisp JSON serializer written with simplicity in mind☆87Oct 17, 2026Updated 2 weeks ago
- An efficient and portable implementation of the Fast Fourier Transform in Common Lisp.☆14Jun 24, 2018Updated 8 years ago
- Various utilities to make use and creation of custom method combinations easier.☆24Dec 6, 2023Updated 2 years ago